summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-19 16:59:01 +0200
committerRemi Collet <remi@php.net>2022-07-19 16:59:01 +0200
commit422307309503d0ea280f3ce81a795efed796a157 (patch)
tree8ed3f903a640e9f8367fefed78667db0bddf2dcc
parent2c5dda92a017e33b8ec15bd27f408d2b55264230 (diff)
update to 2.18.1
add dependency on laminas-servicemanager
-rw-r--r--composer.json24
-rw-r--r--php-laminas-feed.spec35
2 files changed, 36 insertions, 23 deletions
diff --git a/composer.json b/composer.json
index 6ab3a4e..782622a 100644
--- a/composer.json
+++ b/composer.json
@@ -1,10 +1,12 @@
{
"name": "laminas/laminas-feed",
- "description": "provides functionality for consuming RSS and Atom feeds",
+ "description": "provides functionality for creating and consuming RSS and Atom feeds",
"license": "BSD-3-Clause",
"keywords": [
"laminas",
- "feed"
+ "feed",
+ "rss",
+ "atom"
],
"homepage": "https://laminas.dev",
"support": {
@@ -18,29 +20,33 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.3.99"
+ "php": "7.4.99"
+ },
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
}
},
"extra": {
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0",
+ "php": "^7.4 || ~8.0.0 || ~8.1.0",
"ext-dom": "*",
"ext-libxml": "*",
"laminas/laminas-escaper": "^2.9",
+ "laminas/laminas-servicemanager": "^3.14.0",
"laminas/laminas-stdlib": "^3.6"
},
"require-dev": {
- "laminas/laminas-cache": "^2.7.2",
- "laminas/laminas-coding-standard": "~2.2.1",
+ "laminas/laminas-cache": "^2.13.2 || ^3.1.3",
+ "laminas/laminas-cache-storage-adapter-memory": "^1.1.0 || ^2.0.0",
+ "laminas/laminas-coding-standard": "~2.3.0",
"laminas/laminas-db": "^2.13.3",
"laminas/laminas-http": "^2.15",
- "laminas/laminas-servicemanager": "^3.7",
"laminas/laminas-validator": "^2.15",
"phpunit/phpunit": "^9.5.5",
- "psalm/plugin-phpunit": "^0.13.0",
+ "psalm/plugin-phpunit": "^0.17.0",
"psr/http-message": "^1.0.1",
- "vimeo/psalm": "^4.1"
+ "vimeo/psalm": "^4.24.0"
},
"conflict": {
"laminas/laminas-servicemanager": "<3.3",
diff --git a/php-laminas-feed.spec b/php-laminas-feed.spec
index 5527bcd..0dcb195 100644
--- a/php-laminas-feed.spec
+++ b/php-laminas-feed.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 1ccb024ea615606ed1d676ba0fa3f22a398f3ac0
+%global gh_commit f2b852e88996fb9ffeaa862398505ce06afdbcc0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-feed
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.17.0
+Version: 2.18.1
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 7.4
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-dom
@@ -44,39 +44,40 @@ BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-tidy
# From composer, "require-dev": {
-# "laminas/laminas-cache": "^2.7.2",
-# "laminas/laminas-coding-standard": "~2.2.1",
+# "laminas/laminas-cache": "^2.13.2 || ^3.1.3",
+# "laminas/laminas-cache-storage-adapter-memory": "^1.1.0 || ^2.0.0",
+# "laminas/laminas-coding-standard": "~2.3.0",
# "laminas/laminas-db": "^2.13.3",
# "laminas/laminas-http": "^2.15",
# "laminas/laminas-servicemanager": "^3.7",
# "laminas/laminas-validator": "^2.15",
# "phpunit/phpunit": "^9.5.5",
-# "psalm/plugin-phpunit": "^0.13.0",
+# "psalm/plugin-phpunit": "^0.17.0",
# "psr/http-message": "^1.0.1",
-# "vimeo/psalm": "^4.1"
+# "vimeo/psalm": "^4.24.0"
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.5.5
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(psr/http-message) >= 1.0.1 with php-composer(psr/http-message) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.9 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.14.1 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.7.2 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.13.3 with php-autoloader(%{gh_owner}/laminas-db) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.15 with php-autoloader(%{gh_owner}/laminas-http) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.7 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.15 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
# remirepo:11
%else
BuildRequires: php-psr-http-message
BuildRequires: php-laminas-escaper
+BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-cache
BuildRequires: php-laminas-db
BuildRequires: php-laminas-http
-BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-validator
%endif
%endif
@@ -84,10 +85,11 @@ BuildRequires: php-laminas-validator
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
+# "php": "^7.4 || ~8.0.0 || ~8.1.0",
# "ext-dom": "*",
# "ext-libxml": "*",
# "laminas/laminas-escaper": "^2.9",
+# "laminas/laminas-servicemanager": "^3.14.0",
# "laminas/laminas-stdlib": "^3.2.1",
# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 7.3
@@ -98,7 +100,8 @@ Requires: php-libxml
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(psr/http-message) >= 1.0.1 with php-composer(psr/http-message) < 2)
Requires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.9 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.14.0 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
# "laminas/laminas-cache": "Laminas\\Cache component, for optionally caching feeds between requests",
@@ -110,12 +113,12 @@ Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
Suggests: php-autoloader(%{gh_owner}/laminas-cache)
Suggests: php-autoloader(%{gh_owner}/laminas-db)
Suggests: php-autoloader(%{gh_owner}/laminas-http)
-Suggests: php-autoloader(%{gh_owner}/laminas-servicemanager)
Suggests: php-autoloader(%{gh_owner}/laminas-validator)
-# remirepo:6
+# remirepo:7
%else
Requires: php-psr-http-message
Requires: php-laminas-escaper
+Requires: php-laminas-servicemanager
Requires: php-laminas-stdlib
Requires: php-laminas-zendframework-bridge
%endif
@@ -213,7 +216,7 @@ exit (class_exists("\\Zend\\%{library}\\Uri") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 -d memory_limit=1G ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -236,6 +239,10 @@ exit $ret
%changelog
+* Tue Jul 19 2022 Remi Collet <remi@remirepo.net> - 2.18.1-1
+- update to 2.18.1
+- add dependency on laminas-servicemanager
+
* Thu Mar 24 2022 Remi Collet <remi@remirepo.net> - 2.17.0-1
- update to 2.17.0 (no change)