summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-08-25 14:17:19 +0200
committerRemi Collet <remi@remirepo.net>2020-08-25 14:17:19 +0200
commit6a49887c24fd204c4c5b7bc902b364b2bddd6e6e (patch)
tree822a3cba5c76beb0eaa1af436adbcce7a029844c
parent210751c8af15c0d4fe79cba4e24cfd0182e1b2bd (diff)
update to 3.3.0
raise dependency on PHP 7.3 switch to phpunit 8.5
-rw-r--r--composer.json16
-rw-r--r--php-laminas-eventmanager.spec60
2 files changed, 41 insertions, 35 deletions
diff --git a/composer.json b/composer.json
index 6b25731..795b15a 100644
--- a/composer.json
+++ b/composer.json
@@ -22,23 +22,23 @@
},
"extra": {
"branch-alias": {
- "dev-master": "3.2-dev",
- "dev-develop": "3.3-dev"
+ "dev-master": "3.3.x-dev",
+ "dev-develop": "3.4.x-dev"
}
},
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ^8.0",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
- "athletic/athletic": "^0.1",
- "container-interop/container-interop": "^1.1.0",
+ "container-interop/container-interop": "^1.1",
"laminas/laminas-coding-standard": "~1.0.0",
"laminas/laminas-stdlib": "^2.7.3 || ^3.0",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
+ "phpbench/phpbench": "^0.17.1",
+ "phpunit/phpunit": "^8.5.8"
},
"suggest": {
- "container-interop/container-interop": "^1.1.0, to use the lazy listeners feature",
+ "container-interop/container-interop": "^1.1, to use the lazy listeners feature",
"laminas/laminas-stdlib": "^2.7.3 || ^3.0, to use the FilterChain feature"
},
"autoload": {
@@ -66,6 +66,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-eventmanager": "self.version"
+ "zendframework/zend-eventmanager": "^3.2.1"
}
}
diff --git a/php-laminas-eventmanager.spec b/php-laminas-eventmanager.spec
index 6bb9578..1219450 100644
--- a/php-laminas-eventmanager.spec
+++ b/php-laminas-eventmanager.spec
@@ -6,8 +6,14 @@
#
# Please, preserve the changelog entries
#
-%global bootstrap 0
-%global gh_commit ce4dc0bdf3b14b7f9815775af9dfee80a63b4748
+%bcond_with bootstrap
+%if %{with bootstrap}
+%bcond_with tests
+%else
+%bcond_without tests
+%endif
+
+%global gh_commit 1940ccf30e058b2fd66f5a9d696f1b5e0027b082
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-eventmanager
@@ -15,15 +21,10 @@
%global php_home %{_datadir}/php
%global namespace Laminas
%global library EventManager
-%if %{bootstrap}
-%global with_tests 0%{?_with_tests:1}
-%else
-%global with_tests 0%{!?_without_tests:1}
-%endif
Name: php-%{gh_project}
-Version: 3.2.1
-Release: 2%{?dist}
+Version: 3.3.0
+Release: 1%{?dist}
Summary: Trigger and listen to events within a PHP application
License: BSD
@@ -33,8 +34,8 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
-%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+%if %{with tests}
+BuildRequires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -45,30 +46,30 @@ BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-reflection
BuildRequires: php-spl
# From composer, "require-dev": {
-# "athletic/athletic": "^0.1",
-# "container-interop/container-interop": "^1.1.0",
+# "container-interop/container-interop": "^1.1",
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-stdlib": "^2.7.3 || ^3.0",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
+# "phpbench/phpbench": "^0.17.1",
+# "phpunit/phpunit": "^8.5.8"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(container-interop/container-interop) >= 1.1.0 with php-composer(container-interop/container-interop) < 2)
+BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
# remirepo:4
%else
-BuildRequires: php-container-interop >= 1.1.0
+BuildRequires: php-container-interop >= 1.1
BuildRequires: php-laminas-stdlib >= 3.0
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.2
+%global phpunit %{_bindir}/phpunit8
+BuildRequires: phpunit8 >= 8.5.8
# Autoloader
BuildRequires: php-fedora-autoloader-devel
%endif
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ^8.0",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -76,11 +77,11 @@ Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 wi
%else
Requires: php-laminas-zendframework-bridge
%endif
-%if ! %{bootstrap}
+%if %{without bootstrap}
# remirepo:1
%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
# From composer, "suggest": {
-# "container-interop/container-interop": "^1.1.0, to use the lazy listeners feature",
+# "container-interop/container-interop": "^1.1, to use the lazy listeners feature",
# "laminas/laminas-stdlib": "^2.7.3 || ^3.0, to use the FilterChain feature"
Suggests: php-composer(container-interop/container-interop)
Suggests: php-composer(%{gh_owner}/laminas-stdlib)
@@ -97,8 +98,8 @@ Requires: php-composer(fedora/autoloader)
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 3.2.1-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 3.2.2
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -155,7 +156,7 @@ cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
@@ -165,10 +166,10 @@ require_once __DIR__ . '/../test/_autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit8} --verbose || ret=1
fi
done
@@ -195,6 +196,11 @@ exit $ret
%changelog
+* Tue Aug 25 2020 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- update to 3.3.0
+- raise dependency on PHP 7.3
+- switch to phpunit 8.5
+
* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 3.2.1-2
- cleanup