summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-07 10:58:50 +0100
committerRemi Collet <remi@remirepo.net>2020-01-07 10:58:50 +0100
commit1dd24b6de2c07e645e0142bd0a3c1a6130faa172 (patch)
tree2bf8ddd051f8427258b697e91a06b968f41c971d
duplicate ZF
-rw-r--r--.gitignore8
-rw-r--r--Makefile3
-rw-r--r--composer.json58
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-laminas-eventmanager.spec175
5 files changed, 272 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..daa0499
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,58 @@
+{
+ "name": "zendframework/zend-eventmanager",
+ "description": "Trigger and listen to events within a PHP application",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf2",
+ "event",
+ "events",
+ "eventmanager"
+ ],
+ "homepage": "https://github.com/zendframework/zend-eventmanager",
+ "minimum-stability": "dev",
+ "prefer-stable": true,
+ "extra": {
+ "branch-alias": {
+ "dev-master": "3.2-dev",
+ "dev-develop": "3.3-dev"
+ }
+ },
+ "autoload": {
+ "psr-4": {
+ "Zend\\EventManager\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\EventManager\\": "test/",
+ "ZendBench\\EventManager\\": "benchmarks/"
+ },
+ "files": [
+ "test/_autoload.php"
+ ]
+ },
+ "require": {
+ "php": "^5.6 || ^7.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+ "athletic/athletic": "^0.1",
+ "zendframework/zend-stdlib": "^2.7.3 || ^3.0",
+ "container-interop/container-interop": "^1.1.0",
+ "zendframework/zend-coding-standard": "~1.0.0"
+ },
+ "suggest": {
+ "container-interop/container-interop": "^1.1.0, to use the lazy listeners feature",
+ "zendframework/zend-stdlib": "^2.7.3 || ^3.0, to use the FilterChain feature"
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87d223d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-laminas-eventmanager.spec b/php-laminas-eventmanager.spec
new file mode 100644
index 0000000..452ff50
--- /dev/null
+++ b/php-laminas-eventmanager.spec
@@ -0,0 +1,175 @@
+#
+# Copyright (c) 2015-2018 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit a5e2583a211f73604691586b8406ff7296a946dd
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-eventmanager
+%global php_home %{_datadir}/php
+%global library EventManager
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 3.2.1
+Release: 1%{?dist}
+Summary: Trigger and listen to events within a PHP application
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-reflection
+BuildRequires: php-spl
+# From composer, "require-dev": {
+# "phpunit/PHPUnit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+# "athletic/athletic": "^0.1",
+# "zendframework/zend-stdlib": "^2.7.3 || ^3.0",
+# "container-interop/container-interop": "^1.1.0",
+# "zendframework/zend-coding-standard": "~1.0.0"
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.3
+BuildRequires: php-composer(container-interop/container-interop) >= 1.1.0
+# remirepo:1
+%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
+# remirepo:4
+%else
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+%endif
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0",
+Requires: php(language) >= 5.6
+%if ! %{bootstrap}
+# From composer, "suggest": {
+# "container-interop/container-interop": "^1.1.0, to use the lazy listeners feature",
+# "zendframework/zend-stdlib": "^2.7.3 || ^3.0, to use the FilterChain feature"
+Suggests: php-composer(container-interop/container-interop)
+Suggests: php-composer(%{gh_owner}/zend-stdlib)
+%endif
+# From phpcompatinfo report for version 3.2.0
+Requires: php-reflection
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+The Zend\EventManager is a component designed for the following use cases:
+
+ Implementing simple subject/observer patterns.
+ Implementing Aspect-Oriented designs.
+ Implementing event-driven architectures.
+
+The basic architecture allows you to attach and detach listeners to named
+events, both on a per-instance basis as well as via shared collections;
+trigger events; and interrupt execution of listeners.
+
+Documentation: https://zendframework.github.io/%{gh_project}/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::optional([
+ '%{php_home}/Interop/Container/autoload.php',
+ '%{php_home}/Zend/Stdlib/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/
+cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+require_once __DIR__ . '/../test/_autoload.php';
+EOF
+
+ret=0
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{php_home}/Zend
+%{php_home}/Zend/%{library}
+
+
+%changelog
+* Thu Apr 26 2018 Remi Collet <remi@remirepo.net> - 3.2.1-1
+- update to 3.2.1 (no change)
+- switch to phpunit6 or phpunit7
+
+* Thu Nov 23 2017 Remi Collet <remi@fedoraproject.org> - 3.2.0-3
+- switch from zend-loader to fedora/autoloader
+
+* Wed Jul 12 2017 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- Update to 3.2.0
+- use phpunit6 on F26+
+
+* Tue Dec 20 2016 Remi Collet <remi@fedoraproject.org> - 3.1.0-1
+- update to 3.1.0
+- raise dependency on PHP 5.6
+
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 3.0.1-1
+- update to 3.0.1 for ZendFramework 3
+- dependency on zend-stdlib is optional
+
+* Fri Feb 19 2016 Remi Collet <remi@fedoraproject.org> - 2.6.3-1
+- update to 2.6.3
+- raise dependency on zend-stdlib >= 2.7
+
+* Thu Jan 28 2016 Remi Collet <remi@fedoraproject.org> - 2.6.2-1
+- update to 2.6.2
+
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- initial package