summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-25 09:38:54 +0200
committerRemi Collet <remi@remirepo.net>2021-06-25 09:38:54 +0200
commit5edf9650e9e45523432a4c82350ae2056aa3ca1a (patch)
tree727ba00bb120cd57c46f220f02db7651ae9fcd93
parent6356c6b1887975f9ae8168afc5de4e35ec9e3168 (diff)
update to 2.7.1
-rw-r--r--composer.json2
-rw-r--r--php-laminas-escaper.spec12
2 files changed, 9 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index d01ae2d..f6ea6e1 100644
--- a/composer.json
+++ b/composer.json
@@ -29,7 +29,7 @@
"ext-mbstring": "*"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-coding-standard": "~2.3.0",
"phpunit/phpunit": "^9.3",
"psalm/plugin-phpunit": "^0.12.2",
"vimeo/psalm": "^3.16"
diff --git a/php-laminas-escaper.spec b/php-laminas-escaper.spec
index 756eabf..a2d4b34 100644
--- a/php-laminas-escaper.spec
+++ b/php-laminas-escaper.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-escaper
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 5e04bc5ae5990b17159d79d331055e2c645e5cc5
+%global gh_commit 67dac07c6b4857fbf2bd7a5257a4e1ca8a1c00d0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-escaper
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.7.0
+Version: 2.7.1
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -48,6 +48,7 @@ BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
+# "laminas/laminas-coding-standard": "~2.3.0",
# "phpunit/phpunit": "^9.3",
# "psalm/plugin-phpunit": "^0.12.2",
# "vimeo/psalm": "^3.16"
@@ -140,7 +141,7 @@ EOF
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit8} --verbose || ret=1
@@ -170,6 +171,9 @@ exit $ret
%changelog
+* Fri Jun 25 2021 Remi Collet <remi@remirepo.net> - 2.7.1-1
+- update to 2.7.1
+
* Wed Nov 18 2020 Remi Collet <remi@remirepo.net> - 2.7.0-1
- update to 2.7.0 (no change)
- raise dependency on PHP 7.3