summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-08 11:17:37 +0100
committerRemi Collet <remi@remirepo.net>2020-01-08 11:17:37 +0100
commitfb668c736b6446bdfa3ca91196ab3faff05461f1 (patch)
tree023b0ded2af8786458be4edc846ecf9d6a31f6fb
duplicate ZF
-rw-r--r--.gitignore8
-rw-r--r--Makefile3
-rw-r--r--composer.json54
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-laminas-dom.spec150
5 files changed, 243 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..3df3bb8
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,54 @@
+{
+ "name": "zendframework/zend-dom",
+ "description": "provides tools for working with DOM documents and structures",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf",
+ "zendframework",
+ "dom"
+ ],
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-dom/",
+ "issues": "https://github.com/zendframework/zend-dom/issues",
+ "source": "https://github.com/zendframework/zend-dom",
+ "rss": "https://github.com/zendframework/zend-dom/releases.atom",
+ "slack": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
+ },
+ "require": {
+ "php": "^5.6 || ^7.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^5.7.23 || ^6.4.3",
+ "zendframework/zend-coding-standard": "~1.0.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "Zend\\Dom\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Dom\\": "test/"
+ }
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.7.x-dev",
+ "dev-develop": "2.8.x-dev"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87d223d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-laminas-dom.spec b/php-laminas-dom.spec
new file mode 100644
index 0000000..9db4735
--- /dev/null
+++ b/php-laminas-dom.spec
@@ -0,0 +1,150 @@
+# remirepo/Fedora spec file for php-zendframework-zend-dom
+#
+# Copyright (c) 2015-2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 66b8459e6f2c0d62ff4f4b16f2b44afdfd466aa0
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-dom
+%global php_home %{_datadir}/php
+%global library Dom
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.7.2
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-dom
+BuildRequires: php-libxml
+BuildRequires: php-pcre
+BuildRequires: php-spl
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.23 || ^6.4.3",
+# "zendframework/zend-coding-standard": "~1.0.0"
+# remirepo:1
+%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit6
+# remirepo:3
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0"
+Requires: php(language) >= 5.6
+# From phpcompatinfo report for version 2.6.0
+Requires: php-dom
+Requires: php-libxml
+Requires: php-pcre
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+The Zend\Dom component provides tools for working with DOM documents and
+structures. Currently, we offer Zend\Dom\Query, which provides a unified
+interface for querying DOM documents utilizing both XPath and CSS selectors.
+
+Documentation: https://zendframework.github.io/%{gh_project}/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Create autoloader
+phpab --template fedora --output src/autoload.php src
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/
+cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+EOF
+
+ret=0
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{php_home}/Zend
+ %{php_home}/Zend/%{library}
+
+
+%changelog
+* Tue Jun 18 2019 Remi Collet <remi@remirepo.net> - 2.7.2-1
+- update to 2.7.2 (no change)
+
+* Wed Apr 11 2018 Remi Collet <remi@remirepo.net> - 2.7.1-1
+- update to 2.7.1
+
+* Fri Mar 30 2018 Remi Collet <remi@remirepo.net> - 2.7.0-1
+- update to 2.7.0
+- raise dependency on PHP 5.6
+- use phpunit6
+
+* Tue Dec 5 2017 Remi Collet <remi@remirepo.net> - 2.6.0-5
+- switch from zend-loader to fedora/autoloader
+
+* Thu Jan 28 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+- raise min php version to 5.5
+
+* Thu Aug 6 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-2
+- fix description
+
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
+- initial package