summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-17 13:54:58 +0200
committerRemi Collet <remi@php.net>2022-10-17 13:54:58 +0200
commitf4cfcec8a03f3f9d24fb92e2f03a54b8139e13ca (patch)
treeb78482541a5c6eab539d0dbdbafec7f5ebbc657f
parentc0370d7d739c0a34099bb5e937ab07deb44d6805 (diff)
update to 2.13.0HEADmaster
raise dependency on PHP 8.0
-rw-r--r--composer.json11
-rw-r--r--php-laminas-dom.spec22
2 files changed, 20 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index 9867aad..2e7b5df 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,10 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"extra": {
"branch-alias": {
@@ -25,13 +28,13 @@
}
},
"require": {
- "php": "^7.4 || ~8.0.0 || ~8.1.0",
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
"ext-dom": "*",
"ext-libxml": "*"
},
"require-dev": {
- "laminas/laminas-coding-standard": "^2.1.4",
- "phpunit/phpunit": "^9.5.10"
+ "laminas/laminas-coding-standard": "^2.4.0",
+ "phpunit/phpunit": "^9.5.25"
},
"autoload": {
"psr-4": {
diff --git a/php-laminas-dom.spec b/php-laminas-dom.spec
index 50987e2..cce4099 100644
--- a/php-laminas-dom.spec
+++ b/php-laminas-dom.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 8cc95ab8843edce65c2b0e77d8f811daff3e4295
+%global gh_commit d30cbc41b970363afb66391ade3dab911487e3c0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-dom
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.12.1
+Version: 2.13.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 8.0
BuildRequires: php-dom
BuildRequires: php-libxml
# remirepo:1
@@ -47,19 +47,19 @@ BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "^2.1.4",
-# "phpunit/phpunit": "^9.5.10"
+# "laminas/laminas-coding-standard": "^2.4.0",
+# "phpunit/phpunit": "^9.5.25"
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.10
+BuildRequires: phpunit9 >= 9.5.25
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "ext-dom": "*",
# "ext-libxml": "*"
-Requires: php(language) >= 7.4
+Requires: php(language) >= 8.0
Requires: php-dom
Requires: php-libxml
# remirepo:1
@@ -136,7 +136,7 @@ EOF
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -166,6 +166,10 @@ exit $ret
%changelog
+* Mon Oct 17 2022 Remi Collet <remi@remirepo.net> - 2.13.0-1
+- update to 2.13.0
+- raise dependency on PHP 8.0
+
* Thu Jun 9 2022 Remi Collet <remi@remirepo.net> - 2.12.1-1
- update to 2.12.1