summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json15
-rw-r--r--php-laminas-diagnostics.spec28
2 files changed, 25 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index 6c4ab9c..9c76c8a 100644
--- a/composer.json
+++ b/composer.json
@@ -32,16 +32,18 @@
},
"require-dev": {
"doctrine/migrations": "^2.0 || ^3.0",
+ "enlightn/security-checker": "^1.2",
"guzzlehttp/guzzle": "^5.3.3 || ^6.3.3",
"laminas/laminas-coding-standard": "~1.0.0",
"laminas/laminas-loader": "^2.0",
"mikey179/vfsstream": "dev-master#08a798577d677436f4f4ea3d0b3c949f64655548 as 1.6.9",
- "php-amqplib/php-amqplib": "^2.0",
+ "php-amqplib/php-amqplib": "^2.0 || ^3.0",
"phpspec/prophecy-phpunit": "^2.0",
- "phpunit/phpunit": "^9.4.1",
+ "phpunit/phpunit": "^9.5",
+ "psalm/plugin-phpunit": "^0.15.1",
"predis/predis": "^1.0",
- "sensiolabs/security-checker": "^5.0 || ^6.0.3",
- "symfony/yaml": "^2.7 || ^3.0 || ^4.0 || ^5.0"
+ "symfony/yaml": "^2.7 || ^3.0 || ^4.0 || ^5.0",
+ "vimeo/psalm": "^4.7"
},
"conflict": {
"guzzlehttp/ringphp": "<1.1.1"
@@ -51,9 +53,9 @@
"doctrine/migrations": "Required by Check\\DoctrineMigration",
"guzzlehttp/guzzle": "Required by Check\\GuzzleHttpService",
"predis/predis": "Required by Check\\Redis",
- "sensiolabs/security-checker": "Required by Check\\SecurityAdvisory",
+ "enlightn/security-checker": "Required by Check\\SecurityAdvisory",
"symfony/yaml": "Required by Check\\YamlFile",
- "videlalvaro/php-amqplib": "Required by Check\\RabbitMQ"
+ "php-amqplib/php-amqplib": "Required by Check\\RabbitMQ"
},
"autoload": {
"files": [
@@ -75,6 +77,7 @@
],
"cs-check": "phpcs",
"cs-fix": "phpcbf",
+ "static-analysis": "psalm --shepherd --stats",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
diff --git a/php-laminas-diagnostics.spec b/php-laminas-diagnostics.spec
index 6344f74..71de47b 100644
--- a/php-laminas-diagnostics.spec
+++ b/php-laminas-diagnostics.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 9a634ebdc6af7e92ae3b13712b22c88121709ca9
+%global gh_commit 85b7981527f7a1cf6f99988aeb670cc07672b9cc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-diagnostics
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 1.8.0
+Version: 1.9.0
Release: 1%{?dist}
Summary: A set of components for performing diagnostic tests
@@ -38,23 +38,26 @@ BuildRequires: php-spl
BuildRequires: php-xmlreader
# From composer, "require-dev": {
# "doctrine/migrations": "^2.0 || ^3.0",
+# "enlightn/security-checker": "^1.2",
# "guzzlehttp/guzzle": "^5.3.3 || ^6.3.3",
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-loader": "^2.0",
# "mikey179/vfsstream": "dev-master#08a798577d677436f4f4ea3d0b3c949f64655548 as 1.6.9",
-# "php-amqplib/php-amqplib": "^2.0",
+# "php-amqplib/php-amqplib": "^2.0 || ^3.0",
# "phpspec/prophecy-phpunit": "^2.0",
-# "phpunit/phpunit": "^9.4.1",
+# "phpunit/phpunit": "^9.5",
+# "psalm/plugin-phpunit": "^0.15.1",
# "predis/predis": "^1.0",
# "sensiolabs/security-checker": "^5.0 || ^6.0.3",
-# "symfony/yaml": "^2.7 || ^3.0 || ^4.0 || ^5.0"
+# "symfony/yaml": "^2.7 || ^3.0 || ^4.0 || ^5.0",
+# "vimeo/psalm": "^4.7"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
BuildRequires: (php-composer(doctrine/migrations) >= 2.0 with php-composer(doctrine/migrations) < 4)
BuildRequires: (php-composer(guzzlehttp/guzzle) >= 5.3.3 with php-composer(guzzlehttp/guzzle) < 7)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-loader) >= 2.0 with php-autoloader(%{gh_owner}/laminas-loader) < 3)
-BuildRequires: (php-composer(mikey179/vfsStream) >= 1.6 with php-composer(mikey179/vfsStream) < 2)
+BuildRequires: (php-composer(mikey179/vfsstream) >= 1.6 with php-composer(mikey179/vfsstream) < 2)
BuildRequires: (php-composer(php-amqplib/php-amqplib) >= 2.0 with php-composer(php-amqplib/php-amqplib) < 3)
BuildRequires: (php-composer(predis/predis) >= 1.0 with php-composer(predis/predis) < 2)
BuildRequires: (php-composer(sensiolabs/security-checker) >= 5.0 with php-composer(sensiolabs/security-checker) < 7)
@@ -66,7 +69,7 @@ BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-doctrine-migrations
BuildRequires: php-guzzlehttp-guzzle6
BuildRequires: php-laminas-loader
-BuildRequires: php-mikey179-vfsStream
+BuildRequires: php-mikey179-vfsstream
BuildRequires: php-amqplib
BuildRequires: php-nrk-Predis
BuildRequires: php-sensiolabs-security-checker
@@ -74,7 +77,7 @@ BuildRequires: php-symfony3-yaml
BuildRequires: php-phpspec-prophecy-phpunit
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.4.1
+BuildRequires: phpunit9 >= 9.5
BuildRequires: /bin/ps
%endif
# Autoloader
@@ -89,14 +92,13 @@ Requires: php(language) >= 7.3
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# "suggest": {
# "ext-bcmath": "Required by Check\\CpuPerformance",
-# "sensiolabs/security-checker": "Required by Check\\SecurityAdvisory",
+# "enlightn/security-checker": "Required by Check\\SecurityAdvisory",
# "symfony/yaml": "Required by Check\\YamlFile",
# "guzzlehttp/guzzle": "Required by Check\\GuzzleHttpService",
# "predis/predis": "Required by Check\\Redis",
-# "videlalvaro/php-amqplib": "Required by Check\\RabbitMQ",
+# "php-amqplib/php-amqplib": "Required by Check\\RabbitMQ"
# "doctrine/migrations": "Required by Check\\DoctrineMigration"
Recommends: php-bcmath
-Recommends: (php-composer(sensiolabs/security-checker) >= 5.0 with php-composer(sensiolabs/security-checker) < 7)
Recommends: (php-composer(symfony/yaml) >= 2.7 with php-composer(symfony/yaml) < 6)
Recommends: (php-composer(guzzlehttp/guzzle) >= 5.3.3 with php-composer(guzzlehttp/guzzle) < 7)
Recommends: (php-composer(predis/predis) >= 1.0 with php-composer(predis/predis) < 2)
@@ -146,7 +148,6 @@ cat << 'EOF' | tee -a src/autoload.php
__DIR__ . '/_autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/SensioLabs/Security/autoload.php',
[
'%{php_home}/Symfony5/Component/Yaml/autoload.php',
'%{php_home}/Symfony4/Component/Yaml/autoload.php',
@@ -238,6 +239,9 @@ exit $ret
%changelog
+* Fri Jul 9 2021 Remi Collet <remi@remirepo.net> - 1.9.0-1
+- update to 1.9.0
+
* Tue Jan 26 2021 Remi Collet <remi@remirepo.net> - 1.8.0-1
- update to 1.8.0
- compatibility with doctrine/migrations v2 and v3