summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-26 17:26:39 +0100
committerRemi Collet <remi@remirepo.net>2021-01-26 17:26:39 +0100
commitee80a100b9ce42414134e12041e03dd18a11584a (patch)
tree0b060b857516752a2603a9ea45b4d549c2377291
parent0912bcf661d23aa3ff139e6dce53024a5dfb4514 (diff)
update to 1.8.0
compatibility with doctrine/migrations v2 and v3
-rw-r--r--composer.json2
-rw-r--r--php-laminas-diagnostics.spec16
2 files changed, 11 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 4a3704e..6c4ab9c 100644
--- a/composer.json
+++ b/composer.json
@@ -31,7 +31,7 @@
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
- "doctrine/migrations": "^1.0 || ^2.0",
+ "doctrine/migrations": "^2.0 || ^3.0",
"guzzlehttp/guzzle": "^5.3.3 || ^6.3.3",
"laminas/laminas-coding-standard": "~1.0.0",
"laminas/laminas-loader": "^2.0",
diff --git a/php-laminas-diagnostics.spec b/php-laminas-diagnostics.spec
index 7bfb7df..6344f74 100644
--- a/php-laminas-diagnostics.spec
+++ b/php-laminas-diagnostics.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit e3964695d3cc11aa207d0cbf90ac0e815f519fe3
+%global gh_commit 9a634ebdc6af7e92ae3b13712b22c88121709ca9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-diagnostics
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 1.7.0
+Version: 1.8.0
Release: 1%{?dist}
Summary: A set of components for performing diagnostic tests
@@ -37,7 +37,7 @@ BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-xmlreader
# From composer, "require-dev": {
-# "doctrine/migrations": "^1.0 || ^2.0",
+# "doctrine/migrations": "^2.0 || ^3.0",
# "guzzlehttp/guzzle": "^5.3.3 || ^6.3.3",
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-loader": "^2.0",
@@ -51,7 +51,7 @@ BuildRequires: php-xmlreader
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
-BuildRequires: (php-composer(doctrine/migrations) >= 1.0 with php-composer(doctrine/migrations) < 3)
+BuildRequires: (php-composer(doctrine/migrations) >= 2.0 with php-composer(doctrine/migrations) < 4)
BuildRequires: (php-composer(guzzlehttp/guzzle) >= 5.3.3 with php-composer(guzzlehttp/guzzle) < 7)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-loader) >= 2.0 with php-autoloader(%{gh_owner}/laminas-loader) < 3)
BuildRequires: (php-composer(mikey179/vfsStream) >= 1.6 with php-composer(mikey179/vfsStream) < 2)
@@ -101,7 +101,7 @@ Recommends: (php-composer(symfony/yaml) >= 2.7 with php-comp
Recommends: (php-composer(guzzlehttp/guzzle) >= 5.3.3 with php-composer(guzzlehttp/guzzle) < 7)
Recommends: (php-composer(predis/predis) >= 1.0 with php-composer(predis/predis) < 2)
Recommends: (php-composer(php-amqplib/php-amqplib) >= 2.0 with php-composer(php-amqplib/php-amqplib) < 3)
-Recommends: (php-composer(doctrine/migrations) >= 1.0 with php-composer(doctrine/migrations) < 3)
+Recommends: (php-composer(doctrine/migrations) >= 2.0 with php-composer(doctrine/migrations) < 4)
# remirepo:3
%else
Requires: php-laminas-zendframework-bridge
@@ -156,8 +156,8 @@ cat << 'EOF' | tee -a src/autoload.php
'%{php_home}/GuzzleHttp6/autoload.php',
'%{php_home}/PhpAmqpLib/autoload.php',
[
+ '%{php_home}/Doctrine/Migrations3/autoload.php',
'%{php_home}/Doctrine/Migrations/autoload.php',
- '%{php_home}/Doctrine/DBAL/Migrations/autoload.php',
],
]);
if (file_exists('/usr/share/pear/Predis/Autoloader.php')) {
@@ -238,6 +238,10 @@ exit $ret
%changelog
+* Tue Jan 26 2021 Remi Collet <remi@remirepo.net> - 1.8.0-1
+- update to 1.8.0
+- compatibility with doctrine/migrations v2 and v3
+
* Tue Jan 26 2021 Remi Collet <remi@remirepo.net> - 1.7.0-1
- update to 1.7.0
- raise dependency on PHP 7.3