summaryrefslogtreecommitdiffstats
path: root/php-laminas-diactoros2.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-11 08:39:43 +0200
committerRemi Collet <remi@php.net>2022-10-11 08:39:43 +0200
commit7b1277fcf74a53373b3b7b1f765355e137ea1920 (patch)
tree65c3d9c4474a5783f3aa0b2094fc9136391a023e /php-laminas-diactoros2.spec
parentad118eb5f5ae80fe6759239e205287ec9ee81e3d (diff)
update to 2.19.0
raise dependency on PHP 8.0
Diffstat (limited to 'php-laminas-diactoros2.spec')
-rw-r--r--php-laminas-diactoros2.spec36
1 files changed, 19 insertions, 17 deletions
diff --git a/php-laminas-diactoros2.spec b/php-laminas-diactoros2.spec
index 85ce76d..1c9e414 100644
--- a/php-laminas-diactoros2.spec
+++ b/php-laminas-diactoros2.spec
@@ -10,7 +10,7 @@
%global gh_owner laminas
%global gh_project laminas-diactoros
-%global gh_commit 6cb35f61913f06b2c91075db00f67cfd78869e28
+%global gh_commit b3c7e9262b4fbec801d8df2370cdebb4f5d3a0ae
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global php_home %{_datadir}/php
%global namespace Laminas
@@ -37,7 +37,7 @@
%{!?phpdir: %global phpdir %{_datadir}/php}
Name: php-%{gh_project}%{major}
-Version: 2.14.0
+Version: 2.19.0
Release: 1%{?gh_release}%{?dist}
Summary: PSR HTTP Message implementations v%{major}
@@ -59,17 +59,15 @@ BuildArch: noarch
# Tests
%if %{with tests}
## composer.json
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
BuildRequires: (php-composer(psr/http-factory) >= 1.0 with php-composer(psr/http-factory) < 2)
-BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
-# remirepo:5
+# remirepo:4
%else
BuildRequires: php-psr-http-message
BuildRequires: php-psr-http-factory
-BuildRequires: php-phpspec-prophecy-phpunit
%endif
# "require-dev": {
# "ext-curl": "*",
@@ -77,15 +75,14 @@ BuildRequires: php-phpspec-prophecy-phpunit
# "ext-gd": "*",
# "ext-libxml": "*",
# "http-interop/http-factory-tests": "^0.9.0",
-# "laminas/laminas-coding-standard": "~2.3.0",
+# "laminas/laminas-coding-standard": "~2.4.0",
# "php-http/psr7-integration-tests": "^1.1.1",
-# "phpspec/prophecy-phpunit": "^2.0",
-# "phpunit/phpunit": "^9.5"
+# "phpunit/phpunit": "^9.5.25"
# "psalm/plugin-phpunit": "^0.17.0",
-# "vimeo/psalm": "^4.24.0"
+# "vimeo/psalm": "^4.28"
# },
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5
+BuildRequires: phpunit9 >= 9.5.25
BuildRequires: php-curl
BuildRequires: php-dom
BuildRequires: php-gd
@@ -104,10 +101,10 @@ BuildRequires: php-fedora-autoloader-devel
# composer.json
# "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "psr/http-factory": "^1.0",
# "psr/http-message": "^1.0"
-Requires: php(language) >= 7.3
+Requires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
@@ -186,9 +183,6 @@ cat <<'BOOTSTRAP' | tee bootstrap.php
<?php
require_once '%{buildroot}%{phpdir}/%{namespace}/%{library}%{major}/autoload.php';
-\Fedora\Autoloader\Dependencies::required([
- '%{phpdir}/Prophecy/PhpUnit/autoload.php',
-]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', __DIR__.'/test');
\Fedora\Autoloader\Autoload::addPsr4('Http\\Psr7Test\\', __DIR__.'/psr7/src');
\Fedora\Autoloader\Autoload::addPsr4('Interop\\Http\\Factory\\', __DIR__.'/factory/test');
@@ -200,7 +194,7 @@ sed -e 's:vendor/http-interop/http-factory-tests:factory:' \
: Upstream tests
# Skip tests requiring network access
RETURN_CODE=0
-for CMDARG in "php %{phpunit}" php74 php80 php81 php82; do
+for CMDARG in "php %{phpunit}" php80 php81 php82; do
if which $CMDARG; then
set $CMDARG
$1 ${2:-%{_bindir}/phpunit9} \
@@ -226,6 +220,14 @@ exit $RETURN_CODE
%changelog
+* Tue Oct 11 2022 Remi Collet <remi@remirepo.net> - 2.19.0-1
+- update to 2.19.0
+- raise dependency on PHP 8.0
+
+* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 2.17.0-1
+- update to 2.17.0
+- raise dependency on PHP 7.4
+
* Mon Aug 1 2022 Remi Collet <remi@remirepo.net> - 2.14.0-1
- update to 2.14.0