summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-03-30 09:37:17 +0200
committerRemi Collet <remi@remirepo.net>2020-03-30 09:37:17 +0200
commitbe070a24cf06d8ee25c09ec8359c5ce2d21564fc (patch)
treec47de7d489813ca5ab53d0e2078f8ec877af9395
parentd73459d626a82c30043e1e71564bb753264067d9 (diff)
update to 2.2.3 (no change)
-rw-r--r--composer-factory.json3
-rw-r--r--composer.json4
-rw-r--r--php-laminas-diactoros2.spec13
3 files changed, 12 insertions, 8 deletions
diff --git a/composer-factory.json b/composer-factory.json
index 7a15318..04b3166 100644
--- a/composer-factory.json
+++ b/composer-factory.json
@@ -16,8 +16,9 @@
}
],
"require": {
+ "php": "^7.1",
"psr/http-factory": "^1.0",
- "phpunit/phpunit": "^6.5 || ^7.0"
+ "phpunit/phpunit": "^6.5 || ^7.0 || ^8.0"
},
"autoload": {
"psr-4": {
diff --git a/composer.json b/composer.json
index a1b5660..9f0526c 100644
--- a/composer.json
+++ b/composer.json
@@ -39,7 +39,7 @@
"ext-libxml": "*",
"http-interop/http-factory-tests": "^0.5.0",
"laminas/laminas-coding-standard": "~1.0.0",
- "php-http/psr7-integration-tests": "dev-master",
+ "php-http/psr7-integration-tests": "^1.0",
"phpunit/phpunit": "^7.5.18"
},
"provide": {
@@ -88,6 +88,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-diactoros": "self.version"
+ "zendframework/zend-diactoros": "^2.2.1"
}
}
diff --git a/php-laminas-diactoros2.spec b/php-laminas-diactoros2.spec
index f8efada..64021cf 100644
--- a/php-laminas-diactoros2.spec
+++ b/php-laminas-diactoros2.spec
@@ -11,7 +11,7 @@
%global gh_owner laminas
%global gh_project laminas-diactoros
%global zf_name zend-diactoros
-%global gh_commit 95178c4751d737cdf9ab0a9f70a42754ac860e7b
+%global gh_commit b596c7141f5093aefec94cb5e8745212299e290f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global php_home %{_datadir}/php
%global namespace Laminas
@@ -27,8 +27,8 @@
%global gh_factory_owner http-interop
%global gh_factory_name http-factory-tests
-%global gh_factory_version 0.5.0
-%global gh_factory_commit 3c6c62052daeb67ca7dc3e1ea1b72c0f0cc19070
+%global gh_factory_version 0.6.0
+%global gh_factory_commit 92d8b91e7236957d7512ef93e8a237d241671ce7
%global gh_factory_short %(c=%{gh_factory_commit}; echo ${c:0:7})
# Build using "--without tests" to disable tests
@@ -37,8 +37,8 @@
%{!?phpdir: %global phpdir %{_datadir}/php}
Name: php-%{gh_project}%{major}
-Version: 2.2.2
-Release: 2%{?gh_release}%{?dist}
+Version: 2.2.3
+Release: 1%{?gh_release}%{?dist}
Summary: PSR HTTP Message implementations v%{major}
License: BSD
@@ -252,6 +252,9 @@ exit $RETURN_CODE
%changelog
+* Mon Mar 30 2020 Remi Collet <remi@remirepo.net> - 2.2.3-1
+- update to 2.2.3 (no change)
+
* Thu Jan 23 2020 Remi Collet <remi@remirepo.net> - 2.2.2-2
- fix autoloader, ensure functions are not defined twice