summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-05-19 09:48:09 +0200
committerRemi Collet <remi@remirepo.net>2021-05-19 09:48:09 +0200
commitbbc85592defcaffff14f56de32ff89ad489c59d2 (patch)
tree6765d043efd5846d5f9912ceed5f0d84e5c839eb
parentef9152d9af8d8114077d1b8ce5ebb1da3489cdd6 (diff)
update to 2.6.0
-rw-r--r--composer.json7
-rw-r--r--php-laminas-diactoros2.spec7
2 files changed, 10 insertions, 4 deletions
diff --git a/composer.json b/composer.json
index f6f476a..313ba94 100644
--- a/composer.json
+++ b/composer.json
@@ -42,7 +42,9 @@
"laminas/laminas-coding-standard": "~1.0.0",
"php-http/psr7-integration-tests": "^1.1",
"phpspec/prophecy-phpunit": "^2.0",
- "phpunit/phpunit": "^9.1"
+ "phpunit/phpunit": "^9.1",
+ "psalm/plugin-phpunit": "^0.14.0",
+ "vimeo/psalm": "^4.3"
},
"provide": {
"psr/http-factory-implementation": "1.0",
@@ -87,7 +89,8 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "static-analysis": "psalm --shepherd --stats"
},
"replace": {
"zendframework/zend-diactoros": "^2.2.1"
diff --git a/php-laminas-diactoros2.spec b/php-laminas-diactoros2.spec
index 5d639d7..e54b18c 100644
--- a/php-laminas-diactoros2.spec
+++ b/php-laminas-diactoros2.spec
@@ -10,7 +10,7 @@
%global gh_owner laminas
%global gh_project laminas-diactoros
-%global gh_commit 53df7b7cd66e0905e6133970a4b90392a7a08075
+%global gh_commit 7d2034110ae18afe05050b796a3ee4b3fe177876
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global php_home %{_datadir}/php
%global namespace Laminas
@@ -36,7 +36,7 @@
%{!?phpdir: %global phpdir %{_datadir}/php}
Name: php-%{gh_project}%{major}
-Version: 2.5.1
+Version: 2.6.0
Release: 1%{?gh_release}%{?dist}
Summary: PSR HTTP Message implementations v%{major}
@@ -228,6 +228,9 @@ exit $RETURN_CODE
%changelog
+* Wed May 19 2021 Remi Collet <remi@remirepo.net> - 2.6.0-1
+- update to 2.6.0
+
* Wed Apr 14 2021 Remi Collet <remi@remirepo.net> - 2.5.1-1
- update to 2.5.1 (no change)
- drop ZF compatibility