summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-07 15:54:51 +0200
committerRemi Collet <remi@php.net>2022-07-07 15:54:51 +0200
commit14bafe319e577ac72f19aba796c5d4573ec8aaee (patch)
treeecabeb92640ee7f02d9ed9a75b45beaafd648163
parent15ad7122222f488e5784fcddb1ffd848c8491e47 (diff)
update to 2.13.0
-rw-r--r--composer.json18
-rw-r--r--php-laminas-diactoros2.spec30
2 files changed, 30 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index 27dffe5..154e70a 100644
--- a/composer.json
+++ b/composer.json
@@ -19,9 +19,15 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ },
"sort-packages": true,
"platform": {
"php": "7.3.99"
+ },
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
}
},
"extra": {
@@ -40,13 +46,13 @@
"ext-dom": "*",
"ext-gd": "*",
"ext-libxml": "*",
- "http-interop/http-factory-tests": "^0.8.0",
- "laminas/laminas-coding-standard": "~1.0.0",
- "php-http/psr7-integration-tests": "^1.1",
+ "http-interop/http-factory-tests": "^0.9.0",
+ "laminas/laminas-coding-standard": "~2.3.0",
+ "php-http/psr7-integration-tests": "^1.1.1",
"phpspec/prophecy-phpunit": "^2.0",
- "phpunit/phpunit": "^9.1",
- "psalm/plugin-phpunit": "^0.14.0",
- "vimeo/psalm": "^4.3"
+ "phpunit/phpunit": "^9.5",
+ "psalm/plugin-phpunit": "^0.17.0",
+ "vimeo/psalm": "^4.24.0"
},
"provide": {
"psr/http-factory-implementation": "1.0",
diff --git a/php-laminas-diactoros2.spec b/php-laminas-diactoros2.spec
index 003c437..8341bf0 100644
--- a/php-laminas-diactoros2.spec
+++ b/php-laminas-diactoros2.spec
@@ -10,24 +10,25 @@
%global gh_owner laminas
%global gh_project laminas-diactoros
-%global gh_commit 54d4682ac51c005db15c50543e76796a86606fe9
+%global gh_commit 34ba65010be9aa74e159d168c5ecfa5c01e4d956
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global php_home %{_datadir}/php
%global namespace Laminas
%global library Diactoros
%global major 2
-
+# https://github.com/php-http/psr7-integration-tests/tags
%global gh_psr7_owner php-http
%global gh_psr7_name psr7-integration-tests
-%global gh_psr7_version 1.1.0
-%global gh_psr7_commit b63c2f50c114a474086c6801aea58c0aa96f9b27
+%global gh_psr7_version 1.1.1
+%global gh_psr7_commit dbc81e59655c3d927ba62b2cd38be9af334590fc
%global gh_psr7_short %(c=%{gh_psr7_commit}; echo ${c:0:7})
+# https://github.com/http-interop/http-factory-tests/tags
%global gh_factory_owner http-interop
%global gh_factory_name http-factory-tests
-%global gh_factory_version 0.8.0
-%global gh_factory_commit 7384d93cd4841647b16b3c9bfd56c0367a40fce1
+%global gh_factory_version 0.9.0
+%global gh_factory_commit 642056c5360e8a74779cbf133afbc8aa2c174e15
%global gh_factory_short %(c=%{gh_factory_commit}; echo ${c:0:7})
# Build using "--without tests" to disable tests
@@ -36,7 +37,7 @@
%{!?phpdir: %global phpdir %{_datadir}/php}
Name: php-%{gh_project}%{major}
-Version: 2.12.0
+Version: 2.13.0
Release: 1%{?gh_release}%{?dist}
Summary: PSR HTTP Message implementations v%{major}
@@ -75,14 +76,16 @@ BuildRequires: php-phpspec-prophecy-phpunit
# "ext-dom": "*",
# "ext-gd": "*",
# "ext-libxml": "*",
-# "http-interop/http-factory-tests": "^0.8.0",
-# "laminas/laminas-coding-standard": "~1.0.0",
-# "php-http/psr7-integration-tests": "^1.1",
+# "http-interop/http-factory-tests": "^0.9.0",
+# "laminas/laminas-coding-standard": "~2.3.0",
+# "php-http/psr7-integration-tests": "^1.1.1",
# "phpspec/prophecy-phpunit": "^2.0",
-# "phpunit/phpunit": "^9.1"
+# "phpunit/phpunit": "^9.5"
+# "psalm/plugin-phpunit": "^0.17.0",
+# "vimeo/psalm": "^4.24.0"
# },
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.5
BuildRequires: php-curl
BuildRequires: php-dom
BuildRequires: php-gd
@@ -223,6 +226,9 @@ exit $RETURN_CODE
%changelog
+* Thu Jul 7 2022 Remi Collet <remi@remirepo.net> - 2.13.0-1
+- update to 2.13.0
+
* Wed Jul 6 2022 Remi Collet <remi@remirepo.net> - 2.12.0-1
- update to 2.12.0