summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-laminas-diactoros.spec15
1 files changed, 9 insertions, 6 deletions
diff --git a/php-laminas-diactoros.spec b/php-laminas-diactoros.spec
index 40033f8..e3e117c 100644
--- a/php-laminas-diactoros.spec
+++ b/php-laminas-diactoros.spec
@@ -1,6 +1,6 @@
# remirepo/Fedora spec file for php-laminas-diactoros
#
-# Copyright (c) 2015-2020 Shawn Iwinski, Remi Collet
+# Copyright (c) 2015-2021 Shawn Iwinski, Remi Collet
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -36,7 +36,7 @@
Name: php-%{gh_project}
Version: 1.8.7p2
-Release: 1%{?gh_release}%{?dist}
+Release: 4%{?gh_release}%{?dist}
Summary: PSR HTTP Message implementations
License: BSD
@@ -64,7 +64,7 @@ BuildRequires: (php-composer(psr/http-message) >= %{psr_http_message_min_ver}
BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-psr-http-message
%endif
-%global phpunit %{_bindir}/phpunit6
+%global phpunit %{_bindir}/phpunit7
BuildRequires: %{phpunit}
BuildRequires: php-dom
BuildRequires: php-libxml
@@ -203,10 +203,10 @@ BOOTSTRAP
: Upstream tests
# Skip testReasonPhraseDefaultsAgainstIana requiring network access
RETURN_CODE=0
-for CMDARG in "php %{phpunit}" php72 php73 php74; do
+for CMDARG in "php %{phpunit}" php73 php74 php80; do
if which $CMDARG; then
set $CMDARG
- $1 ${2:-%{_bindir}/phpunit6} \
+ $1 ${2:-%{_bindir}/phpunit7} \
--bootstrap bootstrap.php \
--filter '^((?!(testReasonPhraseDefaultsAgainstIana)).)*$' \
--verbose || RETURN_CODE=1
@@ -236,8 +236,11 @@ exit $RETURN_CODE
%changelog
+* Thu Mar 25 2021 Remi Collet <remi@remirepo.net> - 1.8.7p2-4
+- switch to phpunit7
+
* Mon Mar 30 2020 Remi Collet <remi@remirepo.net> - 1.8.7p2-1
-- update to 1.8.7p2
+- update to 1.8.7p2 (no change)
* Thu Jan 23 2020 Remi Collet <remi@remirepo.net> - 1.8.7p1-3
- fix autoloader, ensure functions are not defined twice