summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-08 12:14:41 +0100
committerRemi Collet <remi@remirepo.net>2020-01-08 12:14:41 +0100
commit78bf01c8f1bc398913e61750b8d1200cebaec682 (patch)
treed79ef1ed90eb92bfa913c396012e17d83a6898a7
duplicate ZF
-rw-r--r--.gitignore8
-rw-r--r--composer-psr7.json43
-rw-r--r--composer.json72
l---------makesrc.sh1
-rw-r--r--php-laminas-diactoros.spec296
-rwxr-xr-xphp-zendframework-zend-diactoros-get-source.sh71
6 files changed, 491 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer-psr7.json b/composer-psr7.json
new file mode 100644
index 0000000..83b1a99
--- /dev/null
+++ b/composer-psr7.json
@@ -0,0 +1,43 @@
+{
+ "name": "php-http/psr7-integration-tests",
+ "description": "Test suite for PSR7",
+ "license": "MIT",
+ "keywords": ["test", "psr-7"],
+ "homepage": "http://php-http.org",
+ "authors": [
+ {
+ "name": "Tobias Nyholm",
+ "email": "tobias.nyholm@gmail.com"
+ }
+ ],
+ "require": {
+ "php": "^5.4 || ^7.0",
+ "psr/http-message": "^1.0",
+ "phpunit/phpunit": "^5.4 || ^6.0 || ^7.0"
+ },
+ "require-dev": {
+ "zendframework/zend-diactoros": "^1.8",
+ "guzzlehttp/psr7": "^1.4",
+ "slim/http": "^0.3",
+ "ringcentral/psr7": "^1.2",
+ "nyholm/psr7": "dev-master"
+ },
+ "autoload": {
+ "psr-4": {
+ "Http\\Psr7Test\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Http\\Psr7Test\\Tests\\": "tests/"
+ }
+ },
+ "scripts": {
+ "test": "vendor/bin/phpunit"
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.0-dev"
+ }
+ }
+}
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..cd72e25
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,72 @@
+{
+ "name": "zendframework/zend-diactoros",
+ "description": "PSR HTTP Message implementations",
+ "type": "library",
+ "license": "BSD-2-Clause",
+ "keywords": [
+ "http",
+ "psr",
+ "psr-7"
+ ],
+ "homepage": "https://github.com/zendframework/zend-diactoros",
+ "support": {
+ "issues": "https://github.com/zendframework/zend-diactoros/issues",
+ "source": "https://github.com/zendframework/zend-diactoros"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-release-1.8": "1.8.x-dev"
+ }
+ },
+ "require": {
+ "php": "^5.6 || ^7.0",
+ "psr/http-message": "^1.0"
+ },
+ "require-dev": {
+ "ext-dom": "*",
+ "ext-libxml": "*",
+ "php-http/psr7-integration-tests": "dev-master",
+ "phpunit/phpunit": "^5.7.16 || ^6.0.8 || ^7.2.7",
+ "zendframework/zend-coding-standard": "~1.0"
+ },
+ "provide": {
+ "psr/http-message-implementation": "1.0"
+ },
+ "autoload": {
+ "files": [
+ "src/functions/create_uploaded_file.php",
+ "src/functions/marshal_headers_from_sapi.php",
+ "src/functions/marshal_method_from_sapi.php",
+ "src/functions/marshal_protocol_version_from_sapi.php",
+ "src/functions/marshal_uri_from_sapi.php",
+ "src/functions/normalize_server.php",
+ "src/functions/normalize_uploaded_files.php",
+ "src/functions/parse_cookie_header.php"
+ ],
+ "psr-4": {
+ "Zend\\Diactoros\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Diactoros\\": "test/"
+ },
+ "files": [
+ "test/TestAsset/Functions.php",
+ "test/TestAsset/SapiResponse.php"
+ ]
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 120000
index 0000000..bf1532e
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1 @@
+php-zendframework-zend-diactoros-get-source.sh \ No newline at end of file
diff --git a/php-laminas-diactoros.spec b/php-laminas-diactoros.spec
new file mode 100644
index 0000000..99a8019
--- /dev/null
+++ b/php-laminas-diactoros.spec
@@ -0,0 +1,296 @@
+# remirepo spec file for php-zendframework-zend-diactoros, from
+#
+# Fedora spec file for php-zendframework-zend-diactoros
+#
+# Copyright (c) 2015-2018 Shawn Iwinski <shawn.iwinski@gmail.com>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner zendframework
+%global github_name zend-diactoros
+%global github_version 1.8.7
+%global github_commit a85e67b86e9b8520d07e6415fcbcb8391b44a75b
+
+%global github_psr7_owner php-http
+%global github_psr7_name psr7-integration-tests
+%global github_psr7_version 0
+%global github_psr7_commit 5dfefb2da33ca24ae20c971b725c9a6fe7403008
+
+%global composer_vendor zendframework
+%global composer_project zend-diactoros
+
+# "php": "^5.6 || ^7.0"
+%global php_min_ver 5.6
+# "psr/http-message": "^1.0"
+%global psr_http_message_min_ver 1.0
+%global psr_http_message_max_ver 2.0
+
+# Build using "--without tests" to disable tests
+%global with_tests 0%{!?_without_tests:1}
+
+%{!?phpdir: %global phpdir %{_datadir}/php}
+
+Name: php-%{composer_vendor}-%{composer_project}
+Version: %{github_version}
+Release: 1%{?github_release}%{?dist}
+Summary: PSR HTTP Message implementations
+
+License: BSD
+URL: https://zendframework.github.io/%{github_name}/
+
+# GitHub export does not include tests.
+# Run php-zendframework-zend-diactoros-get-source.sh to create full source.
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
+# Temporarily bundled, no release, only used for tests
+Source2: %{github_psr7_owner}-%{github_psr7_name}-%{github_psr7_version}-%{github_psr7_commit}.tar.gz
+Source3: %{github_psr7_owner}-%{github_psr7_name}-get-source.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+## composer.json
+BuildRequires: php(language) >= %{php_min_ver}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: (php-composer(psr/http-message) >= %{psr_http_message_min_ver} with php-composer(psr/http-message) < %{psr_http_message_max_ver})
+# remirepo:5
+%else
+%global phpunit %{_bindir}/phpunit
+BuildRequires: php-composer(psr/http-message) < %{psr_http_message_max_ver}
+BuildRequires: php-composer(psr/http-message) >= %{psr_http_message_min_ver}
+%endif
+BuildRequires: %{phpunit}
+BuildRequires: php-dom
+BuildRequires: php-libxml
+## phpcompatinfo (computed from version 1.8.6)
+### NOTE: curl, gd, gmp, and shmop are all optional for
+### ZendTest\Diactoros\StreamTest::getResourceFor67()
+### (test/StreamTest.php) but the first one found wins
+### so only curl is chosen as a requirement here.
+BuildRequires: php-curl
+BuildRequires: php-dom
+BuildRequires: php-json
+BuildRequires: php-libxml
+BuildRequires: php-pcre
+BuildRequires: php-reflection
+BuildRequires: php-shmop
+BuildRequires: php-spl
+%endif
+## Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# composer.json
+Requires: php(language) >= %{php_min_ver}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(psr/http-message) >= %{psr_http_message_min_ver} with php-composer(psr/http-message) < %{psr_http_message_max_ver})
+# remirepo:4
+%else
+Requires: php-composer(psr/http-message) < %{psr_http_message_max_ver}
+Requires: php-composer(psr/http-message) >= %{psr_http_message_min_ver}
+%endif
+# phpcompatinfo (computed from version 1.8.6)
+Requires: php-json
+Requires: php-pcre
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+Provides: php-autoloader(%{composer_vendor}/%{composer_project}) = %{version}
+Provides: php-composer(psr/http-message-implementation) = 1.0
+
+%description
+A PHP package containing implementations of the accepted PSR-7 HTTP message
+interfaces [1], as well as a "server" implementation similar to node's
+http.Server [2].
+
+Documentation: https://zendframework.github.io/%{github_name}/
+
+Autoloader: %{phpdir}/Zend/Diactoros/autoload.php
+
+[1] http://www.php-fig.org/psr/psr-7/
+[2] http://nodejs.org/api/http.html
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit} -a2
+
+mv %{github_psr7_name}-%{github_psr7_commit} psr7
+mv LICENSE.md LICENSE
+
+
+%build
+: Create autoloader
+phpab --template fedora --output src/autoload.php src
+cat <<'AUTOLOAD' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required(array(
+ '%{phpdir}/Psr/Http/Message/autoload.php',
+ __DIR__.'/functions/create_uploaded_file.php',
+ __DIR__.'/functions/marshal_headers_from_sapi.php',
+ __DIR__.'/functions/marshal_method_from_sapi.php',
+ __DIR__.'/functions/marshal_protocol_version_from_sapi.php',
+ __DIR__.'/functions/marshal_uri_from_sapi.php',
+ __DIR__.'/functions/normalize_server.php',
+ __DIR__.'/functions/normalize_uploaded_files.php',
+ __DIR__.'/functions/parse_cookie_header.php',
+));
+AUTOLOAD
+
+
+%install
+mkdir -p %{buildroot}%{phpdir}/Zend/Diactoros
+cp -rp src/* %{buildroot}%{phpdir}/Zend/Diactoros/
+
+
+%check
+%if %{with_tests}
+: Create tests bootstrap
+cat <<'BOOTSTRAP' | tee bootstrap.php
+<?php
+
+require_once '%{buildroot}%{phpdir}/Zend/Diactoros/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\Diactoros\\', __DIR__.'/test');
+\Fedora\Autoloader\Autoload::addPsr4('Http\\Psr7Test\\', __DIR__.'/psr7/src');
+
+\Fedora\Autoloader\Dependencies::required(array(
+ __DIR__.'/test/TestAsset/Functions.php',
+ __DIR__.'/test/TestAsset/SapiResponse.php',
+));
+BOOTSTRAP
+
+: Skip test requiring network access
+sed 's/function testReasonPhraseDefaultsAgainstIana/function SKIP_testReasonPhraseDefaultsAgainstIana/' \
+ -i test/ResponseTest.php
+
+: Upstream tests
+RETURN_CODE=0
+for CMDARG in "php %{phpunit}" php71 php72 php73 php74; do
+ if which $CMDARG; then
+ set $CMDARG
+ $1 ${2:-%{_bindir}/phpunit6} --bootstrap bootstrap.php --verbose \
+ || RETURN_CODE=1
+ fi
+done
+exit $RETURN_CODE
+%else
+: Tests skipped
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{phpdir}/Zend
+ %{phpdir}/Zend/Diactoros
+
+
+%changelog
+* Fri Aug 30 2019 Remi Collet <remi@remirepo.net> - 1.8.7-1
+- update to 1.8.7
+
+* Thu Sep 6 2018 Remi Collet <remi@remirepo.net> - 1.8.6-1
+- update to 1.8.6
+- bundle php-http/psr7-integration-tests only used for tests
+
+* Mon Aug 20 2018 Remi Collet <remi@remirepo.net> - 1.8.5-1
+- update to 1.8.5
+
+* Thu Aug 02 2018 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.8.4-1
+- Update to 1.8.4 (RHBZ #1504401 / ZF2018-01 / CVE-2018-14773 / CVE-2018-14774)
+
+* Wed May 30 2018 Remi Collet <remi@remirepo.net> - 1.7.2-1
+- update to 1.7.2
+
+* Fri Mar 30 2018 Remi Collet <remi@remirepo.net> - 1.7.1-1
+- update to 1.7.1
+- use range dependencies on F27+
+
+* Fri Jan 5 2018 Remi Collet <remi@remirepo.net> - 1.7.0-1
+- Update to 1.7.0
+
+* Tue Dec 5 2017 Remi Collet <remi@remirepo.net> - 1.6.1-2
+- switch to classmap autoloader for consistency
+- provide php-autoloader(zendframework/zend-diactoros)
+
+* Thu Nov 2 2017 Remi Collet <remi@remirepo.net> - 1.6.1-1
+- Update to 1.6.1
+- use phpunit6 on F26+
+
+* Sun Oct 08 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.6.0-1
+- Updated to 1.6.0 (RHBZ #1491486)
+
+* Sun Sep 10 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.4.1-1
+- Updated to 1.4.1 (RHBZ #1482723)
+
+* Sat Apr 08 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.4.0-1
+- Updated to 1.4.0 (RHBZ #1440332)
+
+* Sat Mar 11 2017 Remi Collet <remi@fedoraproject.org> - 1.3.10-2
+- change URL to documentation site
+- simplify documentation
+
+* Sun Mar 05 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.3.10-1
+- Updated to 1.3.10 (RHBZ #1411062)
+- Test with SCLs if available
+
+* Mon Jan 23 2017 Remi Collet <remi@remirepo.net> - 1.3.10-1
+- update to 1.3.10
+
+* Wed Jan 18 2017 Remi Collet <remi@remirepo.net> - 1.3.9-1
+- update to 1.3.9
+
+* Fri Jan 6 2017 Remi Collet <remi@remirepo.net> - 1.3.8-1
+- update to 1.3.8
+
+* Sat Dec 03 2016 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.3.7-1
+- Updated to 1.3.7 (RHBZ #1318837)
+- Switch autoloader from php-composer(symfony/class-loader) to
+ php-composer(fedora/autoloader)
+
+* Wed Oct 12 2016 Remi Collet <remi@remirepo.net> - 1.3.7-1
+- update to 1.3.7
+
+* Thu Sep 8 2016 Remi Collet <remi@remirepo.net> - 1.3.6-1
+- update to 1.3.6
+
+* Wed Apr 6 2016 Remi Collet <remi@remirepo.net> - 1.3.5-1
+- update to 1.3.5
+
+* Mon Jan 04 2016 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.3.3-1
+- Updated to 1.3.3 (RHBZ #1285581)
+
+* Mon Oct 26 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.1.4-1
+- Updated to 1.1.4 (RHBZ #1272627)
+
+* Sun Oct 18 2015 Remi Collet <remi@remirepo.net> - 1.1.4-1
+- update to 1.1.4
+
+* Tue Aug 11 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.1.3-1
+- Updated to 1.1.3 (RHBZ #1252195)
+- Updated autoloader to load dependencies after self registration
+
+* Tue Aug 11 2015 Remi Collet <remi@remirepo.net> - 1.1.3-1
+- update to 1.1.3
+
+* Mon Jul 20 2015 Remi Collet <remi@remirepo.net> - 1.1.2-1
+- add EL-5 stuff, backport for #remirepo
+
+* Wed Jul 15 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.1.2-1
+- Update to 1.1.2
+- Fix license
+- Update description
+- Use full path in autoloader
+
+* Wed Jul 08 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.1.1-1
+- Initial package
diff --git a/php-zendframework-zend-diactoros-get-source.sh b/php-zendframework-zend-diactoros-get-source.sh
new file mode 100755
index 0000000..4ad1051
--- /dev/null
+++ b/php-zendframework-zend-diactoros-get-source.sh
@@ -0,0 +1,71 @@
+#/bin/sh
+
+GIT=`which git`
+RPM=`which rpm`
+
+if [ -z "$GIT" ]
+then
+ echo "ERROR: 'git' command not found" 1>&2
+ exit 1
+elif [ -z "$RPM" ]
+then
+ echo "ERROR: 'rpm' command not found" 1>&2
+ exit 1
+fi
+
+function print {
+ echo -e "\e[0;33m>>>>> ${1}\e[0m"
+}
+
+if [ -x "$1" ]
+then
+ SPEC=$1
+else
+ SPEC=`ls *.spec | head -1`
+fi
+
+NAME=`echo $SPEC | sed 's#\.spec##'`
+VERSION=`egrep '%global\s*github_version' $SPEC | awk '{print $3}'`
+
+print "SPEC = $SPEC"
+print "NAME = $NAME"
+
+GIT_OWNER=`egrep '%global\s*github_owner' $SPEC | awk '{print $3}'`
+GIT_NAME=`egrep '%global\s*github_name' $SPEC | awk '{print $3}'`
+GIT_COMMIT=`egrep '%global\s*github_commit' $SPEC | awk '{print $3}'`
+GIT_REPO=https://github.com/${GIT_OWNER}/${GIT_NAME}
+GIT_DIR=`echo $GIT_REPO | sed 's#.*/##'`
+
+print "GIT_OWNER = $GIT_OWNER"
+print "GIT_NAME = $GIT_NAME"
+print "GIT_COMMIT = $GIT_COMMIT"
+print "GIT_REPO = $GIT_REPO"
+print "GIT_DIR = $GIT_DIR"
+
+TEMP_DIR=$(mktemp --dir)
+TAR_FILE=$PWD/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+CMP_FILE=$PWD/composer.json
+
+pushd $TEMP_DIR
+ print "Cloning git repo..."
+ $GIT clone $GIT_REPO
+
+ pushd $GIT_DIR
+ print "Checking out commit..."
+ $GIT checkout $GIT_COMMIT
+ cp composer.json $CMP_FILE
+ popd
+
+ TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
+ print "TAR_DIR = $TAR_DIR"
+
+ mv $GIT_DIR $TAR_DIR
+
+ print "TAR_FILE = $TAR_FILE"
+
+ [ -e $TAR_FILE ] && rm -f $TAR_FILE
+ tar --exclude-vcs -czf $TAR_FILE $TAR_DIR
+ chmod 0644 $TAR_FILE
+popd
+
+rm -rf $TEMP_DIR