summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--php-laminas-di3.spec15
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 46325ff..c4e76e6 100644
--- a/composer.json
+++ b/composer.json
@@ -43,9 +43,9 @@
"mikey179/vfsstream": "^1.6.11@alpha",
"phpbench/phpbench": "^1.2.7",
"phpunit/phpunit": "^9.5.26",
- "psalm/plugin-phpunit": "^0.16.1",
+ "psalm/plugin-phpunit": "^0.18.0",
"squizlabs/php_codesniffer": "^3.7.1",
- "vimeo/psalm": "^4.10"
+ "vimeo/psalm": "^5.0"
},
"conflict": {
"zendframework/zend-di": "*",
diff --git a/php-laminas-di3.spec b/php-laminas-di3.spec
index 48e04b3..db8c1b3 100644
--- a/php-laminas-di3.spec
+++ b/php-laminas-di3.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-di3
#
-# Copyright (c) 2015-2022 Remi Collet
+# Copyright (c) 2015-2023 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 45c9dfd57370617d2028e597061c4ef2a2ea0118
+%global gh_commit 8d4074b5f51b747a6e4e055995f1bdf2a825d5a6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-di
@@ -22,11 +22,11 @@
%endif
Name: php-%{gh_project}%{major}
-Version: 3.11.0
+Version: 3.12.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component v%{major}
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -49,9 +49,9 @@ BuildRequires: (php-composer(psr/log) >= 1.1.
# "mikey179/vfsstream": "^1.6.11@alpha",
# "phpbench/phpbench": "^1.2.7",
# "phpunit/phpunit": "^9.5.26",
-# "psalm/plugin-phpunit": "^0.16.1",
+# "psalm/plugin-phpunit": "^0.18.0",
# "squizlabs/php_codesniffer": "^3.7.1",
-# "vimeo/psalm": "^4.10"
+# "vimeo/psalm": "^5.0"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-composer(mikey179/vfsstream) >= 1.6.11 with php-composer(mikey179/vfsstream) < 2)
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
@@ -184,6 +184,9 @@ exit $ret
%changelog
+* Tue Jan 3 2023 Remi Collet <remi@remirepo.net> - 3.12.0-1
+- update to 3.12.0
+
* Fri Nov 25 2022 Remi Collet <remi@remirepo.net> - 3.11.0-1
- update to 3.11.0
- raise dependency on PHP 8.0