summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-30 07:12:48 +0200
committerRemi Collet <remi@php.net>2022-06-30 07:12:48 +0200
commitad71c65261189fe536360d73c23c20daa11d6f83 (patch)
treed7695be8b641d84145dc06202989425ae3fdc2e7
parent34ad88412fbdb71dd7ee723b47be375a48f9c3e2 (diff)
update to 3.8.0
-rw-r--r--composer.json5
-rw-r--r--php-laminas-di3.spec13
2 files changed, 13 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index 47cca62..d7c9d4d 100644
--- a/composer.json
+++ b/composer.json
@@ -42,6 +42,7 @@
"laminas/laminas-coding-standard": "~2.3.0",
"laminas/laminas-servicemanager": "^3.7",
"mikey179/vfsstream": "^1.6.10@alpha",
+ "phpbench/phpbench": "^1.2",
"phpspec/prophecy-phpunit": "^2.0",
"phpstan/phpstan": "^0.12.64",
"phpunit/phpunit": "^9.5.5",
@@ -62,10 +63,12 @@
},
"autoload-dev": {
"psr-4": {
- "LaminasTest\\Di\\": "test/"
+ "LaminasTest\\Di\\": "test/",
+ "LaminasBench\\Di\\": "benchmarks/"
}
},
"scripts": {
+ "benchmark": "phpbench run --revs=2 --iterations=2 --report=aggregate",
"check": [
"@cs-check",
"@analyse",
diff --git a/php-laminas-di3.spec b/php-laminas-di3.spec
index 8656153..f0e28e8 100644
--- a/php-laminas-di3.spec
+++ b/php-laminas-di3.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 80c90d68bc15d4e094a609760144ce1d1aad0a79
+%global gh_commit 0335b07367eb63302a57cc30d096aa1f20664dba
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-di
@@ -22,8 +22,8 @@
%endif
Name: php-%{gh_project}%{major}
-Version: 3.7.0
-Release: 2%{?dist}
+Version: 3.8.0
+Release: 1%{?dist}
Summary: Laminas Framework %{library} component v%{major}
License: BSD
@@ -59,7 +59,7 @@ BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0
BuildRequires: php-laminas-stdlib >= 3.6
BuildRequires: php-psr-container >= 1.1.1
BuildRequires: php-PsrLog >= 1.1.4
-BuildRequires: php-laminas-servicemanager >= 3.7
+BuildRequires: php-laminas-servicemanager >= 3.12
BuildRequires: php-mikey179-vfsstream >= 1.6.7
BuildRequires: php-phpspec-prophecy-phpunit >= 2.0
%endif
@@ -148,6 +148,7 @@ cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}%{major}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Bench\\%{library}\\', dirname(__DIR__) . '/benchmarks');
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/org/bovigo/vfs/autoload.php',
'%{php_home}/Prophecy/PhpUnit/autoload.php',
@@ -155,6 +156,7 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}%{major}/autoload.p
EOF
ret=0
+# TODO php 8.2 because of mikey179/vfsstream
for cmd in php php74 php80 php81; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 \
@@ -179,6 +181,9 @@ exit $ret
%changelog
+* Thu Jun 30 2022 Remi Collet <remi@remirepo.net> - 3.8.0-1
+- update to 3.8.0
+
* Thu Jun 23 2022 Remi Collet <remi@remirepo.net> - 3.7.0-2
- drop dependency on container-interop/container-interop
replaced by servicemanager >= 3.12