summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-25 15:24:38 +0100
committerRemi Collet <remi@php.net>2022-11-25 15:24:38 +0100
commitaa7dcbec4653207913a633cf37096d1f35b38138 (patch)
treeefeb98f36c16a63f541e52f745226a8165d8e372
parenta412f7f4b6d3f8c863f51223da6209de8ccb294a (diff)
update to 3.11.0
raise dependency on PHP 8.0
-rw-r--r--composer.json22
-rw-r--r--php-laminas-di3.spec33
2 files changed, 30 insertions, 25 deletions
diff --git a/composer.json b/composer.json
index 3c5cbdd..46325ff 100644
--- a/composer.json
+++ b/composer.json
@@ -19,7 +19,7 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.4.99"
+ "php": "8.0.99"
},
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
@@ -32,25 +32,25 @@
}
},
"require": {
- "php": ">=7.4, <8.2",
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
"laminas/laminas-stdlib": "^3.6",
"psr/container": "^1.1.1",
"psr/log": "^1.1.4 || ^3.0.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~2.3.0",
+ "laminas/laminas-coding-standard": "~2.4.0",
"laminas/laminas-servicemanager": "^3.12",
- "mikey179/vfsstream": "^1.6.10@alpha",
- "phpbench/phpbench": "^1.2",
- "phpspec/prophecy-phpunit": "^2.0",
- "phpunit/phpunit": "^9.5.5",
- "squizlabs/php_codesniffer": "^3.6"
+ "mikey179/vfsstream": "^1.6.11@alpha",
+ "phpbench/phpbench": "^1.2.7",
+ "phpunit/phpunit": "^9.5.26",
+ "psalm/plugin-phpunit": "^0.16.1",
+ "squizlabs/php_codesniffer": "^3.7.1",
+ "vimeo/psalm": "^4.10"
},
"conflict": {
"zendframework/zend-di": "*",
"laminas/laminas-servicemanager-di": "*",
- "laminas/laminas-servicemanager": "<3.13.0",
- "phpspec/prophecy": "<1.9.0"
+ "laminas/laminas-servicemanager": "<3.13.0"
},
"suggest": {
"laminas/laminas-servicemanager": "An IoC container without auto wiring capabilities"
@@ -70,11 +70,11 @@
"benchmark": "phpbench run --revs=2 --iterations=2 --report=aggregate",
"check": [
"@cs-check",
- "@analyse",
"@test"
],
"cs-check": "phpcs",
"cs-fix": "phpcbf",
+ "analyse": "psalm --shepherd --stats",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
diff --git a/php-laminas-di3.spec b/php-laminas-di3.spec
index 45b2cac..48e04b3 100644
--- a/php-laminas-di3.spec
+++ b/php-laminas-di3.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 9b7091c50587f7ded53519d229421a02532feb9a
+%global gh_commit 45c9dfd57370617d2028e597061c4ef2a2ea0118
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-di
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}%{major}
-Version: 3.9.1
+Version: 3.11.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component v%{major}
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 8.0
BuildRequires: php-reflection
BuildRequires: php-pcre
BuildRequires: php-spl
@@ -44,14 +44,16 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6
BuildRequires: (php-composer(psr/container) >= 1.1.1 with php-composer(psr/container) < 2)
BuildRequires: (php-composer(psr/log) >= 1.1.4 with php-composer(psr/log) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "^2.3.0",
+# "laminas/laminas-coding-standard": "^2.4.0",
# "laminas/laminas-servicemanager": "^3.12",
-# "mikey179/vfsstream": "^1.6.10@alpha",
-# "phpstan/phpstan": "^0.12",
-# "phpspec/prophecy-phpunit": "^2.0",
-# "phpunit/phpunit": "^9.5.5"
+# "mikey179/vfsstream": "^1.6.11@alpha",
+# "phpbench/phpbench": "^1.2.7",
+# "phpunit/phpunit": "^9.5.26",
+# "psalm/plugin-phpunit": "^0.16.1",
+# "squizlabs/php_codesniffer": "^3.7.1",
+# "vimeo/psalm": "^4.10"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-BuildRequires: (php-composer(mikey179/vfsstream) >= 1.6.10 with php-composer(mikey179/vfsstream) < 2)
+BuildRequires: (php-composer(mikey179/vfsstream) >= 1.6.11 with php-composer(mikey179/vfsstream) < 2)
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
# remirepo:8
%else
@@ -62,17 +64,17 @@ BuildRequires: php-laminas-servicemanager >= 3.12
BuildRequires: php-mikey179-vfsstream >= 1.6.7
BuildRequires: php-phpspec-prophecy-phpunit >= 2.0
%endif
-BuildRequires: phpunit9 >= 9.5.5
+BuildRequires: phpunit9 >= 9.5.26
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": ">=7.4, <8.2",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "laminas/laminas-stdlib": "^3.6",
# "psr/container": "^1.1.1",
# "psr/log": "^1.1.4 || ^3.0.0"
-Requires: php(language) >= 7.4
+Requires: php(language) >= 8.0
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -158,8 +160,7 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}%{major}/autoload.p
EOF
ret=0
-# TODO php 8.2 Use of "static" in callables is deprecated
-for cmd in php php74 php80 php81; do
+for cmd in php php80 php81 php82; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 \
--verbose || ret=1
@@ -183,6 +184,10 @@ exit $ret
%changelog
+* Fri Nov 25 2022 Remi Collet <remi@remirepo.net> - 3.11.0-1
+- update to 3.11.0
+- raise dependency on PHP 8.0
+
* Thu Jun 30 2022 Remi Collet <remi@remirepo.net> - 3.9.1-1
- update to 3.9.1
- allow psr/log v3