summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-30 10:01:00 +0200
committerRemi Collet <remi@php.net>2022-03-30 10:01:00 +0200
commit9d7dd3ed3a9f8257ae76dabedaf3d05a5659d40b (patch)
treec405128c12d9bcf339163656d092d60842c0e499
parent84d3a6825f9f66d618cd412c9cb06b12a46b8d6e (diff)
update to 2.14.1
lower dependency on PHP 7.3
-rw-r--r--composer.json8
-rw-r--r--php-laminas-db.spec24
2 files changed, 18 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index 8a47892..be7db1d 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.4.99"
+ "php": "7.3.99"
},
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
@@ -31,14 +31,14 @@
}
},
"require": {
- "php": "^7.4 || ~8.0.0 || ~8.1.0",
+ "php": "^7.3 || ~8.0.0 || ~8.1.0",
"laminas/laminas-stdlib": "^3.7.1"
},
"require-dev": {
- "laminas/laminas-coding-standard": "^2.3.0",
+ "laminas/laminas-coding-standard": "~2.2.1",
"laminas/laminas-eventmanager": "^3.4.0",
"laminas/laminas-hydrator": "^3.2 || ^4.3",
- "laminas/laminas-servicemanager": "^3.10.0",
+ "laminas/laminas-servicemanager": "^3.7.0",
"phpunit/phpunit": "^9.5.19"
},
"suggest": {
diff --git a/php-laminas-db.spec b/php-laminas-db.spec
index c343196..7794f6c 100644
--- a/php-laminas-db.spec
+++ b/php-laminas-db.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit f0c039e3d99cd0ebf053077b436caa4d7791728a
+%global gh_commit 7daba1149e69dc828ce083844cde1101c0418afa
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-db
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.14.0
+Version: 2.14.1
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 7.3
BuildRequires: php-date
BuildRequires: php-pcre
BuildRequires: php-pdo
@@ -44,15 +44,15 @@ BuildRequires: php-spl
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.7.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "^2.3.0",
+# "laminas/laminas-coding-standard": "~2.2.1",
# "laminas/laminas-eventmanager": "^3.4.0",
# "laminas/laminas-hydrator": "^3.2 || ^4.3",
-# "laminas/laminas-servicemanager": "^3.10.0",
+# "laminas/laminas-servicemanager": "^3.7.0",
# "phpunit/phpunit": "^9.5.19"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.4 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-hydrator) >= 3.2 with php-autoloader(%{gh_owner}/laminas-hydrator) < 5)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.10 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.7 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
# remirepo:7
%else
BuildRequires: php-laminas-stdlib
@@ -68,9 +68,9 @@ BuildRequires: phpunit9 >= 9.5.18
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
# "laminas/laminas-stdlib": "^3.6",
-Requires: php(language) >= 7.4
+Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -179,7 +179,7 @@ exit (class_exists("\\Zend\\%{library}\\ConfigProvider") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -202,6 +202,10 @@ exit $ret
%changelog
+* Wed Mar 30 2022 Remi Collet <remi@remirepo.net> - 2.14.1-1
+- update to 2.14.1
+- lower dependency on PHP 7.3
+
* Wed Mar 30 2022 Remi Collet <remi@remirepo.net> - 2.14.0-1
- update to 2.14.0
- raise dependency on PHP 7.4