summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-29 09:06:51 +0100
committerRemi Collet <remi@php.net>2021-11-29 09:06:51 +0100
commit7e8239bff453cb3c07724af3720b0c1b965bda9b (patch)
tree710399f570aa2d8af720b0adce53f53c6197a38f
parent8af52e20fc268d98a3d0054dd531d15feeaa436a (diff)
update to 3.5.1
raise dependency on laminas-math 3.4 raise dependency on laminas-stdlib 3.6
-rw-r--r--composer.json6
-rw-r--r--php-laminas-crypt.spec29
2 files changed, 19 insertions, 16 deletions
diff --git a/composer.json b/composer.json
index 4445eb9..f28aa31 100644
--- a/composer.json
+++ b/composer.json
@@ -19,11 +19,11 @@
"sort-packages": true
},
"require": {
- "php": "^7.3 || ~8.0.0",
+ "php": "^7.3 || ~8.0.0 || ~8.1.0",
"ext-mbstring": "*",
"container-interop/container-interop": "^1.2",
- "laminas/laminas-math": "^3.0",
- "laminas/laminas-stdlib": "^2.7.7 || ^3.1",
+ "laminas/laminas-math": "^3.4",
+ "laminas/laminas-stdlib": "^3.6",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
diff --git a/php-laminas-crypt.spec b/php-laminas-crypt.spec
index 895b485..ad7980e 100644
--- a/php-laminas-crypt.spec
+++ b/php-laminas-crypt.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit a058eeb2fe57824b958ac56753faff790a649e18
+%global gh_commit 026fe31aa5c9d68679267e5473d64d96f4576020
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-crypt
@@ -22,8 +22,8 @@
%endif
Name: php-%{gh_project}
-Version: 3.4.0
-Release: 3%{?dist}
+Version: 3.5.1
+Release: 1%{?dist}
Summary: Laminas Framework %{library} component
License: BSD
@@ -46,8 +46,8 @@ BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.0 with php-autoloader(%{gh_owner}/laminas-math) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.4 with php-autoloader(%{gh_owner}/laminas-math) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:7
%else
@@ -64,11 +64,11 @@ BuildRequires: phpunit9 >= 9.3
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
# "ext-mbstring": "*",
# "container-interop/container-interop": "^1.2",
-# "laminas/laminas-math": "^3.0",
-# "laminas/laminas-stdlib": "^2.7.7 || ^3.1",
+# "laminas/laminas-math": "^3.4",
+# "laminas/laminas-stdlib": "^3.6",
# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 7.3
Requires: php-mbstring
@@ -76,8 +76,8 @@ Requires: php-mbstring
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
-Requires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.0 with php-autoloader(%{gh_owner}/laminas-math) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-math) >= 3.4 with php-autoloader(%{gh_owner}/laminas-math) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:7
%else
@@ -178,12 +178,10 @@ EOF
ret=0
# ccm
FILTER="testCcmEncryptWithTagSize|testIsSupportedAndCache"
-# since phpunit 9.5.10
-FILTER="$FILTER|testSetSaltError|testGetSaltError|testDeprecated"
# since openssl 3.0
FILTER="$FILTER|testFactory|testSetAlgorithm|testSetCipher|testSetCipherAlgorithm|testGenerateKeysWithUnsetPrivateKey"
-for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -215,6 +213,11 @@ exit $ret
%changelog
+* Mon Nov 29 2021 Remi Collet <remi@remirepo.net> - 3.5.1-1
+- update to 3.5.1
+- raise dependency on laminas-math 3.4
+- raise dependency on laminas-stdlib 3.6
+
* Wed Nov 10 2021 Remi Collet <remi@remirepo.net> - 3.4.0-3
- ignore tests for deprecation