summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-04-12 13:59:09 +0200
committerRemi Collet <remi@php.net>2022-04-12 13:59:09 +0200
commit12ab6585025f6acd8cb9f50dd71b8b160650c078 (patch)
treee6b0cbe1269034854c0277d7379e982cdd1f4ddd
parentbacf163098a34fa5116098d3db19aa948667832f (diff)
update to 3.7.0
raise dependency on PHP 7.3
-rw-r--r--.gitignore2
-rw-r--r--composer.json14
-rw-r--r--php-laminas-crypt.spec22
3 files changed, 25 insertions, 13 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/composer.json b/composer.json
index bd982d3..487e019 100644
--- a/composer.json
+++ b/composer.json
@@ -16,18 +16,24 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ },
+ "platform": {
+ "php": "7.4"
+ }
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0",
+ "php": "^7.4 || ~8.0.0 || ~8.1.0",
"ext-mbstring": "*",
"container-interop/container-interop": "^1.2",
"laminas/laminas-math": "^3.4",
"laminas/laminas-stdlib": "^3.6"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^9.3"
+ "laminas/laminas-coding-standard": "~2.3.0",
+ "phpunit/phpunit": "^9.5.11"
},
"suggest": {
"ext-openssl": "Required for most features of Laminas\\Crypt"
diff --git a/php-laminas-crypt.spec b/php-laminas-crypt.spec
index 443e0b3..c656dac 100644
--- a/php-laminas-crypt.spec
+++ b/php-laminas-crypt.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-crypt
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit ad2c29c289a4bc837b37a7650f5178edda0fc548
+%global gh_commit a0008a26b1904801ff73281f608e8de10d6deaad
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-crypt
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.6.0
+Version: 3.7.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -34,15 +34,15 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 7.4
BuildRequires: php-mbstring
BuildRequires: php-hash
BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^9.3"
+# "laminas/laminas-coding-standard": "~2.3.0",
+# "phpunit/phpunit": "^9.5.11"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(container-interop/container-interop) >= 1.2 with php-composer(container-interop/container-interop) < 2)
@@ -58,18 +58,18 @@ BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-zendframework-bridge
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.5.11
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
+# "php": "^7.4 || ~8.0.0 || ~8.1.0",
# "ext-mbstring": "*",
# "container-interop/container-interop": "^1.2",
# "laminas/laminas-math": "^3.4",
# "laminas/laminas-stdlib": "^3.6"
-Requires: php(language) >= 7.3
+Requires: php(language) >= 7.4
Requires: php-mbstring
%if ! %{bootstrap}
# remirepo:1
@@ -212,6 +212,10 @@ exit $ret
%changelog
+* Tue Apr 12 2022 Remi Collet <remi@remirepo.net> - 3.7.0-1
+- update to 3.7.0
+- raise dependency on PHP 7.3
+
* Tue Dec 7 2021 Remi Collet <remi@remirepo.net> - 3.6.0-1
- update to 3.6.0 (no change)
- keep compatibility using laminas-zendframework-bridge