summaryrefslogtreecommitdiffstats
path: root/php-laminas-console.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-console.spec')
-rw-r--r--php-laminas-console.spec190
1 files changed, 190 insertions, 0 deletions
diff --git a/php-laminas-console.spec b/php-laminas-console.spec
new file mode 100644
index 0000000..ba3c3bb
--- /dev/null
+++ b/php-laminas-console.spec
@@ -0,0 +1,190 @@
+# remirepo/Fedora spec file for php-zendframework-zend-console
+#
+# Copyright (c) 2015-2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 95817ae78f73c48026972e350a2ecc31c6d9f9ae
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-console
+%global php_home %{_datadir}/php
+%global library Console
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.8.0
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-ctype
+BuildRequires: php-dom
+BuildRequires: php-pcre
+BuildRequires: php-reflection
+BuildRequires: php-spl
+BuildRequires: php-xml
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.23 || ^6.4.3",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-filter": "^2.7.2",
+# "zendframework/zend-json": "^2.6 || ^3.0",
+# "zendframework/zend-validator": "^2.10.1"
+BuildRequires: (php-autoloader(%{gh_owner}/zend-filter) >= 2.7.2 with php-autoloader(%{gh_owner}/zend-filter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-json) >= 2.6 with php-autoloader(%{gh_owner}/zend-json) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+# remirepo:10
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
+BuildRequires: php-autoloader(%{gh_owner}/zend-filter) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-filter) >= 2.7.2
+BuildRequires: php-autoloader(%{gh_owner}/zend-json) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-json) >= 2.6
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1
+%endif
+BuildRequires: phpunit6 >= 6.4.3
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0",
+# "zendframework/zend-stdlib": "^3.2.1"
+Requires: php(language) >= 5.6
+%if ! %{bootstrap}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+# From composer, "suggest": {
+# "zendframework/zend-validator": "To support DefaultRouteMatcher usage",
+# "zendframework/zend-filter": "To support DefaultRouteMatcher usage"
+Suggests: php-autoloader(%{gh_owner}/zend-validator)
+Suggests: php-autoloader(%{gh_owner}/zend-filter)
+# remirepo:4
+%else
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
+%endif
+%endif
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 2.5.1
+Requires: php-ctype
+Requires: php-dom
+Requires: php-pcre
+Requires: php-reflection
+Requires: php-spl
+Requires: php-xml
+
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Zend\Console is a component to design and implement console applications in PHP.
+
+Documentation: https://zendframework.github.io/%{gh_project}/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Zend/Stdlib/autoload.php',
+]);
+\Fedora\Autoloader\Dependencies::optional([
+ '%{php_home}/Zend/Validator/autoload.php',
+ '%{php_home}/Zend/Filter/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/
+cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Zend/Json/autoload.php',
+]);
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+EOF
+
+ret=0
+for cmd in php php70 php71 php72 php73 php74; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/Zend/%{library}
+
+
+%changelog
+* Tue Feb 5 2019 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+- raise dependency on zend-stdlib 3.2.1
+- use range dependencies
+
+* Fri Jan 26 2018 Remi Collet <remi@remirepo.net> - 2.7.0-1
+- Update to 2.7.0
+- raise dependency on PHP 5.6
+- switch to phpunit6
+
+* Thu Dec 7 2017 Remi Collet <remi@remirepo.net> - 2.6.0-5
+- switch from zend-loader to fedora/autoloader
+
+* Fri Feb 12 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on PHP >= 5.5
+- raise dependency on zend-stdlib >= 2.7
+
+* Thu Aug 6 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-2
+- fix description
+
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
+- initial package