summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-17 13:41:34 +0200
committerRemi Collet <remi@php.net>2022-10-17 13:41:34 +0200
commitb17362b96b1038bd975d0e629df514357f524c7b (patch)
tree1f16e0184a6091e7bd59cd58c9cf511f76f730c9
parent8c80f8b68bee98d9c304beacc1935b23b289a345 (diff)
update to 3.8.0HEADmaster
raise dependency on PHP 8.0
-rw-r--r--composer.json17
-rw-r--r--php-laminas-config3.spec35
2 files changed, 30 insertions, 22 deletions
diff --git a/composer.json b/composer.json
index a7196e6..27b4d40 100644
--- a/composer.json
+++ b/composer.json
@@ -16,20 +16,23 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0",
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
"ext-json": "*",
"laminas/laminas-stdlib": "^3.6",
"psr/container": "^1.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
- "laminas/laminas-filter": "^2.7.2",
- "laminas/laminas-i18n": "^2.10.3",
- "laminas/laminas-servicemanager": "^3.7",
- "phpunit/phpunit": "^9.5.5"
+ "laminas/laminas-coding-standard": "~2.4.0",
+ "laminas/laminas-filter": "~2.23.0",
+ "laminas/laminas-i18n": "~2.19.0",
+ "laminas/laminas-servicemanager": "~3.19.0",
+ "phpunit/phpunit": "~9.5.25"
},
"conflict": {
"container-interop/container-interop": "<1.2.0",
diff --git a/php-laminas-config3.spec b/php-laminas-config3.spec
index 6fa571b..5b860eb 100644
--- a/php-laminas-config3.spec
+++ b/php-laminas-config3.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit e43d13dcfc273d4392812eb395ce636f73f34dfd
+%global gh_commit 46baad58d0b12cf98539e04334eff40a1fdfb9a0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-config
@@ -22,8 +22,8 @@
%endif
Name: php-%{gh_project}%{major}
-Version: 3.7.0
-Release: 2%{?dist}
+Version: 3.8.0
+Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component v%{major}
License: BSD
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.0
BuildRequires: php-json
BuildRequires: php-libxml
BuildRequires: php-pcre
@@ -46,13 +46,14 @@ BuildRequires: php-xmlwriter
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-filter": "^2.7.2",
-# "laminas/laminas-i18n": "^2.10.3",
-# "laminas/laminas-servicemanager": "^3.7",
-# "phpunit/phpunit": "^9.5.5"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.7.2 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.10.3 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.7 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+# "laminas/laminas-coding-standard": "~2.4.0",
+# "laminas/laminas-filter": "~2.23.0",
+# "laminas/laminas-i18n": "~2.19.0",
+# "laminas/laminas-servicemanager": "~3.19.0",
+# "phpunit/phpunit": "~9.5.25"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.23.0 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.19.0 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.19.0 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
# remirepo:7
%else
BuildRequires: php-laminas-stdlib
@@ -61,17 +62,17 @@ BuildRequires: php-laminas-filter
BuildRequires: php-laminas-i18n
BuildRequires: php-laminas-servicemanager
%endif
-BuildRequires: phpunit9 >= 9.5.5
+BuildRequires: phpunit9 >= 9.5.25
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "ext-json": "*",
# "laminas/laminas-stdlib": "^3.6",
# "psr/container": "^1.0"
-Requires: php(language) >= 7.3
+Requires: php(language) >= 8.0
Requires: php-json
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -150,7 +151,7 @@ EOF
: upstream test suite
ret=0
-for cmd in php php74 php80 php81; do
+for cmd in php php80 php81 php82; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 \
--filter '^((?!(testCloseWhenCallFromFileReaderGetInvalid|testCloseWhenCallFromStringReaderGetInvalid)).)*$' \
@@ -173,6 +174,10 @@ exit $ret
%changelog
+* Mon Oct 17 2022 Remi Collet <remi@remirepo.net> - 3.8.0-1
+- update to 3.8.0
+- raise dependency on PHP 8.0
+
* Fri Jan 28 2022 Remi Collet <remi@remirepo.net> - 3.7.0-2
- ignore 2 failed tests, FTBFS #2046823