summaryrefslogtreecommitdiffstats
path: root/php-laminas-code4.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-18 08:38:12 +0200
committerRemi Collet <remi@remirepo.net>2021-06-18 08:38:12 +0200
commite15cfd49a23f0e79342cfabfcb722da5f766fe80 (patch)
tree0c999e5f4e69778a498b424b3857f2462afa66b9 /php-laminas-code4.spec
parentb2a1cae0f91a9cedf7f49527a8b97314e29eaac2 (diff)
update to 4.4.0
drop dependency on laminas-eventmanager
Diffstat (limited to 'php-laminas-code4.spec')
-rw-r--r--php-laminas-code4.spec23
1 files changed, 9 insertions, 14 deletions
diff --git a/php-laminas-code4.spec b/php-laminas-code4.spec
index 0217a17..faf5c08 100644
--- a/php-laminas-code4.spec
+++ b/php-laminas-code4.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 1beb4447f9efd26041eba7eff50614e798c353fd
+%global gh_commit 2b0bb59ade31a045fd3ff0097dc558bb896f6596
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-code
@@ -23,7 +23,7 @@
%endif
Name: php-%{gh_project}%{major}
-Version: 4.3.0
+Version: 4.4.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -42,7 +42,6 @@ BuildRequires: php-spl
BuildRequires: php-tokenizer
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
# From composer, "require-dev": {
# "ext-phar": "*",
# "doctrine/annotations": "^1.10.4",
@@ -53,9 +52,8 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.3
# "vimeo/psalm": "^4.3.1"
BuildRequires: (php-composer(doctrine/annotations) >= 1.10.4 with php-composer(doctrine/annotations) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-# remirepo:5
+# remirepo:4
%else
-BuildRequires: php-laminas-eventmanager >= 3.3
BuildRequires: php-doctrine-annotations >= 1.10.4
BuildRequires: php-laminas-stdlib >= 3.3
%endif
@@ -65,21 +63,16 @@ BuildRequires: phpunit9 >= 9.4.2
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0",
-# "laminas/laminas-eventmanager": "^3.3",
+# "php": "^7.4 || ~8.0.0"
Requires: php(language) >= 7.4
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
# From composer, "suggest": {
# "doctrine/annotations": "Doctrine\\Common\\Annotations >=1.0 for annotation features",
# "laminas/laminas-stdlib": "Laminas\\Stdlib component"
Suggests: php-composer(doctrine/annotations)
Suggests: php-autoloader(%{gh_owner}/laminas-stdlib)
-# remirepo:3
-%else
-Requires: php-laminas-eventmanager >= 3.3
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -115,9 +108,6 @@ mv LICENSE.md LICENSE
: Create autoloader
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
-\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/%{namespace}/EventManager/autoload.php',
-]);
\Fedora\Autoloader\Dependencies::optional([
'%{php_home}/Doctrine/Common/Annotations/autoload.php',
'%{php_home}/%{namespace}/Stdlib/autoload.php',
@@ -141,6 +131,7 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}%{major}/autoload.p
EOF
ret=0
+# TODO php81 (1 failure)
for cmd in php php74 php80; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 --verbose || ret=1
@@ -163,6 +154,10 @@ exit $ret
%changelog
+* Fri Jun 18 2021 Remi Collet <remi@remirepo.net> - 4.4.0-1
+- update to 4.4.0
+- drop dependency on laminas-eventmanager
+
* Mon May 17 2021 Remi Collet <remi@remirepo.net> - 4.3.0-1
- update to 4.3.0