summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-07 14:07:30 +0100
committerRemi Collet <remi@php.net>2021-12-07 14:07:30 +0100
commita64ed155793872b64a5df41b152c9b6307c54ddf (patch)
tree9432c32a2eed4cf0e47c8ffcdbc611a832874961
parent81f8bf7d1162009f1ae28bcdcfac1b854345e982 (diff)
update to 4.5.0
-rw-r--r--composer.json30
-rw-r--r--php-laminas-code4.spec39
2 files changed, 38 insertions, 31 deletions
diff --git a/composer.json b/composer.json
index f44c879..ca20cdc 100644
--- a/composer.json
+++ b/composer.json
@@ -9,32 +9,34 @@
"homepage": "https://laminas.dev",
"license": "BSD-3-Clause",
"require": {
- "php": "^7.4 || ~8.0.0"
- },
- "conflict": {
- "phpspec/prophecy": "<1.9.0"
+ "php": ">=7.4, <8.2"
},
"require-dev": {
"ext-phar": "*",
- "doctrine/annotations": "^1.10.4",
- "laminas/laminas-coding-standard": "^2.1.4",
- "laminas/laminas-stdlib": "^3.3.0",
- "phpunit/phpunit": "^9.4.2",
- "psalm/plugin-phpunit": "^0.14.0",
- "vimeo/psalm": "^4.3.1"
+ "doctrine/annotations": "^1.13.2",
+ "laminas/laminas-coding-standard": "^2.3.0",
+ "laminas/laminas-stdlib": "^3.6.1",
+ "phpunit/phpunit": "^9.5.10",
+ "psalm/plugin-phpunit": "^0.16.1",
+ "vimeo/psalm": "^4.13.1"
},
"suggest": {
"doctrine/annotations": "Doctrine\\Common\\Annotations >=1.0 for annotation features",
- "laminas/laminas-stdlib": "Laminas\\Stdlib component",
- "laminas/laminas-zendframework-bridge": "A bridge with Zend Framework"
+ "laminas/laminas-stdlib": "Laminas\\Stdlib component"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "platform": {
+ "php": "7.4.99"
+ }
},
"autoload": {
"psr-4": {
"Laminas\\Code\\": "src/"
- }
+ },
+ "files": [
+ "polyfill/ReflectionEnumPolyfill.php"
+ ]
},
"autoload-dev": {
"psr-4": {
diff --git a/php-laminas-code4.spec b/php-laminas-code4.spec
index 1d8860d..8e1d5e2 100644
--- a/php-laminas-code4.spec
+++ b/php-laminas-code4.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit bb324850d09dd437b6acb142c13e64fdc725b0e1
+%global gh_commit c99ef8e5629c33bfaa3a8f1df773e916af564cd6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-code
@@ -23,7 +23,7 @@
%endif
Name: php-%{gh_project}%{major}
-Version: 4.4.3
+Version: 4.5.0
Release: 1%{?dist}
Summary: Laminas Framework %{library} component
@@ -44,26 +44,26 @@ BuildRequires: php-tokenizer
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
# From composer, "require-dev": {
# "ext-phar": "*",
-# "doctrine/annotations": "^1.10.4",
-# "laminas/laminas-coding-standard": "^2.1.4",
-# "laminas/laminas-stdlib": "^3.3.0",
-# "phpunit/phpunit": "^9.4.2",
-# "psalm/plugin-phpunit": "^0.14.0",
-# "vimeo/psalm": "^4.3.1"
-BuildRequires: (php-composer(doctrine/annotations) >= 1.10.4 with php-composer(doctrine/annotations) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+# "doctrine/annotations": "^1.13.2",
+# "laminas/laminas-coding-standard": "^2.3.0",
+# "laminas/laminas-stdlib": "^3.6.1",
+# "phpunit/phpunit": "^9.5.10",
+# "psalm/plugin-phpunit": "^0.16.1",
+# "vimeo/psalm": "^4.13.1"
+BuildRequires: (php-composer(doctrine/annotations) >= 1.13.2 with php-composer(doctrine/annotations) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
# remirepo:4
%else
-BuildRequires: php-doctrine-annotations >= 1.10.4
-BuildRequires: php-laminas-stdlib >= 3.3
+BuildRequires: php-doctrine-annotations >= 1.13.2
+BuildRequires: php-laminas-stdlib >= 3.6.1
%endif
-BuildRequires: phpunit9 >= 9.4.2
+BuildRequires: phpunit9 >= 9.5.10
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0"
+# "php": "php": ">=7.4, <8.2"
Requires: php(language) >= 7.4
%if ! %{bootstrap}
# remirepo:1
@@ -112,14 +112,16 @@ cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::optional([
'%{php_home}/Doctrine/Common/Annotations/autoload.php',
'%{php_home}/%{namespace}/Stdlib/autoload.php',
+ __DIR__ . '/polyfill/ReflectionEnumPolyfill.php',
]);
EOF
%install
: Laminas library
-mkdir -p %{buildroot}%{php_home}/%{namespace}/
-cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}%{major}
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}%{major}
+cp -pr polyfill %{buildroot}%{php_home}/%{namespace}/%{library}%{major}/polyfill
%check
@@ -133,7 +135,7 @@ EOF
ret=0
# TODO php81 (1 failure)
-for cmd in php php74 php80; do
+for cmd in php php74 php80 php81; do
if which $cmd; then
$cmd %{_bindir}/phpunit9 --verbose || ret=1
fi
@@ -155,6 +157,9 @@ exit $ret
%changelog
+* Tue Dec 7 2021 Remi Collet <remi@remirepo.net> - 4.5.0-1
+- update to 4.5.0
+
* Thu Sep 23 2021 Remi Collet <remi@remirepo.net> - 4.4.3-1
- update to 4.4.3