summaryrefslogtreecommitdiffstats
path: root/php-laminas-code.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-code.spec')
-rw-r--r--php-laminas-code.spec109
1 files changed, 71 insertions, 38 deletions
diff --git a/php-laminas-code.spec b/php-laminas-code.spec
index 4dd3f32..affec98 100644
--- a/php-laminas-code.spec
+++ b/php-laminas-code.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zend-code
+# remirepo/Fedora spec file for php-laminas-code
#
# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
@@ -7,11 +7,13 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 268040548f92c2bfcba164421c1add2ba43abaaa
+%global gh_commit 1cb8f203389ab1482bf89c0e70a04849bacd7766
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-code
+%global gh_owner laminas
+%global gh_project laminas-code
+%global zf_name zend-code
%global php_home %{_datadir}/php
+%global namespace Laminas
%global library Code
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -19,13 +21,13 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 3.4.1
Release: 1%{?dist}
-Summary: Zend Framework %{library} component
+Summary: Laminas Framework %{library} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -39,23 +41,23 @@ BuildRequires: php-spl
BuildRequires: php-tokenizer
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6 with php-autoloader(%{gh_owner}/zend-eventmanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.0 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "ext-phar": "*",
# "doctrine/annotations": "^1.7",
-# "phpunit/phpunit": "^7.5.16 || ^8.4,"
-# "zendframework/zend-coding-standard": "^1.0",
-# "zendframework/zend-stdlib": "^2.7 || ^3.0"
-BuildRequires: (php-composer(doctrine/annotations) >= 1.7 with php-composer(doctrine/annotations) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-# remirepo:8
+# "laminas/laminas-coding-standard": "^1.0",
+# "laminas/laminas-stdlib": "^2.7 || ^3.0",
+# "phpunit/phpunit": "^7.5.16 || ^8.4"
+BuildRequires: (php-composer(doctrine/annotations) >= 1.7 with php-composer(doctrine/annotations) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+# remirepo:7
%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-eventmanager) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6
-BuildRequires: php-composer(doctrine/annotations) < 2
-BuildRequires: php-composer(doctrine/annotations) >= 1.7
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+BuildRequires: php-laminas-eventmanager
+BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-composer(doctrine/annotations) < 2
+BuildRequires: php-composer(doctrine/annotations) >= 1.7
+BuildRequires: php-laminas-stdlib
%endif
BuildRequires: phpunit8 >= 8.4
%endif
@@ -64,46 +66,51 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^7.1",
-# "zendframework/zend-eventmanager": "^2.6 || ^3.0""
+# "laminas/laminas-eventmanager": "^2.6 || ^3.0",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 7.1
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6 with php-autoloader(%{gh_owner}/zend-eventmanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.0 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
# "doctrine/annotations": "Doctrine\\Common\\Annotations >=1.0 for annotation features",
-# "zendframework/zend-stdlib": "Zend\\Stdlib component"
+# "laminas/laminas-stdlib": "Laminas\\Stdlib component"
Suggests: php-composer(doctrine/annotations)
-Suggests: php-autoloader(%{gh_owner}/zend-stdlib)
+Suggests: php-autoloader(%{gh_owner}/laminas-stdlib)
# remirepo:4
%else
-Requires: php-autoloader(%{gh_owner}/zend-eventmanager) < 4
-Requires: php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6
+Requires: php-laminas-eventmanager
+Requires: php-laminas-zendframework-bridge
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
%endif
-# From phpcompatinfo report for version 2.6.2
+# From phpcompatinfo report for version 3.4.1
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
Requires: php-tokenizer
-Obsoletes: php-ZendFramework2-%{library} < 2.5
-Provides: php-ZendFramework2-%{library} = %{version}
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 3.4.1-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-Zend\Code\Generator provides facilities to generate arbitrary code using
+%{gh_project} provides facilities to generate arbitrary code using
an object-oriented interface, both to create new code as well as to update
existing code. While the current implementation is limited to generating
PHP code, you can easily extend the base class in order to provide code
generation for other tasks: JavaScript, configuration files, apache vhosts,
etc.
-Documentation: https://zendframework.github.io/%{gh_project}/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -117,18 +124,32 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/EventManager/autoload.php',
+ '%{php_home}/%{namespace}/EventManager/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
'%{php_home}/Doctrine/Common/Annotations/autoload.php',
- '%{php_home}/Zend/Stdlib/autoload.php',
+ '%{php_home}/%{namespace}/Stdlib/autoload.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/Zend/
-cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
+
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
%check
@@ -136,8 +157,8 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
ret=0
@@ -146,6 +167,13 @@ for cmd in php php72 php73 php74; do
$cmd %{_bindir}/phpunit8 --verbose || ret=1
fi
done
+
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
+return (class_exists("\\Zend\\%{library}\\NameInformation") ? 0 : 1);
+'
+
exit $ret
%else
: Test suite disabled
@@ -153,14 +181,19 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
%{php_home}/Zend/%{library}
+%{php_home}/%{namespace}/%{library}
%changelog
+* Tue Jan 7 2020 Remi Collet <remi@remirepo.net> - 3.4.1-1
+- switch to Laminas
+
* Wed Dec 11 2019 Remi Collet <remi@remirepo.net> - 3.4.1-1
- update to 3.4.1