summaryrefslogtreecommitdiffstats
path: root/php-laminas-captcha.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-15 11:20:00 +0100
committerRemi Collet <remi@remirepo.net>2020-01-15 11:20:00 +0100
commit0735f1000e11f979e1113f730128a9c16a0d8ef8 (patch)
treece14a395fffb1294eea535c27783fe74fbeb8958 /php-laminas-captcha.spec
duplicate ZF
Diffstat (limited to 'php-laminas-captcha.spec')
-rw-r--r--php-laminas-captcha.spec227
1 files changed, 227 insertions, 0 deletions
diff --git a/php-laminas-captcha.spec b/php-laminas-captcha.spec
new file mode 100644
index 0000000..738f5a2
--- /dev/null
+++ b/php-laminas-captcha.spec
@@ -0,0 +1,227 @@
+# remirepo/Fedora spec file for php-zendframework-zend-captcha
+#
+# Copyright (c) 2015-2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 4272f3d0cde0a1fa9135d0cbc4a629fb655391d3
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-captcha
+%global php_home %{_datadir}/php
+%global library Captcha
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.9.0
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-date
+BuildRequires: php-gd
+BuildRequires: php-spl
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-session": "^2.8",
+# "zendframework/zend-text": "^2.6",
+# "zendframework/zend-validator": "^2.10.1",
+# "zendframework/zendservice-recaptcha": "^3.0"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-math) >= 2.7 with php-autoloader(%{gh_owner}/zend-math) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-session) >= 2.8 with php-autoloader(%{gh_owner}/zend-session) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-text) >= 2.6 with php-autoloader(%{gh_owner}/zend-text) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zendservice-recaptcha) >= 3.0 with php-autoloader(%{gh_owner}/zendservice-recaptcha) < 4)
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
+# remirepo:16
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-math) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-math) >= 2.7
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
+BuildRequires: php-autoloader(%{gh_owner}/zend-session) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-session) >= 2.8
+BuildRequires: php-autoloader(%{gh_owner}/zend-text) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-text) >= 2.6
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1
+BuildRequires: php-autoloader(%{gh_owner}/zendservice-recaptcha) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zendservice-recaptcha) >= 3.0
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+%endif
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0",
+# "zendframework/zend-math": "^2.7 || ^3.0",
+# "zendframework/zend-stdlib": "^3.2.1"
+Requires: php(language) >= 5.6
+%if ! %{bootstrap}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-math) >= 2.7 with php-autoloader(%{gh_owner}/zend-math) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+# remirepo:6
+%else
+Requires: php-autoloader(%{gh_owner}/zend-math) < 4
+Requires: php-autoloader(%{gh_owner}/zend-math) >= 2.7
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
+%endif
+# From composer, "suggest": {
+# "zendframework/zend-i18n-resources": "Translations of captcha messages",
+# "zendframework/zend-session": "Zend\\Session component",
+# "zendframework/zend-text": "Zend\\Text component",
+# "zendframework/zend-validator": "Zend\\Validator component",
+# "zendframework/zendservice-recaptcha": "ZendService\\ReCaptcha component"
+Suggests: php-autoloader(%{gh_owner}/zend-i18n-resources)
+Suggests: php-autoloader(%{gh_owner}/zend-session)
+Suggests: php-autoloader(%{gh_owner}/zend-text)
+Suggests: php-autoloader(%{gh_owner}/zend-validator)
+Suggests: php-autoloader(%{gh_owner}/zendservice-recaptcha)
+%endif
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 2.5.2
+Requires: php-date
+Requires: php-gd
+Requires: php-spl
+
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Zend\Captcha component is able to manage “Completely Automated Public
+Turing test to tell Computers and Humans Apart” (CAPTCHA); it is used
+as a challenge-response to ensure that the individual submitting
+information is a human and not an automated process. Typically, a captcha
+is used with form submissions where authenticated users are not necessary,
+but you want to prevent spam submissions.
+
+Documentation: https://zendframework.github.io/%{gh_project}/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Generate autoloader
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Zend/Math/autoload.php',
+ '%{php_home}/Zend/Stdlib/autoload.php',
+]);
+\Fedora\Autoloader\Dependencies::optional([
+ '%{php_home}/Zend/I18n/Translator/autoload.php',
+ '%{php_home}/Zend/Session/autoload.php',
+ '%{php_home}/Zend/Text/autoload.php',
+ '%{php_home}/Zend/Validator/autoload.php',
+ '%{php_home}/ZendService/ReCaptcha/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/
+cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+EOF
+
+ret=0
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/Zend/%{library}
+
+
+%changelog
+* Tue Jun 18 2019 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0 (no change)
+- raise dependency on zend-stdlib 3.2.1
+
+* Thu Apr 26 2018 Remi Collet <remi@remirepo.net> - 2.8.0-2
+- update to 2.8.0
+- raise dependency on zend-math 2.7
+- raise dependency on zend-stdlib 2.7.7
+- switch to phpunit6 or phpunit7
+- use range dependencies on F27+
+
+* Mon Dec 11 2017 Remi Collet <remi@remirepo.net> - 2.7.1-3
+- switch from zend-loader to fedora/autoloader
+
+* Thu Feb 23 2017 Remi Collet <remi@fedoraproject.org> - 2.7.1-1
+- update to 2.7.1
+
+* Mon Feb 20 2017 Remi Collet <remi@fedoraproject.org> - 2.7.0-1
+- update to 2.7.0
+
+* Wed Jun 22 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on PHP 5.6
+
+* Tue Feb 23 2016 Remi Collet <remi@fedoraproject.org> - 2.5.4-1
+- update to 2.5.4
+- raise dependency on zend-math >= 2.6
+- raise dependency on zend-stdlib >= 2.7
+
+* Tue Feb 23 2016 Remi Collet <remi@fedoraproject.org> - 2.5.3-1
+- update to 2.5.3
+
+* Wed Nov 25 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- update to 2.5.2
+- raise dependency on PHP 5.5
+
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
+- initial package