summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-15 11:34:01 +0100
committerRemi Collet <remi@remirepo.net>2020-01-15 11:34:01 +0100
commitb07d21b2385a12b45b1d49273adf0f3a08a9d0a4 (patch)
tree82d267a53eac5af08ecc41eb44431fd7528ffc81
parent0735f1000e11f979e1113f730128a9c16a0d8ef8 (diff)
switch to Laminas
-rw-r--r--composer.json70
-rw-r--r--php-laminas-captcha.spec180
2 files changed, 142 insertions, 108 deletions
diff --git a/composer.json b/composer.json
index 82db84e..96420e3 100644
--- a/composer.json
+++ b/composer.json
@@ -1,57 +1,58 @@
{
- "name": "zendframework/zend-captcha",
+ "name": "laminas/laminas-captcha",
"description": "Generate and validate CAPTCHAs using Figlets, images, ReCaptcha, and more",
"license": "BSD-3-Clause",
"keywords": [
- "zf",
- "zendframework",
+ "laminas",
"captcha"
],
+ "homepage": "https://laminas.dev",
"support": {
- "docs": "https://docs.zendframework.com/zend-captcha/",
- "issues": "https://github.com/zendframework/zend-captcha/issues",
- "source": "https://github.com/zendframework/zend-captcha",
- "rss": "https://github.com/zendframework/zend-captcha/releases.atom",
- "chat": "https://zendframework-slack.herokuapp.com",
- "forum": "https://discourse.zendframework.com/c/questions/components"
+ "docs": "https://docs.laminas.dev/laminas-captcha/",
+ "issues": "https://github.com/laminas/laminas-captcha/issues",
+ "source": "https://github.com/laminas/laminas-captcha",
+ "rss": "https://github.com/laminas/laminas-captcha/releases.atom",
+ "chat": "https://laminas.dev/chat",
+ "forum": "https://discourse.laminas.dev"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.9.x-dev",
+ "dev-develop": "2.10.x-dev"
+ }
},
"require": {
"php": "^5.6 || ^7.0",
- "zendframework/zend-math": "^2.7 || ^3.0",
- "zendframework/zend-stdlib": "^3.2.1"
+ "laminas/laminas-math": "^2.7 || ^3.0",
+ "laminas/laminas-stdlib": "^3.2.1",
+ "laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
- "zendframework/zend-coding-standard": "~1.0.0",
- "zendframework/zend-session": "^2.8",
- "zendframework/zend-text": "^2.6",
- "zendframework/zend-validator": "^2.10.1",
- "zendframework/zendservice-recaptcha": "^3.0"
+ "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-recaptcha": "^3.0",
+ "laminas/laminas-session": "^2.8",
+ "laminas/laminas-text": "^2.6",
+ "laminas/laminas-validator": "^2.10.1",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
},
"suggest": {
- "zendframework/zend-i18n-resources": "Translations of captcha messages",
- "zendframework/zend-session": "Zend\\Session component",
- "zendframework/zend-text": "Zend\\Text component",
- "zendframework/zend-validator": "Zend\\Validator component",
- "zendframework/zendservice-recaptcha": "ZendService\\ReCaptcha component"
+ "laminas/laminas-i18n-resources": "Translations of captcha messages",
+ "laminas/laminas-recaptcha": "Laminas\\ReCaptcha component",
+ "laminas/laminas-session": "Laminas\\Session component",
+ "laminas/laminas-text": "Laminas\\Text component",
+ "laminas/laminas-validator": "Laminas\\Validator component"
},
"autoload": {
"psr-4": {
- "Zend\\Captcha\\": "src/"
+ "Laminas\\Captcha\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
- "ZendTest\\Captcha\\": "test/"
- }
- },
- "config": {
- "sort-packages": true
- },
- "extra": {
- "branch-alias": {
- "dev-master": "2.9.x-dev",
- "dev-develop": "2.10.x-dev"
+ "LaminasTest\\Captcha\\": "test/"
}
},
"scripts": {
@@ -63,5 +64,8 @@
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ },
+ "replace": {
+ "zendframework/zend-captcha": "self.version"
}
}
diff --git a/php-laminas-captcha.spec b/php-laminas-captcha.spec
index 738f5a2..ec2ec0c 100644
--- a/php-laminas-captcha.spec
+++ b/php-laminas-captcha.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zend-captcha
+# remirepo/Fedora spec file for php-laminas-captcha
#
# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
@@ -7,11 +7,13 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 4272f3d0cde0a1fa9135d0cbc4a629fb655391d3
+%global gh_commit b88f650f3adf2d902ef56f6377cceb5cd87b9876
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-captcha
+%global gh_owner laminas
+%global gh_project laminas-captcha
+%global zf_name zend-captcha
%global php_home %{_datadir}/php
+%global namespace Laminas
%global library Captcha
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -19,13 +21,13 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 2.9.0
Release: 1%{?dist}
-Summary: Zend Framework %{library} component
+Summary: %{namespace} Framework %{library} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -36,95 +38,95 @@ BuildRequires: php(language) >= 5.6
BuildRequires: php-date
BuildRequires: php-gd
BuildRequires: php-spl
-# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
-# "zendframework/zend-coding-standard": "~1.0.0",
-# "zendframework/zend-session": "^2.8",
-# "zendframework/zend-text": "^2.6",
-# "zendframework/zend-validator": "^2.10.1",
-# "zendframework/zendservice-recaptcha": "^3.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-math) >= 2.7 with php-autoloader(%{gh_owner}/zend-math) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-session) >= 2.8 with php-autoloader(%{gh_owner}/zend-session) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-text) >= 2.6 with php-autoloader(%{gh_owner}/zend-text) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/zend-validator) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zendservice-recaptcha) >= 3.0 with php-autoloader(%{gh_owner}/zendservice-recaptcha) < 4)
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.2
-# remirepo:16
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-math) >= 2.7 with php-autoloader(%{gh_owner}/laminas-math) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# From composer, "require-dev": {
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-recaptcha": "^3.0",
+# "laminas/laminas-session": "^2.8",
+# "laminas/laminas-text": "^2.6",
+# "laminas/laminas-validator": "^2.10.1",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-recaptcha) >= 3.0 with php-autoloader(%{gh_owner}/laminas-recaptcha) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.8 with php-autoloader(%{gh_owner}/laminas-session) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-text) >= 2.6 with php-autoloader(%{gh_owner}/laminas-text) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+# remirepo:9
%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-math) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-math) >= 2.7
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-session) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-session) >= 2.8
-BuildRequires: php-autoloader(%{gh_owner}/zend-text) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-text) >= 2.6
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1
-BuildRequires: php-autoloader(%{gh_owner}/zendservice-recaptcha) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zendservice-recaptcha) >= 3.0
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.8
+BuildRequires: php-laminas-math
+BuildRequires: php-laminas-stdlib
+BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-laminas-recaptcha
+BuildRequires: php-laminas-session
+BuildRequires: php-laminas-text
+BuildRequires: php-laminas-validator
%endif
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
-# "zendframework/zend-math": "^2.7 || ^3.0",
-# "zendframework/zend-stdlib": "^3.2.1"
+# "laminas/laminas-math": "^2.7 || ^3.0",
+# "laminas/laminas-stdlib": "^3.2.1",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/zend-math) >= 2.7 with php-autoloader(%{gh_owner}/zend-math) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-# remirepo:6
+Requires: (php-autoloader(%{gh_owner}/laminas-math) >= 2.7 with php-autoloader(%{gh_owner}/laminas-math) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# From composer, "suggest": {
+# "laminas/laminas-i18n-resources": "Translations of captcha messages",
+# "laminas/laminas-recaptcha": "Laminas\\ReCaptcha component",
+# "laminas/laminas-session": "Laminas\\Session component",
+# "laminas/laminas-text": "Laminas\\Text component",
+# "laminas/laminas-validator": "Laminas\\Validator component"
+Suggests: php-autoloader(%{gh_owner}/laminas-i18n-resources)
+Suggests: php-autoloader(%{gh_owner}/laminas-recaptcha)
+Suggests: php-autoloader(%{gh_owner}/laminas-session)
+Suggests: php-autoloader(%{gh_owner}/laminas-text)
+Suggests: php-autoloader(%{gh_owner}/laminas-validator)
+# remirepo:5
%else
-Requires: php-autoloader(%{gh_owner}/zend-math) < 4
-Requires: php-autoloader(%{gh_owner}/zend-math) >= 2.7
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
+Requires: php-laminas-math
+Requires: php-laminas-stdlib
+Requires: php-laminas-zendframework-bridge
%endif
-# From composer, "suggest": {
-# "zendframework/zend-i18n-resources": "Translations of captcha messages",
-# "zendframework/zend-session": "Zend\\Session component",
-# "zendframework/zend-text": "Zend\\Text component",
-# "zendframework/zend-validator": "Zend\\Validator component",
-# "zendframework/zendservice-recaptcha": "ZendService\\ReCaptcha component"
-Suggests: php-autoloader(%{gh_owner}/zend-i18n-resources)
-Suggests: php-autoloader(%{gh_owner}/zend-session)
-Suggests: php-autoloader(%{gh_owner}/zend-text)
-Suggests: php-autoloader(%{gh_owner}/zend-validator)
-Suggests: php-autoloader(%{gh_owner}/zendservice-recaptcha)
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 2.5.2
+# From phpcompatinfo report for version 2.9.0
Requires: php-date
Requires: php-gd
Requires: php-spl
-Obsoletes: php-ZendFramework2-%{library} < 2.5
-Provides: php-ZendFramework2-%{library} = %{version}
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 2.9.0-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-Zend\Captcha component is able to manage “Completely Automated Public
+%{namespace}\Captcha component is able to manage “Completely Automated Public
Turing test to tell Computers and Humans Apart” (CAPTCHA); it is used
as a challenge-response to ensure that the individual submitting
information is a human and not an automated process. Typically, a captcha
is used with form submissions where authenticated users are not necessary,
but you want to prevent spam submissions.
-Documentation: https://zendframework.github.io/%{gh_project}/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -138,22 +140,36 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/Math/autoload.php',
- '%{php_home}/Zend/Stdlib/autoload.php',
+ '%{php_home}/%{namespace}/Math/autoload.php',
+ '%{php_home}/%{namespace}/Stdlib/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/Zend/I18n/Translator/autoload.php',
- '%{php_home}/Zend/Session/autoload.php',
- '%{php_home}/Zend/Text/autoload.php',
- '%{php_home}/Zend/Validator/autoload.php',
- '%{php_home}/ZendService/ReCaptcha/autoload.php',
+ '%{php_home}/%{namespace}/I18n/Translator/autoload.php',
+ '%{php_home}/%{namespace}/Session/autoload.php',
+ '%{php_home}/%{namespace}/Text/autoload.php',
+ '%{php_home}/%{namespace}/Validator/autoload.php',
+ '%{php_home}/%{namespace}/ReCaptcha/autoload.php',
]);
EOF
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
+ ]);
+EOF
+
%install
-mkdir -p %{buildroot}%{php_home}/Zend/
-cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
+
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
%check
@@ -161,12 +177,21 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
+exit (class_exists("\\Zend\\%{library}\\Image") ? 0 : 1);
+'
+
+# No TESTS_LAMINAS_CAPTCHA_RECAPTCHA_SUPPORT as online
+
+: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
@@ -179,14 +204,19 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
%{php_home}/Zend/%{library}
+%{php_home}/%{namespace}/%{library}
%changelog
+* Tue Jan 14 2020 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- switch to Laminas
+
* Tue Jun 18 2019 Remi Collet <remi@remirepo.net> - 2.9.0-1
- update to 2.9.0 (no change)
- raise dependency on zend-stdlib 3.2.1