summaryrefslogtreecommitdiffstats
path: root/php-laminas-cache.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-cache.spec')
-rw-r--r--php-laminas-cache.spec40
1 files changed, 28 insertions, 12 deletions
diff --git a/php-laminas-cache.spec b/php-laminas-cache.spec
index 3bfaf75..f072112 100644
--- a/php-laminas-cache.spec
+++ b/php-laminas-cache.spec
@@ -11,7 +11,7 @@
# When buid without laminas-session
%global bootstrap 0
-%global gh_commit c0c24cb12f6180c4025eaabe092f63309876c2a9
+%global gh_commit 23d1340f4c044681819a2b4f0379e460d43ce9fb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-cache
@@ -21,8 +21,8 @@
%global library Cache
# Adapter tests
-%global gh_test_commit 4896c384cce35c49e514cc55f40364b08886c65f
-%global gh_test_version 1.0.2
+%global gh_test_commit 2a1f1606fbb57f4641aab5c93eb161606eafc4aa
+%global gh_test_version 1.1.1
%global gh_test_short %(c=%{gh_test_commit}; echo ${c:0:7})
# APC adapter
%global gh_apc_commit 8b375d994f6e67534f6ae6e995249e706faa30c1
@@ -45,20 +45,20 @@
%global gh_ext_mongodb_version 1.0.1
%global gh_ext_mongodb_short %(c=%{gh_ext_mongodb_commit}; echo ${c:0:7})
# Filesystem adapter
-%global gh_filesystem_commit e803d9942b30396491efbe649a3886450d22385f
-%global gh_filesystem_version 1.1.0
+%global gh_filesystem_commit 76fc488c3fa0ad442e4e70f807305c940d1bdcbc
+%global gh_filesystem_version 1.1.1
%global gh_filesystem_short %(c=%{gh_filesystem_commit}; echo ${c:0:7})
# Memcache adapter
%global gh_memcache_commit 62d0fab1cd261b44a81821e986c0110d7dda896b
%global gh_memcache_version 1.0.1
%global gh_memcache_short %(c=%{gh_memcache_commit}; echo ${c:0:7})
# Memcached adapter
-%global gh_memcached_commit 29599106bb501eb96207b175c460c95487518db1
-%global gh_memcached_version 1.0.1
+%global gh_memcached_commit f5d35cc2ef6264c76021bcc798569182103baa91
+%global gh_memcached_version 1.1.0
%global gh_memcached_short %(c=%{gh_memcached_commit}; echo ${c:0:7})
# Memory adapter
-%global gh_memory_commit 58f4b45281552bb6673c900fadddad21e0ed05c8
-%global gh_memory_version 1.0.1
+%global gh_memory_commit 02c7a4a1118bbd47d1c0f0bfe1e8b140af79d2bd
+%global gh_memory_version 1.1.0
%global gh_memory_short %(c=%{gh_memory_commit}; echo ${c:0:7})
# Mongodb adapter
%global gh_mongodb_commit ef4aa396b55533b8eb3e1d4126c39a78a22e49a6
@@ -87,7 +87,7 @@
Name: php-%{gh_project}
-Version: 2.10.1
+Version: 2.10.2
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -261,7 +261,7 @@ for i in apc apcu blackhole dba ext-mongodb filesystem memcache memcached memory
do
pushd laminas-cache-storage-adapter-$i-*
mv src/* ../src/Storage/Adapter
- mv CHANGELOG.md ../CHANGELOG-$i.md
+ [ -f CHANGELOG.md ] && mv CHANGELOG.md ../CHANGELOG-$i.md
mv LICENSE.md ../LICENSE-$i
mv composer.json ../composer-$i.json
case $i in
@@ -339,10 +339,19 @@ sed -e '/unlinkDelay/s/5000/50000/' \
-e '/usleep/s/1000/10000/' \
-i test/Storage/Adapter/filesystem/unit/FilesystemTest.php
+# Fix for PHPUnit (some requires v7, some v9)
+find test/ -type f \
+ -exec sed \
+ -e 's/function setUp()$/function setUp(): void/' \
+ -e 's/function tearDown()$/function tearDown(): void/' \
+ -e 's/>onlyMethods(/>setMethods(/' \
+ -e 's/>assertMatchesRegularExpression(/>assertRegExp(/' \
+ -i {} \;
+
: upstream test suite
ret=0
# TODO php80
-for cmdarg in "php %{phpunit}" php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} || ret=1
@@ -372,6 +381,13 @@ exit $ret
%changelog
+* Thu Apr 29 2021 Remi Collet <remi@remirepo.net> - 2.10.2-1
+- update to 2.10.2
+- update laminas-cache-storage-adapter-filesystem to 1.1.1
+- update laminas-cache-storage-adapter-memcached to 1.1.0
+- update laminas-cache-storage-adapter-memory to 1.1.0
+- update laminas-cache-storage-adapter-test to 1.1.1
+
* Fri Feb 26 2021 Remi Collet <remi@remirepo.net> - 2.10.1-1
- update to 2.10.1
- update laminas-cache-storage-adapter-backhole to 1.1.1 (no change)