summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer-blackhole.json10
-rw-r--r--composer-memcache.json11
-rw-r--r--php-laminas-cache.spec16
3 files changed, 21 insertions, 16 deletions
diff --git a/composer-blackhole.json b/composer-blackhole.json
index ef44169..fc7c85a 100644
--- a/composer-blackhole.json
+++ b/composer-blackhole.json
@@ -7,7 +7,7 @@
],
"license": "BSD-3-Clause",
"require": {
- "php": "^5.6 || ^7.0"
+ "php": "^7.3 || ~8.0.0"
},
"conflict": {
"laminas/laminas-cache": "<2.10"
@@ -16,10 +16,10 @@
"laminas/laminas-cache-storage-implementation": "1.0"
},
"require-dev": {
- "laminas/laminas-cache": "^2.10",
- "laminas/laminas-cache-storage-adapter-test": "^1.0.2",
- "laminas/laminas-coding-standard": "~1.0.0",
- "squizlabs/php_codesniffer": "^2.7"
+ "laminas/laminas-cache": "^2.10.1",
+ "laminas/laminas-cache-storage-adapter-test": "^1.1.1",
+ "laminas/laminas-coding-standard": "^2.1.4",
+ "squizlabs/php_codesniffer": "^3.5.8"
},
"config": {
"sort-packages": true
diff --git a/composer-memcache.json b/composer-memcache.json
index 4b09899..f119583 100644
--- a/composer-memcache.json
+++ b/composer-memcache.json
@@ -7,7 +7,7 @@
],
"license": "BSD-3-Clause",
"require": {
- "php": "^5.6 || ^7.0"
+ "php": "^7.3 || ~8.0.0"
},
"conflict": {
"laminas/laminas-cache": "<2.10"
@@ -16,10 +16,11 @@
"laminas/laminas-cache-storage-implementation": "1.0"
},
"require-dev": {
- "laminas/laminas-cache": "^2.10",
- "laminas/laminas-cache-storage-adapter-test": "^1.0@dev",
- "laminas/laminas-coding-standard": "~1.0.0",
- "squizlabs/php_codesniffer": "^2.7"
+ "laminas/laminas-cache": "^2.10.1",
+ "laminas/laminas-cache-storage-adapter-test": "^1.1.1",
+ "laminas/laminas-coding-standard": "^2.1.4",
+ "laminas/laminas-serializer": "^2.10.1",
+ "squizlabs/php_codesniffer": "^3.6.0"
},
"suggest": {
"ext-memcache": "Memcache >= 2.0.0 to use the Memcache storage adapter"
diff --git a/php-laminas-cache.spec b/php-laminas-cache.spec
index 23d121d..ad06263 100644
--- a/php-laminas-cache.spec
+++ b/php-laminas-cache.spec
@@ -33,8 +33,8 @@
%global gh_apcu_version 1.0.1
%global gh_apcu_short %(c=%{gh_apcu_commit}; echo ${c:0:7})
# Blackhole adapter
-%global gh_blackhole_commit 78aab2ceac8464e27aa330d2b5bba314b44accee
-%global gh_blackhole_version 1.1.1
+%global gh_blackhole_commit 4af1053efd81785a292c2a9442871c075700345a
+%global gh_blackhole_version 1.2.1
%global gh_blackhole_short %(c=%{gh_blackhole_commit}; echo ${c:0:7})
# Dba adapter
%global gh_dba_commit ad968d3d8a0350af8e6717be58bb96e5a9e77f3b
@@ -49,8 +49,8 @@
%global gh_filesystem_version 1.1.1
%global gh_filesystem_short %(c=%{gh_filesystem_commit}; echo ${c:0:7})
# Memcache adapter
-%global gh_memcache_commit 62d0fab1cd261b44a81821e986c0110d7dda896b
-%global gh_memcache_version 1.0.1
+%global gh_memcache_commit 1d2a74e300a0fd0b8d0e0cb4e379a173ccad0088
+%global gh_memcache_version 1.1.0
%global gh_memcache_short %(c=%{gh_memcache_commit}; echo ${c:0:7})
# Memcached adapter
%global gh_memcached_commit f5d35cc2ef6264c76021bcc798569182103baa91
@@ -88,7 +88,7 @@
Name: php-%{gh_project}
Version: 2.11.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: %{namespace} Framework %{library} component
License: BSD
@@ -273,7 +273,7 @@ do
ext-mongodb|memcache|memcached|mongodb|redis)
# skip test requiring a running server
;;
- blackhole|dba|zend-server)
+ dba|zend-server)
# skip test no ready for PHPUnit 9
;;
%if %{bootstrap}
@@ -388,6 +388,10 @@ exit $ret
%changelog
+* Mon May 3 2021 Remi Collet <remi@remirepo.net> - 2.11.0-2
+- update laminas-cache-storage-adapter-blackhole to 1.2.1
+- update laminas-cache-storage-adapter-memcache to 1.1.0
+
* Mon May 3 2021 Remi Collet <remi@remirepo.net> - 2.11.0-1
- update to 2.11.0
- update laminas-cache-storage-adapter-redis to 1.1.0