summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json12
-rw-r--r--php-laminas-barcode.spec34
2 files changed, 23 insertions, 23 deletions
diff --git a/composer.json b/composer.json
index 643f690..96b5813 100644
--- a/composer.json
+++ b/composer.json
@@ -18,15 +18,9 @@
"config": {
"sort-packages": true
},
- "extra": {
- "branch-alias": {
- "dev-master": "2.8.x-dev",
- "dev-develop": "2.9.x-dev"
- }
- },
"require": {
- "php": "^5.6 || ^7.0",
- "laminas/laminas-servicemanager": "^2.7.8 || ^3.3",
+ "php": "^7.3 || ~8.0.0",
+ "laminas/laminas-servicemanager": "^3.6.0",
"laminas/laminas-stdlib": "^2.7.7 || ^3.1",
"laminas/laminas-validator": "^2.10.1",
"laminas/laminas-zendframework-bridge": "^1.0"
@@ -34,7 +28,7 @@
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
"laminas/laminas-config": "^2.6 || ^3.1",
- "phpunit/phpunit": "^5.7.23 || ^6.4.3 || ^7.5.20",
+ "phpunit/phpunit": "^9.5.2",
"zendframework/zendpdf": "^2.0.2"
},
"suggest": {
diff --git a/php-laminas-barcode.spec b/php-laminas-barcode.spec
index 7485e72..8af9277 100644
--- a/php-laminas-barcode.spec
+++ b/php-laminas-barcode.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-barcode
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7806b774328a32b1f121f2972c72a0ded85939e1
+%global gh_commit 74034895076d2305ce6716f93dd8d821f3c1e4fc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-barcode
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.8.2
+Version: 2.9.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-dom
BuildRequires: php-gd
@@ -43,14 +43,14 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.6.0 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-config": "^2.6 || ^3.1",
-# "phpunit/phpunit": "^5.7.23 || ^6.4.3 || ^7.5.20",
+# "phpunit/phpunit": "^9.5.2",
# "zendframework/zendpdf": "^2.0.2"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 4)
BuildRequires: (php-autoloader(zendframework/zendpdf) >= 2.0.2 with php-autoloader(zendframework/zendpdf) < 3)
@@ -63,22 +63,22 @@ BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-config
BuildRequires: php-zendframework-zendpdf
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.5.20
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.5.2
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
-# "laminas/laminas-servicemanager": "^2.7.8 || ^3.3",
+# "php": "^7.3 || ~8.0.0",
+# "laminas/laminas-servicemanager": "^3.6.0",
# "laminas/laminas-stdlib": "^2.7.7 || ^3.1",
# "laminas/laminas-validator": "^2.10.1",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.6.0 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -186,10 +186,10 @@ exit (class_exists("\\Zend\\%{library}\\Barcode") ? 0 : 1);
: upstream test suite
export TESTS_LAMINAS_BARCODE_PDF_SUPPORT=1
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -209,6 +209,12 @@ exit $ret
%changelog
+* Mon Feb 15 2021 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+- raise dependency on PHP 7.3
+- raise dependency on laminas-servicemanager 3.6
+- switch to phpunit9
+
* Mon Mar 30 2020 Remi Collet <remi@remirepo.net> - 2.8.2-1
- update to 2.8.2 (no change)