summaryrefslogtreecommitdiffstats
path: root/php-laminas-barcode.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-20 14:28:07 +0100
committerRemi Collet <remi@php.net>2021-12-20 14:28:07 +0100
commitac64ead21862a8a3caf91a548fa3e6576ae23ab3 (patch)
tree4c04becca6c4200cbcd1a113942108d843f9e90b /php-laminas-barcode.spec
parent5a572c261262763393b6c82f2bb85d38ffd7db33 (diff)
update to 2.10.0 (no change)
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader
Diffstat (limited to 'php-laminas-barcode.spec')
-rw-r--r--php-laminas-barcode.spec29
1 files changed, 14 insertions, 15 deletions
diff --git a/php-laminas-barcode.spec b/php-laminas-barcode.spec
index 8af9277..cb3b2db 100644
--- a/php-laminas-barcode.spec
+++ b/php-laminas-barcode.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 74034895076d2305ce6716f93dd8d821f3c1e4fc
+%global gh_commit 0e853bec9165f2b99b7e956673bbf3b1f393177b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-barcode
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.9.0
+Version: 2.10.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -53,15 +53,13 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "phpunit/phpunit": "^9.5.2",
# "zendframework/zendpdf": "^2.0.2"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 4)
-BuildRequires: (php-autoloader(zendframework/zendpdf) >= 2.0.2 with php-autoloader(zendframework/zendpdf) < 3)
-# remirepo:8
+# remirepo:7
%else
BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-validator
BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-config
-BuildRequires: php-zendframework-zendpdf
%endif
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.5.2
@@ -73,8 +71,7 @@ BuildRequires: php-fedora-autoloader-devel
# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-servicemanager": "^3.6.0",
# "laminas/laminas-stdlib": "^2.7.7 || ^3.1",
-# "laminas/laminas-validator": "^2.10.1",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "laminas/laminas-validator": "^2.10.1"
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -82,9 +79,6 @@ Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.6.
Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
-# From composer, "suggest": {
-# "zendframework/zendpdf": "ZendPdf component"
-Suggests: php-autoloader(zendframework/zendpdf)
# remirepo:6
%else
Requires: php-laminas-servicemanager
@@ -137,9 +131,6 @@ cat << 'EOF' | tee -a src/autoload.php
'%{php_home}/%{namespace}/Validator/autoload.php',
'%{php_home}/%{namespace}/ServiceManager/autoload.php',
]);
-\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/ZendPdf/autoload.php',
-]);
EOF
cat << 'EOF' | tee zf.php
@@ -184,9 +175,9 @@ exit (class_exists("\\Zend\\%{library}\\Barcode") ? 0 : 1);
'
: upstream test suite
-export TESTS_LAMINAS_BARCODE_PDF_SUPPORT=1
+export TESTS_LAMINAS_BARCODE_PDF_SUPPORT=0
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -209,6 +200,14 @@ exit $ret
%changelog
+* Mon Dec 20 2021 Remi Collet <remi@remirepo.net> - 2.10.0-1
+- update to 2.10.0 (no change)
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
+* Wed Mar 10 2021 Remi Collet <remi@remirepo.net> - 2.9.0-2
+- disable PDF support
+
* Mon Feb 15 2021 Remi Collet <remi@remirepo.net> - 2.9.0-1
- update to 2.9.0
- raise dependency on PHP 7.3