summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-16 09:02:54 +0100
committerRemi Collet <remi@php.net>2022-11-16 09:02:54 +0100
commit98aec23b147bf0520945f7bb047edf2517025c55 (patch)
treedb425a4eb52a68d2b7d5f539d57af43398ac9627
parent454235fde313783f1584aa3eec15d030dd02634a (diff)
update to 2.12.0HEADmaster
raise dependency on PHP 8.0
-rw-r--r--composer.json12
-rw-r--r--php-laminas-barcode.spec20
2 files changed, 21 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index fe0de85..536ea66 100644
--- a/composer.json
+++ b/composer.json
@@ -16,10 +16,16 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "platform": {
+ "php": "8.0.99"
+ },
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"require": {
- "php": "~7.4.0 || ~8.0.0 || ~8.1.0",
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
"laminas/laminas-servicemanager": "^3.10.0",
"laminas/laminas-stdlib": "^3.6.0",
"laminas/laminas-validator": "^2.15.1"
@@ -27,7 +33,7 @@
"require-dev": {
"laminas/laminas-coding-standard": "~2.3.0",
"laminas/laminas-config": "^3.7.0",
- "phpunit/phpunit": "^9.3.7"
+ "phpunit/phpunit": "^9.5"
},
"autoload": {
"psr-4": {
diff --git a/php-laminas-barcode.spec b/php-laminas-barcode.spec
index 13fc6d3..61e6762 100644
--- a/php-laminas-barcode.spec
+++ b/php-laminas-barcode.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit e2a4b56e2f6c800992fe1c7e7cc0da851dcfdfa0
+%global gh_commit f3e36bc861daae5e76d2a3f40b743f4908a85823
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-barcode
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.11.0
+Version: 2.12.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 8.0
BuildRequires: php-dom
BuildRequires: php-gd
@@ -50,7 +50,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~2.3.0",
# "laminas/laminas-config": "^3.7.0",
-# "phpunit/phpunit": "^9.3.7"
+# "phpunit/phpunit": "^9.5"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.7 with php-autoloader(%{gh_owner}/laminas-config) < 4)
# remirepo:7
%else
@@ -61,17 +61,17 @@ BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-config3
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3.7
+BuildRequires: phpunit9 >= 9.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "~7.4.0 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "laminas/laminas-servicemanager": "^3.10.0",
# "laminas/laminas-stdlib": "^3.6.0",
# "laminas/laminas-validator": "^2.15.1"
-Requires: php(language) >= 7.4
+Requires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.10.0 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
@@ -172,7 +172,7 @@ exit (class_exists("\\Zend\\%{library}\\Barcode") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -195,6 +195,10 @@ exit $ret
%changelog
+* Wed Nov 16 2022 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0
+- raise dependency on PHP 8.0
+
* Wed Jan 5 2022 Remi Collet <remi@remirepo.net> - 2.11.0-1
- update to 2.11.0
- raise dependency on PHP 7.4