summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-10 10:22:23 +0100
committerRemi Collet <remi@remirepo.net>2020-01-10 10:22:23 +0100
commit02bad1503835efd60431c0eca69b5ecb9c222581 (patch)
tree4a50731b8af9795f07bbb65e804115647b96b08e
duplicate ZF
-rw-r--r--.gitignore8
-rw-r--r--2.patch35
-rw-r--r--Makefile3
-rw-r--r--composer.json62
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-laminas-barcode.spec204
6 files changed, 340 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/2.patch b/2.patch
new file mode 100644
index 0000000..608ef25
--- /dev/null
+++ b/2.patch
@@ -0,0 +1,35 @@
+From c765b77757f5fff04998232fd45d401b48288102 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 2 Jan 2020 14:34:04 +0100
+Subject: [PATCH] Fix Invalid characters passed for attempted conversion (7.4)
+
+---
+ src/Object/AbstractObject.php | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/Object/AbstractObject.php b/src/Object/AbstractObject.php
+index a3b2d48..0fa2689 100644
+--- a/src/Object/AbstractObject.php
++++ b/src/Object/AbstractObject.php
+@@ -429,8 +429,8 @@ public function getFactor()
+ */
+ public function setForeColor($value)
+ {
+- if (preg_match('`\#[0-9A-F]{6}`', $value)) {
+- $this->foreColor = hexdec($value);
++ if (preg_match('`\#([0-9A-F]{6})`', $value, $reg)) {
++ $this->foreColor = hexdec($reg[1]);
+ } elseif (is_numeric($value) && $value >= 0 && $value <= 16777125) {
+ $this->foreColor = intval($value);
+ } else {
+@@ -460,8 +460,8 @@ public function getForeColor()
+ */
+ public function setBackgroundColor($value)
+ {
+- if (preg_match('`\#[0-9A-F]{6}`', $value)) {
+- $this->backgroundColor = hexdec($value);
++ if (preg_match('`\#([0-9A-F]{6})`', $value, $reg)) {
++ $this->backgroundColor = hexdec($reg[1]);
+ } elseif (is_numeric($value) && $value >= 0 && $value <= 16777125) {
+ $this->backgroundColor = intval($value);
+ } else {
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..f9696bf
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,62 @@
+{
+ "name": "zendframework/zend-barcode",
+ "description": "Programmatically create and render barcodes as images or in PDFs",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "zf",
+ "zendframework",
+ "barcode"
+ ],
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-barcode/",
+ "issues": "https://github.com/zendframework/zend-barcode/issues",
+ "source": "https://github.com/zendframework/zend-barcode",
+ "rss": "https://github.com/zendframework/zend-barcode/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
+ },
+ "require": {
+ "php": "^5.6 || ^7.0",
+ "zendframework/zend-servicemanager": "^2.7.8 || ^3.3",
+ "zendframework/zend-stdlib": "^2.7.7 || ^3.1",
+ "zendframework/zend-validator": "^2.10.1"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^5.7.23 || ^6.4.3",
+ "zendframework/zend-coding-standard": "~1.0.0",
+ "zendframework/zend-config": "^2.6 || ^3.1",
+ "zendframework/zendpdf": "^2.0.2"
+ },
+ "suggest": {
+ "zendframework/zendpdf": "ZendPdf component"
+ },
+ "autoload": {
+ "psr-4": {
+ "Zend\\Barcode\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\Barcode\\": "test/"
+ }
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.8.x-dev",
+ "dev-develop": "2.9.x-dev"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87d223d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-laminas-barcode.spec b/php-laminas-barcode.spec
new file mode 100644
index 0000000..afdf574
--- /dev/null
+++ b/php-laminas-barcode.spec
@@ -0,0 +1,204 @@
+# remirepo/Fedora spec file for php-zendframework-zend-barcode
+#
+# Copyright (c) 2015-2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 6db95687997920b8217e71d2f12b51ec10e824d9
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-barcode
+%global php_home %{_datadir}/php
+%global library Barcode
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.8.0
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+Patch0: https://patch-diff.githubusercontent.com/raw/laminas/laminas-barcode/pull/2.patch
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-dom
+BuildRequires: php-gd
+BuildRequires: php-iconv
+BuildRequires: php-pcre
+BuildRequires: php-spl
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.8
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.7
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.23 || ^6.4.3",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-config": "^2.6 || ^3.1",
+# "zendframework/zendpdf": "^2.0.2"
+BuildRequires: php-autoloader(%{gh_owner}/zend-config) >= 2.6
+BuildRequires: php-autoloader(%{gh_owner}/zendpdf) >= 2.0.2
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.4.3
+%else
+%global phpunit %{_bindir}/phpunit
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7.22
+%endif
+# Autoloader
+BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0",
+# "zendframework/zend-servicemanager": "^2.7.8 || ^3.3",
+# "zendframework/zend-stdlib": "^2.7.7 || ^3.1",
+# "zendframework/zend-validator": "^2.10.1"
+Requires: php(language) >= 5.6
+%if ! %{bootstrap}
+Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.8
+Requires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.7
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+Requires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1
+Requires: php-autoloader(%{gh_owner}/zend-validator) < 3
+# From composer, "suggest": {
+# "zendframework/zendpdf": "ZendPdf component"
+%if 0%{?fedora} >= 21
+Suggests: php-autoloader(%{gh_owner}/zendpdf)
+%endif
+%endif
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 2.6.0
+Requires: php-dom
+Requires: php-gd
+Requires: php-iconv
+Requires: php-pcre
+Requires: php-spl
+
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Zend\Barcode provides a generic way to generate barcodes.
+The Zend\Barcode component is divided into two subcomponents: barcode objects
+and renderers. Objects allow you to create barcodes independently of the
+renderer. Renderer allow you to draw barcodes based on the support required.
+
+Documentation: https://zendframework.github.io/%{gh_project}/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+%patch0 -p1 -b .pr2
+
+
+%build
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Zend/Stdlib/autoload.php',
+ '%{php_home}/Zend/Validator/autoload.php',
+ '%{php_home}/Zend/ServiceManager/autoload.php',
+]);
+\Fedora\Autoloader\Dependencies::optional([
+ '%{php_home}/ZendPdf/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/
+cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Zend/Config/autoload.php',
+]);
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+EOF
+
+export TESTS_ZEND_BARCODE_PDF_SUPPORT=1
+ret=0
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/Zend/%{library}
+
+
+%changelog
+* Thu Jan 2 2020 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+- add patch for PHP 7.4 from
+ https://github.com/laminas/laminas-barcode/pull/2
+
+* Mon Sep 23 2019 Remi Collet <remi@remirepo.net> - 2.7.1-1
+- update to 2.7.1
+
+* Tue Dec 12 2017 Remi Collet <remi@remirepo.net> - 2.7.0-1
+- Update to 2.7.0
+- raise dependency on PHP 5.6
+- raise dependency on zend-servicemanager 2.7.8
+- raise dependency on zend-stdlib 2.7.7
+- raise dependency on zend-validator 2.10.1
+- use phpunit6 on F26+
+
+* Thu Dec 7 2017 Remi Collet <remi@remirepo.net> - 2.6.0-5
+- switch from zend-loader to fedora/autoloader
+- run PDF tests
+
+* Fri Oct 20 2017 Remi Collet <remi@fedoraproject.org> - 2.6.0-4
+- fix FTBFS from Koschei, add patch for PHP 7.2 from
+ https://github.com/zendframework/zend-barcode/pull/36
+
+* Thu Feb 18 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+- raise dependency on zend-stdlib ^2.7
+- raise dependency on zend-servicemanager ^2.7.5
+
+* Thu Aug 6 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-2
+- add optional dependency on zendframework/zendpdf
+
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- initial package