summaryrefslogtreecommitdiffstats
path: root/php-laminas-authentication.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-14 14:46:32 +0100
committerRemi Collet <remi@remirepo.net>2020-01-14 14:46:32 +0100
commitdffc811267cf615cc52f4bc3981dc46f4c417f69 (patch)
tree776789ccce640628da6eb51702cbbbb73e4ca744 /php-laminas-authentication.spec
duplicate ZF
Diffstat (limited to 'php-laminas-authentication.spec')
-rw-r--r--php-laminas-authentication.spec223
1 files changed, 223 insertions, 0 deletions
diff --git a/php-laminas-authentication.spec b/php-laminas-authentication.spec
new file mode 100644
index 0000000..7a27f86
--- /dev/null
+++ b/php-laminas-authentication.spec
@@ -0,0 +1,223 @@
+# remirepo/Fedora spec file for php-zendframework-zend-authentication
+#
+# Copyright (c) 2015-2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 1f379f6384fca34b3bfe94d953abd65e9e7ee746
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-authentication
+%global php_home %{_datadir}/php
+%global library Authentication
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.7.0
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-ctype
+BuildRequires: php-date
+BuildRequires: php-hash
+BuildRequires: php-pcre
+BuildRequires: php-spl
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-crypt": "^2.6 || ^3.2.1",
+# "zendframework/zend-db": "^2.8.2",
+# "zendframework/zend-http": "^2.7",
+# "zendframework/zend-ldap": "^2.8",
+# "zendframework/zend-session": "^2.8",
+# "zendframework/zend-uri": "^2.5.2",
+# "zendframework/zend-validator": "^2.10.1"
+BuildRequires: (php-autoloader(%{gh_owner}/zend-db) >= 2.8.2 with php-autoloader(%{gh_owner}/zend-db) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-crypt) >= 2.6 with php-autoloader(%{gh_owner}/zend-crypt) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-http) >= 2.7 with php-autoloader(%{gh_owner}/zend-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-ldap) >= 2.8 with php-autoloader(%{gh_owner}/zend-ldap) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-session) >= 2.8 with php-autoloader(%{gh_owner}/zend-session) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-uri) >= 2.5.2 with php-autoloader(%{gh_owner}/zend-uri) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+# remirepo:18
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
+BuildRequires: php-autoloader(%{gh_owner}/zend-db) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-db) >= 2.8.2
+BuildRequires: php-autoloader(%{gh_owner}/zend-crypt) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-crypt) >= 2.6
+BuildRequires: php-autoloader(%{gh_owner}/zend-http) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-http) >= 2.7
+BuildRequires: php-autoloader(%{gh_owner}/zend-ldap) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-ldap) >= 2.8
+BuildRequires: php-autoloader(%{gh_owner}/zend-session) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-session) >= 2.8
+BuildRequires: php-autoloader(%{gh_owner}/zend-uri) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-uri) >= 2.5.2
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1
+%endif
+# remirepo:1
+%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
+%global phpunit %{_bindir}/phpunit7
+# remirepo:3
+%else
+%global phpunit %{_bindir}/phpunit6
+%endif
+BuildRequires: %{phpunit}
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0",
+# "zendframework/zend-stdlib": "^3.2.1"
+Requires: php(language) >= 5.6
+%if ! %{bootstrap}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+# From composer, "suggest": {
+# "zendframework/zend-db": "Zend\\Db component",
+# "zendframework/zend-crypt": "Zend\\Crypt component",
+# "zendframework/zend-http": "Zend\\Http component",
+# "zendframework/zend-ldap": "Zend\\Ldap component",
+# "zendframework/zend-session": "Zend\\Session component",
+# "zendframework/zend-uri": "Zend\\Uri component",
+# "zendframework/zend-validator": "Zend\\Validator component"
+Suggests: php-autoloader(%{gh_owner}/zend-db)
+Suggests: php-autoloader(%{gh_owner}/zend-crypt)
+Suggests: php-autoloader(%{gh_owner}/zend-http)
+Suggests: php-autoloader(%{gh_owner}/zend-ldap)
+Suggests: php-autoloader(%{gh_owner}/zend-session)
+Suggests: php-autoloader(%{gh_owner}/zend-uri)
+Suggests: php-autoloader(%{gh_owner}/zend-validator)
+# remirepo:4
+%else
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+%endif
+%endif
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 2.5.2
+Requires: php-ctype
+Requires: php-date
+Requires: php-hash
+Requires: php-pcre
+Requires: php-spl
+
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+The Zend\Authentication component provides an API for authentication and
+includes concrete authentication adapters for common use case scenarios.
+
+Documentation: https://zendframework.github.io/%{gh_project}/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Generate autoloader
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Zend/Stdlib/autoload.php',
+]);
+\Fedora\Autoloader\Dependencies::optional([
+ '%{php_home}/Zend/Db/autoload.php',
+ '%{php_home}/Zend/Crypt/autoload.php',
+ '%{php_home}/Zend/Http/autoload.php',
+ '%{php_home}/Zend/Ldap/autoload.php',
+ '%{php_home}/Zend/Session/autoload.php',
+ '%{php_home}/Zend/Uri/autoload.php',
+ '%{php_home}/Zend/Validator/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/
+cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+EOF
+
+ret=0
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/Zend/%{library}
+
+
+%changelog
+* Wed May 15 2019 Remi Collet <remi@remirepo.net> - 2.7.0-1
+- update to 2.7.0
+- raise dependency on zend-stdlib 3.2.1
+- use range dependencies
+
+* Mon Apr 16 2018 Remi Collet <remi@remirepo.net> - 2.6.0-2
+- update to 2.6.0
+- raise dependency on PHP 5.6
+- raise dependency on zend-stdlib 3.1
+- use phpunit7
+
+* Mon Dec 11 2017 Remi Collet <remi@remirepo.net> - 2.5.3-4
+- switch from zend-loader to fedora/autoloader
+
+* Sun Feb 28 2016 Remi Collet <remi@fedoraproject.org> - 2.5.3-1
+- update to 2.5.3
+- raise dependency on zend-stdlib ~2.7
+
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- initial package