summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-23 14:54:29 +0200
committerRemi Collet <remi@php.net>2022-06-23 14:54:29 +0200
commite7b1a388f5d71c76b937bc43285b522ad6ff0649 (patch)
treee9eeb445e65bb2cb6bfdee3347c4d379a4a7f038
parentd9ed601883ea91d3ca39247ddfce56c2adab13d5 (diff)
v2.11.0
-rw-r--r--composer.json8
-rw-r--r--php-laminas-authentication.spec11
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index d3e77c3..6e5efc3 100644
--- a/composer.json
+++ b/composer.json
@@ -16,6 +16,9 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ },
"sort-packages": true,
"platform": {
"php": "7.3.99"
@@ -26,7 +29,7 @@
"laminas/laminas-stdlib": "^3.2.1"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-coding-standard": "~2.3.0",
"laminas/laminas-crypt": "^2.6 || ^3.2.1",
"laminas/laminas-db": "^2.13",
"laminas/laminas-http": "^2.15.0",
@@ -54,9 +57,6 @@
}
},
"autoload-dev": {
- "files": [
- "test/autoload.php"
- ],
"psr-4": {
"LaminasTest\\Authentication\\": "test/"
}
diff --git a/php-laminas-authentication.spec b/php-laminas-authentication.spec
index 3a4c225..832de34 100644
--- a/php-laminas-authentication.spec
+++ b/php-laminas-authentication.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7308db03e11147fbf567b5004ac428bdaba267f9
+%global gh_commit 51815691d862b82b749a4aa9c4f6ec078d579f74
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-authentication
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.10.1
+Version: 2.11.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -45,7 +45,7 @@ BuildRequires: php-spl
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-coding-standard": "~2.3.0",
# "laminas/laminas-crypt": "^2.6 || ^3.2.1",
# "laminas/laminas-db": "^2.13",
# "laminas/laminas-http": "^2.15",
@@ -201,7 +201,7 @@ exit (class_exists("\\Zend\\%{library}\\Result") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -225,6 +225,9 @@ exit $ret
%changelog
+* Thu Jun 23 2022 Remi Collet <remi@remirepo.net> - 2.11.0-1
+- update to 2.11.0
+
* Thu Mar 10 2022 Remi Collet <remi@remirepo.net> - 2.10.1-1
- update to 2.10.1