summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-18 07:11:41 +0100
committerRemi Collet <remi@remirepo.net>2021-03-18 07:11:41 +0100
commit9f7beaa28f159f7c6380347260deb3dce72feaf8 (patch)
tree2597aa1d42ebcc7d02e367b4991d9faf531c5306
parent8d3139286dc36b70cb7ff73de9ab5b372496d0b6 (diff)
update to 2.8.0
raise dependency on PHP 7.3 switch to phpunit9
-rw-r--r--composer.json12
-rw-r--r--php-laminas-authentication.spec30
2 files changed, 23 insertions, 19 deletions
diff --git a/composer.json b/composer.json
index 38d3d63..60665cd 100644
--- a/composer.json
+++ b/composer.json
@@ -19,13 +19,9 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "2.7.x-dev",
- "dev-develop": "2.8.x-dev"
- }
},
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-stdlib": "^3.2.1",
"laminas/laminas-zendframework-bridge": "^1.0"
},
@@ -38,7 +34,9 @@
"laminas/laminas-session": "^2.8",
"laminas/laminas-uri": "^2.5.2",
"laminas/laminas-validator": "^2.10.1",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
+ "phpunit/phpunit": "^9.3",
+ "psalm/plugin-phpunit": "^0.15.1",
+ "vimeo/psalm": "^4.6"
},
"suggest": {
"laminas/laminas-crypt": "Laminas\\Crypt component",
@@ -73,6 +71,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-authentication": "self.version"
+ "zendframework/zend-authentication": "^2.7.0"
}
}
diff --git a/php-laminas-authentication.spec b/php-laminas-authentication.spec
index b48e071..863ca39 100644
--- a/php-laminas-authentication.spec
+++ b/php-laminas-authentication.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-authentication
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 53505e07858d243792b96be763456f786d953501
+%global gh_commit 0b77d353a3a039d65c15318c98dd055d62f010b6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-authentication
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.7.0
+Version: 2.8.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-hash
@@ -73,17 +73,17 @@ BuildRequires: php-laminas-session
BuildRequires: php-laminas-uri
BuildRequires: php-laminas-validator
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.2
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-stdlib": "^3.2.1",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -119,11 +119,12 @@ Requires: php-hash
Requires: php-pcre
Requires: php-spl
+# remirepo:2
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 2.7.0-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 2.7.1
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -198,10 +199,10 @@ exit (class_exists("\\Zend\\%{library}\\Result") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} || ret=1
fi
done
exit $ret
@@ -221,6 +222,11 @@ exit $ret
%changelog
+* Thu Mar 18 2021 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- update to 2.8.0
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Tue Jan 14 2020 Remi Collet <remi@remirepo.net> - 2.8.0-1
- switch to Laminas