summaryrefslogtreecommitdiffstats
path: root/php-kdyby-events.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-09 10:24:03 +0100
committerRemi Collet <remi@remirepo.net>2017-11-09 10:24:03 +0100
commitbc326a92dc11f2485e3a73eaf2fbbd4070f67fdb (patch)
tree7c227c4cff6b217d43294439de0dd83a30136d03 /php-kdyby-events.spec
parentd44e64963089543c103331f3ff7f65174c1aaac5 (diff)
fix FTBFS from Koschei, add patch for PHP 7.2
Diffstat (limited to 'php-kdyby-events.spec')
-rw-r--r--php-kdyby-events.spec10
1 files changed, 8 insertions, 2 deletions
diff --git a/php-kdyby-events.spec b/php-kdyby-events.spec
index d22e69b..bba9327 100644
--- a/php-kdyby-events.spec
+++ b/php-kdyby-events.spec
@@ -18,7 +18,7 @@
Name: php-%{gh_owner}-%{gh_project}
Version: 3.1.0
-%global specrel 1
+%global specrel 2
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Events for Nette Framework
@@ -31,6 +31,8 @@ Source1: makesrc.sh
# Autoloader
Source2: %{name}-autoload.php
+Patch0: %{name}-php72.patch
+
BuildArch: noarch
%if %{with_tests}
BuildRequires: php-pcre
@@ -99,6 +101,7 @@ To use this library, you just have to add, in your project:
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
cp %{SOURCE2} src/%{ns_project}/autoload.php
@@ -138,7 +141,7 @@ php -r 'require "vendor/autoload.php";'
: Run test suite in sources tree
ret=0
# PHP 7.2: https://github.com/Kdyby/Events/issues/108
-for cmd in php php56 php70 php71; do
+for cmd in php php56 php70 php71 php72; do
if which $cmd; then
$cmd %{_bindir}/nette-tester --colors 0 -p $cmd -C tests/KdybyTests -s || ret=1
fi
@@ -158,6 +161,9 @@ exit $ret
%changelog
+* Thu Nov 9 2017 Remi Collet <remi@remirepo.net> - 3.1.0-2
+- fix FTBFS from Koschei, add patch for PHP 7.2
+
* Mon May 15 2017 Remi Collet <remi@remirepo.net> - 3.1.0-1
- Update to 3.1.0
- add dependency on nette/reflection