summaryrefslogtreecommitdiffstats
path: root/php-justinrainbow-json-schema5.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-23 09:40:15 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-23 09:40:15 +0100
commitc7c2cafe3ded3a303a12cd6078f77893c09b554c (patch)
tree8b188ccbc30148acfae3db8ce30644fd22fd280a /php-justinrainbow-json-schema5.spec
parent9041633e57b7a54508e38ff6fd995172b1201205 (diff)
v5.2.0
Diffstat (limited to 'php-justinrainbow-json-schema5.spec')
-rw-r--r--php-justinrainbow-json-schema5.spec17
1 files changed, 14 insertions, 3 deletions
diff --git a/php-justinrainbow-json-schema5.spec b/php-justinrainbow-json-schema5.spec
index bf60d84..2bcf0cc 100644
--- a/php-justinrainbow-json-schema5.spec
+++ b/php-justinrainbow-json-schema5.spec
@@ -6,14 +6,14 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 48817e5f95c9d29e11513f12e43cc0223fa5eb6c
+%global gh_commit e3c9bccdc38bbd09bcac0131c00f3be58368b416
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner justinrainbow
%global gh_project json-schema
%global php_home %{_datadir}/php
%global with_tests 0%{!?_without_tests:1}
%global major 5
-%global minor 1.0
+%global minor 2.0
# Some sample files, only used for tests
@@ -59,6 +59,7 @@ BuildRequires: php-spl
# From composer.json, "require-dev": {
# "json-schema/JSON-Schema-Test-Suite": "1.2.0",
# "phpunit/phpunit": "^4.8.22",
+# "friendsofphp/php-cs-fixer": "^2.1",
# "phpdocumentor/phpdocumentor": "~2"
BuildRequires: php-composer(phpunit/phpunit) >= 4.8.22
# Autoloader
@@ -104,7 +105,8 @@ Autoloader: %{php_home}/JsonSchema%{major}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit} -a 1
-%patch0 -p0 -b .rpm
+%patch0 -p1 -b .rpm
+find src -name \*.rpm -delete -print
cp %{SOURCE2} src/JsonSchema/autoload.php
@@ -131,6 +133,9 @@ rm -rf %{buildroot}
: Library
mkdir -p %{buildroot}%{php_home}
cp -pr src/JsonSchema %{buildroot}%{php_home}/JsonSchema%{major}
+: Schemas
+mkdir -p %{buildroot}%{_datadir}/%{name}
+cp -pr dist %{buildroot}%{_datadir}/%{name}/dist
: Command
install -Dpm 0755 bin/validate-json %{buildroot}%{_bindir}/validate-json%{major}
@@ -145,6 +150,8 @@ require '%{buildroot}%{php_home}/JsonSchema%{major}/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('JsonSchema\\Tests\\', 'tests/');
EOF
+export BUILDROOT_SCHEMA=%{buildroot}
+
: Test the command
sed -e 's:%{php_home}:%{buildroot}%{php_home}:' \
bin/validate-json > bin/validate-json-test
@@ -186,9 +193,13 @@ rm -rf %{buildroot}
%doc *.md
%{_bindir}/validate-json%{major}
%{php_home}/JsonSchema%{major}
+%{_datadir}/%{name}
%changelog
+* Thu Mar 23 2017 Remi Collet <remi@remirepo.net> - 5.2.0-1
+- Update to 5.2.0
+
* Wed Feb 22 2017 Remi Collet <remi@fedoraproject.org> - 5.1.0-1
- update to 5.1.0