summaryrefslogtreecommitdiffstats
path: root/php-justinrainbow-json-schema5-makesrc.sh
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-16 10:22:59 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-16 10:22:59 +0100
commit992bd4a6fd5014369aca16c1a8a9372575e4bfe0 (patch)
tree745bc391810296c02006786c852823ee53a904e2 /php-justinrainbow-json-schema5-makesrc.sh
php-justinrainbow-json-schema5: 5.0.0 - New package
Diffstat (limited to 'php-justinrainbow-json-schema5-makesrc.sh')
-rwxr-xr-xphp-justinrainbow-json-schema5-makesrc.sh29
1 files changed, 29 insertions, 0 deletions
diff --git a/php-justinrainbow-json-schema5-makesrc.sh b/php-justinrainbow-json-schema5-makesrc.sh
new file mode 100755
index 0000000..e9f0fbc
--- /dev/null
+++ b/php-justinrainbow-json-schema5-makesrc.sh
@@ -0,0 +1,29 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+MAJOR=$(sed -n '/^%global major/{s/.* //;p}' $NAME.spec)
+MINOR=$(sed -n '/^%global minor/{s/.* //;p}' $NAME.spec)
+VERSION=$MAJOR.$MINOR
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."