summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-15 08:04:54 +0100
committerRemi Collet <remi@remirepo.net>2018-02-15 08:04:54 +0100
commit84b5be8553e7d9dcb9483143a221e098f02894e9 (patch)
treeab971edf8cdbfd139017f74454001eadaa442340
parentbd798569c522d945b4b1195cc1a63023321b118b (diff)
v5.2.7
-rw-r--r--composer.json12
-rw-r--r--php-justinrainbow-json-schema5.spec18
2 files changed, 16 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index 009c148..6e72ab9 100644
--- a/composer.json
+++ b/composer.json
@@ -41,7 +41,7 @@
"require-dev": {
"json-schema/JSON-Schema-Test-Suite": "1.2.0",
"friendsofphp/php-cs-fixer": "^2.1",
- "phpunit/phpunit": "^4.8.22"
+ "phpunit/phpunit": "^4.8.35"
},
"autoload": {
"psr-4": { "JsonSchema\\": "src/JsonSchema/" }
@@ -56,10 +56,10 @@
}
},
"scripts": {
- "test" : "vendor/bin/phpunit",
- "testOnly" : "vendor/bin/phpunit --colors --filter",
- "coverage" : "vendor/bin/phpunit --coverage-text",
- "style-check" : "vendor/bin/php-cs-fixer fix --dry-run --verbose --diff",
- "style-fix" : "vendor/bin/php-cs-fixer fix --verbose"
+ "test" : "phpunit",
+ "testOnly" : "phpunit --colors --filter",
+ "coverage" : "phpunit --coverage-text",
+ "style-check" : "php-cs-fixer fix --dry-run --verbose --diff",
+ "style-fix" : "php-cs-fixer fix --verbose"
}
}
diff --git a/php-justinrainbow-json-schema5.spec b/php-justinrainbow-json-schema5.spec
index 15cbf8b..ccb7f7b 100644
--- a/php-justinrainbow-json-schema5.spec
+++ b/php-justinrainbow-json-schema5.spec
@@ -1,19 +1,19 @@
# remirepo/fedora spec file for php-justinrainbow-json-schema5
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit d283e11b6e14c6f4664cf080415c4341293e5bbd
+%global gh_commit 8560d4314577199ba51bf2032f02cd1315587c23
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner justinrainbow
%global gh_project json-schema
%global php_home %{_datadir}/php
%global with_tests 0%{!?_without_tests:1}
%global major 5
-%global minor 2.6
+%global minor 2.7
# Some sample files, only used for tests
@@ -31,10 +31,9 @@ Name: php-%{gh_owner}-%{gh_project}%{major}
Version: %{major}.%{minor}
Release: 1%{?dist}
Summary: A library to validate a json schema
-
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
+
# git snapshot to get upstream test suite
Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: https://github.com/%{ts_owner}/%{ts_project}/archive/%{ts_commit}/%{ts_project}-%{ts_version}-%{ts_short}.tar.gz
@@ -58,8 +57,8 @@ BuildRequires: php-spl
# From composer.json, "require-dev": {
# "json-schema/JSON-Schema-Test-Suite": "1.2.0",
# "friendsofphp/php-cs-fixer": "^2.1",
-# "phpunit/phpunit": "^4.8.22"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.8.22
+# "phpunit/phpunit": "^4.8.35"
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8.35
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
# For composer schema
@@ -158,7 +157,7 @@ php bin/validate-json-test \
: Upstream test suite
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php70 php71 php72; do
if which $cmd; then
$cmd -d memory_limit=1G %{_bindir}/phpunit -d memory_limit=1G --verbose || ret=1
fi
@@ -180,6 +179,9 @@ exit $ret
%changelog
+* Thu Feb 15 2018 Remi Collet <remi@remirepo.net> - 5.2.7-1
+- Update to 5.2.7
+
* Sun Oct 22 2017 Remi Collet <remi@remirepo.net> - 5.2.6-1
- Update to 5.2.6