summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-29 08:44:04 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-29 08:44:04 +0200
commit1e0268e1eb2399dc0e69eda1d06d5d3a5d0b4bcf (patch)
tree04b102db5289e9f1158291a50f8935c1eb731332
parent83d3b4fff1c951d0bb0abd07b3874851464baabb (diff)
v2.0.1
-rw-r--r--composer.json59
-rw-r--r--php-justinrainbow-json-schema.spec11
2 files changed, 66 insertions, 4 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..2c92cc1
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,59 @@
+{
+ "name": "justinrainbow/json-schema",
+ "description": "A library to validate a json schema.",
+ "version": "2.0.1",
+ "keywords": ["json", "schema"],
+ "homepage": "https://github.com/justinrainbow/json-schema",
+ "type": "library",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Bruno Prieto Reis",
+ "email": "bruno.p.reis@gmail.com"
+ },
+ {
+ "name": "Justin Rainbow",
+ "email": "justin.rainbow@gmail.com"
+ },
+ {
+ "name": "Igor Wiedler",
+ "email": "igor@wiedler.ch"
+ },
+ {
+ "name": "Robert Schönthal",
+ "email": "seroscho@googlemail.com"
+ }
+ ],
+ "repositories": [{
+ "type": "package",
+ "package": {
+ "name": "json-schema/JSON-Schema-Test-Suite",
+ "version": "1.1.0",
+ "source": {
+ "url": "https://github.com/json-schema/JSON-Schema-Test-Suite",
+ "type": "git",
+ "reference": "1.1.0"
+ }
+ }
+ }],
+ "require": {
+ "php": ">=5.3.3"
+ },
+ "require-dev": {
+ "json-schema/JSON-Schema-Test-Suite": "1.1.0",
+ "phpunit/phpunit": "^4.8.22",
+ "phpdocumentor/phpdocumentor": "~2"
+ },
+ "autoload": {
+ "psr-4": { "JsonSchema\\": "src/JsonSchema/" }
+ },
+ "autoload-dev": {
+ "psr-4": { "JsonSchema\\Tests\\": "tests/JsonSchema/Tests/" }
+ },
+ "bin": ["bin/validate-json"],
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.0.x-dev"
+ }
+ }
+}
diff --git a/php-justinrainbow-json-schema.spec b/php-justinrainbow-json-schema.spec
index 9921ce1..617664e 100644
--- a/php-justinrainbow-json-schema.spec
+++ b/php-justinrainbow-json-schema.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit f1f874d2c0eb546553290f56655c755f69cbaaa7
+%global gh_commit 9ef71fdf8aa59a93977446468fc718ea01115a83
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner justinrainbow
%global gh_project json-schema
@@ -16,7 +16,7 @@
# Some sample files, only used for tests
# "json-schema/JSON-Schema-Test-Suite": "1.1.0",
%global ts_commit 4eaaea8711d49656089643baeac4d32a01c1fce2
-%global ts_short %(c=%{gh_commit}; echo ${c:0:7})
+%global ts_short %(c=%{ts_commit}; echo ${c:0:7})
%global ts_owner json-schema
%global ts_project JSON-Schema-Test-Suite
%global ts_version 1.1.0
@@ -24,7 +24,7 @@
%global eolv1 0
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.0.0
+Version: 2.0.1
Release: 1%{?dist}
Summary: A library to validate a json schema
@@ -33,7 +33,7 @@ License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
# git snapshot to get upstream test suite
Source0: %{name}-%{version}-%{gh_short}.tgz
-Source1: https://github.com/%{ts_owner}/%{ts_project}/archive/%{ts_commit}/%{ts_project}-%{ts_version}-%{gh_short}.tar.gz
+Source1: https://github.com/%{ts_owner}/%{ts_project}/archive/%{ts_commit}/%{ts_project}-%{ts_version}-%{ts_short}.tar.gz
Source2: %{name}-autoload.php
Source3: %{name}-makesrc.sh
@@ -185,6 +185,9 @@ rm -rf %{buildroot}
%changelog
+* Fri Apr 29 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- update to 2.0.1
+
* Fri Apr 15 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
- initial package, version 2.0.0