summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-17 10:53:44 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-17 10:53:44 +0100
commitebe248a4e1b5e8d4c2ec8dc2283df184a7c68a92 (patch)
tree2a542b31d171e11491bb113ae2938ab5d0998a8a
php-JsonSchema: import from rawhide
-rw-r--r--php-JsonSchema.spec91
1 files changed, 91 insertions, 0 deletions
diff --git a/php-JsonSchema.spec b/php-JsonSchema.spec
new file mode 100644
index 0000000..4eb441f
--- /dev/null
+++ b/php-JsonSchema.spec
@@ -0,0 +1,91 @@
+%global lib_name JsonSchema
+%global github_name json-schema
+
+%global php_min_ver 5.3.0
+
+Name: php-%{lib_name}
+Version: 1.2.2
+Release: 2%{?dist}
+Summary: PHP implementation of JSON schema
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/justinrainbow/%{github_name}
+Source0: %{url}/archive/%{version}.tar.gz
+
+BuildArch: noarch
+# Test build requires
+BuildRequires: php-common >= %{php_min_ver}
+BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
+# Test build requires: phpci
+BuildRequires: php-ctype
+BuildRequires: php-curl
+BuildRequires: php-json
+BuildRequires: php-pcre
+BuildRequires: php-spl
+%{?fedora:BuildRequires: php-filter}
+
+Requires: php-common >= %{php_min_ver}
+# phpci requires
+Requires: php-ctype
+Requires: php-curl
+Requires: php-json
+Requires: php-pcre
+Requires: php-spl
+%{?fedora:Requires: php-filter}
+
+%description
+A PHP implementation for validating JSON structures against a given schema.
+
+See http://json-schema.org for more details.
+
+
+%prep
+%setup -q -n %{github_name}-%{version}
+
+# Clean up unnecessary files
+find . -type f -name '.git*' -delete
+
+# Create PSR-0 autoloader for tests
+( cat <<'AUTOLOAD'
+<?php
+spl_autoload_register(function ($class) {
+ $src = str_replace('\\', '/', $class).'.php';
+ require_once $src;
+});
+AUTOLOAD
+) > autoload.php
+
+
+%build
+# Empty build section, nothing to build
+
+
+%install
+mkdir -p -m 755 %{buildroot}%{_datadir}/php
+cp -rp src/%{lib_name} %{buildroot}%{_datadir}/php/
+
+
+%check
+%{_bindir}/phpunit --bootstrap=autoload.php -d date.timezone="UTC" \
+ -d include_path="src:tests:.:/usr/share/pear" .
+
+
+%files
+%doc LICENSE README.md composer.json
+%{_datadir}/php/%{lib_name}
+
+
+%changelog
+* Sun Dec 9 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 1.2.2-2
+- Fixed failing Mock/Koji builds
+- Removed "docs" directory from %%doc
+
+* Sat Dec 8 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 1.2.2-1
+- Updated to upstream version 1.2.2
+- Added php-ctype require
+- Added PSR-0 autoloader for tests
+- Added %%check
+
+* Tue Nov 27 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 1.2.1-1
+- Initial package