summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-08-31 07:57:50 +0200
committerRemi Collet <fedora@famillecollet.com>2014-08-31 07:57:50 +0200
commitbf3a1a14dad935b383eceb1785b9ec071006439d (patch)
tree60b0cc52ffb35a73c7a26d0c573ec8b385a722d8
parent52a9193fbff49f8fc101cfe8da379a1d6c448780 (diff)
php-JsonSchema: sync with rawhide
-rw-r--r--php-JsonSchema-php-lt-5-4-0-compat.patch23
-rw-r--r--php-JsonSchema.spec14
2 files changed, 34 insertions, 3 deletions
diff --git a/php-JsonSchema-php-lt-5-4-0-compat.patch b/php-JsonSchema-php-lt-5-4-0-compat.patch
new file mode 100644
index 0000000..a63c44e
--- /dev/null
+++ b/php-JsonSchema-php-lt-5-4-0-compat.patch
@@ -0,0 +1,23 @@
+From 3973764636b93f1b94ea6842bdf2e780b2a59822 Mon Sep 17 00:00:00 2001
+From: Shawn Iwinski <siwinski@redhat.com>
+Date: Fri, 29 Aug 2014 22:41:25 -0400
+Subject: [PATCH] PHP < 5.4.0 compatibility for "--dump-schema"
+
+---
+ bin/validate-json | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/bin/validate-json b/bin/validate-json
+index 2f2fe44..8831a6e 100755
+--- a/bin/validate-json
++++ b/bin/validate-json
+@@ -218,7 +218,8 @@ $refResolver = new JsonSchema\RefResolver($retriever);
+ $refResolver->resolve($schema, $urlSchema);
+
+ if (isset($arOptions['--dump-schema'])) {
+- echo json_encode($schema, JSON_PRETTY_PRINT) . "\n";
++ $options = version_compare(PHP_VERSION, '5.4.0', '>=') ? JSON_PRETTY_PRINT : 0;
++ echo json_encode($schema, $options) . "\n";
+ exit();
+ }
+
diff --git a/php-JsonSchema.spec b/php-JsonSchema.spec
index 8b1d9c6..be7530f 100644
--- a/php-JsonSchema.spec
+++ b/php-JsonSchema.spec
@@ -24,7 +24,7 @@
Name: php-%{lib_name}
Version: %{github_version}
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: PHP implementation of JSON schema
Group: Development/Libraries
@@ -32,6 +32,10 @@ License: BSD
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+# PHP < 5.4.0 compatibility for "--dump-schema"
+# https://github.com/justinrainbow/json-schema/pull/109
+Patch0: %{name}-php-lt-5-4-0-compat.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
@@ -68,8 +72,9 @@ See http://json-schema.org for more details.
%prep
%setup -qn %{github_name}-%{github_commit}
-# Update bin file
-## Shebang
+%patch0 -p1
+
+# Update bin shebang
sed 's#/usr/bin/env php#%{_bindir}/php#' \
-i bin/validate-json
@@ -124,6 +129,9 @@ sed 's/colors\s*=\s*"true"/colors="false"/' phpunit.xml.dist > phpunit.xml
%changelog
+* Sat Aug 30 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.3.7-2
+- PHP < 5.4.0 compatibility patch instead of in-spec logic
+
* Fri Aug 29 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.3.7-1
- Updated to 1.3.7 (BZ #1133519)
- Added option to build without tests ("--without tests")