summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-07-08 08:03:35 +0200
committerRemi Collet <fedora@famillecollet.com>2013-07-08 08:03:35 +0200
commit37eed3dfa63173e76ab42556cc42f6fe920722fb (patch)
treeb020cd6594c2bc10fbf6280e1cdf2c38b5b0d710
parentfa365accca425e690dee0a641999622e98f944ac (diff)
php-JsonSchema: 1.3.2 (backport)
-rw-r--r--php-JsonSchema.spec26
1 files changed, 22 insertions, 4 deletions
diff --git a/php-JsonSchema.spec b/php-JsonSchema.spec
index 3c10d48..4d03260 100644
--- a/php-JsonSchema.spec
+++ b/php-JsonSchema.spec
@@ -1,7 +1,7 @@
%global github_owner justinrainbow
%global github_name json-schema
-%global github_version 1.3.1
-%global github_commit 40cb851130a4cdbff7f680b77f6979b0e785c544
+%global github_version 1.3.2
+%global github_commit 3ec2db504e7a79d6504ad8172a706adec5eec681
%global php_min_ver 5.3.0
@@ -21,20 +21,24 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# For tests
BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-pear(pear.phpunit.de/DbUnit)
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
+BuildRequires: php-pear(pear.phpunit.de/PHPUnit_Selenium)
+BuildRequires: php-pear(pear.phpunit.de/PHPUnit_Story)
+
# For tests: phpci
-BuildRequires: php-ctype
BuildRequires: php-curl
BuildRequires: php-json
+BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-filter
Requires: php(language) >= %{php_min_ver}
# phpci
-Requires: php-ctype
Requires: php-curl
Requires: php-json
+Requires: php-mbstring
Requires: php-pcre
Requires: php-spl
Requires: php-filter
@@ -72,6 +76,10 @@ cp -rp src/%{lib_name} %{buildroot}%{_datadir}/php/
%check
+# Remove empty tests
+rm -f tests/JsonSchema/Tests/Drafts/Draft3Test.php \
+ tests/JsonSchema/Tests/Drafts/Draft4Test.php
+
%{_bindir}/phpunit \
-d include_path="./src:./tests:.:%{pear_phpdir}" \
-d date.timezone="UTC" \
@@ -86,6 +94,16 @@ cp -rp src/%{lib_name} %{buildroot}%{_datadir}/php/
%changelog
+* Mon Jul 8 2013 Remi Collet <remi@fedoraproject.org> - 1.3.2-1
+- backport 1.3.2 for remi repo.
+
+* Fri Jul 05 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.3.2-1
+- Updated to 1.3.2
+- Added php-pear(pear.phpunit.de/DbUnit), php-pear(pear.phpunit.de/PHPUnit_Selenium),
+ and php-pear(pear.phpunit.de/PHPUnit_Story) build requires
+- Removed php-ctype require
+- Added php-mbstring require
+
* Sat Mar 23 2013 Remi Collet <remi@fedoraproject.org> - 1.3.1-1
- backport 1.3.1 for remi repo.