summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-22 15:04:17 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-22 15:05:09 +0200
commit35b00159702efecfd9b56657baa35f1764e84e7a (patch)
tree40228bfa6bc3f70a767d5221a060d9da27869265
parentbdf09b1d98c63c09623b96af43d34c65836849cf (diff)
php-phpmd-PHP-PMD: 2.3.1
php-JsonSchema: 1.5.0
-rw-r--r--php-JsonSchema.spec10
1 files changed, 5 insertions, 5 deletions
diff --git a/php-JsonSchema.spec b/php-JsonSchema.spec
index e58df67..5321f73 100644
--- a/php-JsonSchema.spec
+++ b/php-JsonSchema.spec
@@ -12,8 +12,8 @@
%global github_owner justinrainbow
%global github_name json-schema
-%global github_version 1.4.4
-%global github_commit 8dc9b9d85ab639ca60ab4608b34c1279d6ae7bce
+%global github_version 1.5.0
+%global github_commit a4bee9f4b344b66e0a0d96c7afae1e92edf385fe
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global php_min_ver 5.3.2
@@ -41,7 +41,7 @@ BuildArch: noarch
%if %{with_tests}
# For tests
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-phpunit-PHPUnit
+BuildRequires: php-composer(phpunit/phpunit) >= 3.7
# For tests: phpcompatinfo (computed from v1.4.4)
BuildRequires: php-curl
BuildRequires: php-date
@@ -102,10 +102,10 @@ install -Dpm 0755 bin/validate-json %{buildroot}%{_bindir}/validate-json
rm -rf tests/%{lib_name}/Tests/Drafts
mkdir vendor
-cat <<EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require '%{buildroot}%{phpdir}/%{lib_name}/autoload.php';
-\$fedoraClassLoader->addPrefix('%{lib_name}\\\\Tests\\\\', realpath(__DIR__.'/../tests'));
+$fedoraClassLoader->addPrefix('%{lib_name}\\Tests\\', realpath(__DIR__.'/../tests'));
EOF
%{_bindir}/phpunit --verbose