summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-26 09:58:08 +0100
committerRemi Collet <remi@remirepo.net>2020-10-26 09:58:08 +0100
commita4464cbee7e611e50a8e2a66d64a8f107ab9a825 (patch)
treeb75fe428d918f04e69863cc56fcc8377192df07e
parent800ad4a42a85606f79bda942cc581df57ae21983 (diff)
raise dependency on PHP 7.0HEADmaster
raise dependency on nikic/php-parser 4.0 drop dependency on symfony-polyfill
-rw-r--r--php-jeremeamia-superclosure-autoload.php11
-rw-r--r--php-jeremeamia-superclosure.spec30
2 files changed, 18 insertions, 23 deletions
diff --git a/php-jeremeamia-superclosure-autoload.php b/php-jeremeamia-superclosure-autoload.php
index 53233e0..f5e12ea 100644
--- a/php-jeremeamia-superclosure-autoload.php
+++ b/php-jeremeamia-superclosure-autoload.php
@@ -3,12 +3,7 @@
require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('SuperClosure\\', __DIR__);
-\Fedora\Autoloader\Dependencies::required(array(
- '/usr/share/php/Symfony/Polyfill/autoload.php',
- array(
- '/usr/share/php/PhpParser4/autoload.php',
- '/usr/share/php/PhpParser3/autoload.php',
- '/usr/share/php/PhpParser2/autoload.php',
- '/usr/share/php/PhpParser/autoload.php',
-)));
+\Fedora\Autoloader\Dependencies::required([
+ '/usr/share/php/PhpParser4/autoload.php',
+]);
diff --git a/php-jeremeamia-superclosure.spec b/php-jeremeamia-superclosure.spec
index 1f29632..2b37bf7 100644
--- a/php-jeremeamia-superclosure.spec
+++ b/php-jeremeamia-superclosure.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-jeremeamia-superclosure
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -19,7 +19,7 @@
Name: php-%{pk_vendor}-%{pk_name}
Version: 2.4.0
-Release: 1%{?dist}
+Release: 7%{?dist}
Summary: Serialize Closure objects, including their context and binding
License: MIT
@@ -31,13 +31,11 @@ Source1: makesrc.sh
Source2: %{name}-autoload.php
BuildArch: noarch
-BuildRequires: php(language) >= 5.4
+BuildRequires: php(language) >= 7.0
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(nikic/php-parser) >= 1.4 with php-composer(nikic/php-parser) < 5)
-BuildRequires: (php-composer(symfony/polyfill-php56) >= 1.0 with php-composer(symfony/polyfill-php56) < 2)
+BuildRequires: (php-composer(nikic/php-parser) >= 4.0 with php-composer(nikic/php-parser) < 5)
%else
-BuildRequires: php-nikic-php-parser3
-BuildRequires: php-symfony-polyfill
+BuildRequires: php-nikic-php-parser4
%endif
# From composer.json, "require-dev": {
# "phpunit/phpunit": "^4.0|^5.0",
@@ -50,13 +48,11 @@ BuildRequires: php-composer(fedora/autoloader)
# "nikic/php-parser": "^1.2|^2.0|^3.0|^4.0",
# "symfony/polyfill-php56": "^1.0"
# php-parser 1.4 for autoloader
-Requires: php(language) >= 5.4
+Requires: php(language) >= 7.0
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(nikic/php-parser) >= 1.4 with php-composer(nikic/php-parser) < 5)
-Requires: (php-composer(symfony/polyfill-php56) >= 1.0 with php-composer(symfony/polyfill-php56) < 2)
+Requires: (php-composer(nikic/php-parser) >= 4.0 with php-composer(nikic/php-parser) < 5)
%else
-Requires: php-nikic-php-parser3
-Requires: php-symfony-polyfill
+Requires: php-nikic-php-parser4
%endif
# From phpcompatifo report for 2.1.0
Requires: php-hash
@@ -73,8 +69,7 @@ Provides: php-composer(%{pk_vendor}/%{pk_name}) = %{version}
Even though serializing closures is "not allowed" by PHP,
the SuperClosure library makes it possible
-To use this library, you just have to add, in your project:
- require-once '%{_datadir}/php/%{namespace}/autoload.php';
+Autoloader: %{_datadir}/php/%{namespace}/autoload.php
%prep
@@ -103,7 +98,7 @@ EOF
: Run the test suite
ret=0
-for cmd in php php70 php71 php72; do
+for cmd in php php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit || ret=1
fi
@@ -119,6 +114,11 @@ exit $ret
%changelog
+* Mon Oct 26 2020 Remi Collet <remi@remirepo.net> - 2.4.0-7
+- raise dependency on PHP 7.0
+- raise dependency on nikic/php-parser 4.0
+- drop dependency on symfony-polyfill
+
* Thu Mar 22 2018 Remi Collet <remi@remirepo.net> - 2.4.0-1
- update to 2.4.0
- use range dependencies on F27+ else package names