summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--composer.json31
-rw-r--r--php-jakubledl-dissect.spec1
4 files changed, 43 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..800a9b9
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,31 @@
+{
+ "name": "jakubledl/dissect",
+ "description": "Lexing and parsing in pure PHP",
+ "keywords": ["lexing", "parsing", "ast", "parser"],
+ "homepage": "https://github.com/jakubledl/dissect",
+ "license": "unlicense",
+ "authors": [
+ {
+ "name": "Jakub Lédl",
+ "email": "jakubledl@gmail.com"
+ }
+ ],
+
+ "require": {
+ "php": ">=5.3.3"
+ },
+
+ "require-dev": {
+ "symfony/console": "~2.1"
+ },
+
+ "suggest": {
+ "symfony/console": "for the command-line tool"
+ },
+
+ "bin": ["bin/dissect.php", "bin/dissect"],
+
+ "autoload": {
+ "psr-0": { "Dissect": ["src/"] }
+ }
+}
diff --git a/php-jakubledl-dissect.spec b/php-jakubledl-dissect.spec
index a86f8ea..36b417b 100644
--- a/php-jakubledl-dissect.spec
+++ b/php-jakubledl-dissect.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-jakubledl-dissect
#
# Fedora spec file for php-jakubledl-dissect
#