summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-30 16:16:34 +0100
committerRemi Collet <remi@remirepo.net>2018-01-30 16:16:34 +0100
commite6a0d86abc7264cf756e1fb8a7e74790a6abe8a2 (patch)
tree25c81bd45233e6a66ab13b81bd8553e5f9bbccdc
parent185319f079a1d9dea367aa844f93fe61a1efd21c (diff)
v0.6.0
-rw-r--r--Makefile2
-rw-r--r--php-icewind-streams-autoload.php7
-rw-r--r--php-icewind-streams.spec48
3 files changed, 21 insertions, 36 deletions
diff --git a/Makefile b/Makefile
index 91b0fd5..13af741 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
-include ../../common/Makefile
+include ../../../common/Makefile
diff --git a/php-icewind-streams-autoload.php b/php-icewind-streams-autoload.php
deleted file mode 100644
index ecbb3df..0000000
--- a/php-icewind-streams-autoload.php
+++ /dev/null
@@ -1,7 +0,0 @@
-<?php
-/* Autoloader for icewind/streams and its dependencies */
-
-require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
-
-\Fedora\Autoloader\Autoload::addPsr4('Icewind\\Streams\\', __DIR__);
-
diff --git a/php-icewind-streams.spec b/php-icewind-streams.spec
index dd52c26..3cd3d19 100644
--- a/php-icewind-streams.spec
+++ b/php-icewind-streams.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-icewind-streams
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
# Github information
-%global gh_commit 6bfd2fdbd99319f5e010d0a684409189a562cb1e
+%global gh_commit 851b822ac29724c88c546755f52f76bf953e574c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner icewind1991
%global gh_project Streams
@@ -19,7 +19,7 @@
%global ns_name Streams
Name: php-%{pk_vendor}-%{pk_name}
-Version: 0.5.2
+Version: 0.6.0
Release: 1%{?dist}
Summary: A set of generic stream wrappers
@@ -27,9 +27,7 @@ Group: Development/Libraries
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{url}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
-Source1: %{name}-autoload.php
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# For tests
BuildRequires: php(language) >= 5.3
@@ -55,14 +53,20 @@ Provides: php-composer(%{pk_vendor}/%{pk_name}) = %{version}
%description
Generic stream wrappers for php.
-To use this library, you just have to add, in your project:
- require-once '%{_datadir}/php/%{ns_vendor}/%{ns_name}/autoload.php';
+Autoloader: %{_datadir}/php/%{ns_vendor}/%{ns_name}/autoload.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-cp %{SOURCE1} src/autoload.php
+cat << 'EOF' | tee src/autoload.php
+<?php
+/* Autoloader for icewind/streams and its dependencies */
+
+require_once '%{_datadir}/php/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('Icewind\\Streams\\', __DIR__);
+EOF
+
%build
@@ -70,7 +74,6 @@ cp %{SOURCE1} src/autoload.php
%install
-rm -rf %{buildroot}
# Restore PSR-0 tree
mkdir -p %{buildroot}%{_datadir}/php/%{ns_vendor}
cp -pr src %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_name}
@@ -84,30 +87,16 @@ cd tests
echo "require '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_name}/autoload.php';" >> bootstrap.php
: Run the test suite
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit || ret=1
+ fi
+done
exit $ret
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENCE
%doc composer.json
@@ -117,6 +106,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jan 30 2018 Remi Collet <remi@remirepo.net> - 0.6.0-1
+- Update to 0.6.0
+
* Mon Dec 5 2016 Remi Collet <remi@fedoraproject.org> - 0.5.2-1
- update to 0.5.2