summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-01 17:12:09 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-01 17:12:09 +0200
commitc4644a29c48249b2683b60645bb039e619fb525c (patch)
treece09208fbee2bf019bed1b2b02c7a8dec4545c75
php-icewind-streams: 0.2.0 - New Package
-rw-r--r--LICENCE21
-rw-r--r--Makefile4
-rw-r--r--php-icewind-streams-autoload.php15
-rw-r--r--php-icewind-streams.spec108
4 files changed, 148 insertions, 0 deletions
diff --git a/LICENCE b/LICENCE
new file mode 100644
index 0000000..a194b91
--- /dev/null
+++ b/LICENCE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2015 Robin Appelman
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-icewind-streams-autoload.php b/php-icewind-streams-autoload.php
new file mode 100644
index 0000000..a0bcd01
--- /dev/null
+++ b/php-icewind-streams-autoload.php
@@ -0,0 +1,15 @@
+<?php
+/* Autoloader for icewind/streams and its dependencies */
+
+$vendorDir = '/usr/share/php';
+// Use Symfony autoloader
+if (!isset($fedoraClassLoader) || !($fedoraClassLoader instanceof \Symfony\Component\ClassLoader\ClassLoader)) {
+ if (!class_exists('Symfony\\Component\\ClassLoader\\ClassLoader', false)) {
+ require_once $vendorDir . '/Symfony/Component/ClassLoader/ClassLoader.php';
+ }
+
+ $fedoraClassLoader = new \Symfony\Component\ClassLoader\ClassLoader();
+ $fedoraClassLoader->register();
+}
+
+$fedoraClassLoader->addPrefix('Icewind\\Streams\\', dirname(dirname(__DIR__)));
diff --git a/php-icewind-streams.spec b/php-icewind-streams.spec
new file mode 100644
index 0000000..6252332
--- /dev/null
+++ b/php-icewind-streams.spec
@@ -0,0 +1,108 @@
+# remirepo spec/Fedora file for php-icewind-streams
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+# Github information
+%global gh_commit 5aae45f2ddd3d1a6e2a496dd5d1e7857bfeb605a
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner icewind1991
+%global gh_project Streams
+# Packagist information
+%global pk_vendor icewind
+%global pk_name streams
+# Namespace information
+%global ns_vendor Icewind
+%global ns_name Streams
+
+Name: php-%{pk_vendor}-%{pk_name}
+Version: 0.2.0
+Release: 1%{?dist}
+Summary: A set of generic stream wrappers
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{url}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source1: %{name}-autoload.php
+# https://github.com/icewind1991/Streams/issues/1
+Source2: https://raw.githubusercontent.com/icewind1991/Streams/master/LICENCE
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+# For tests
+BuildRequires: php(language) >= 5.3
+# From composer.json, "require-dev": {
+# "satooshi/php-coveralls": "dev-master"
+BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: php-composer(theseer/autoload)
+# Autoloader
+BuildRequires: php-composer(symfony/class-loader)
+
+# From composer.json, "require": {
+# "php": ">=5.3"
+Requires: php(language) >= 5.3
+# From phpcompatinfo report for version 0.2.0
+Requires: php-spl
+# Autoloader
+Requires: php-composer(symfony/class-loader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_name}) = %{version}
+
+
+%description
+Generic stream wrappers for php.
+
+To use this library, you just have to add, in your project:
+ require-once '%{_datadir}/php/%{ns_vendor}/%{ns_name}/autoload.php';
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+cp %{SOURCE1} src/autoload.php
+cp %{SOURCE2} LICENSE
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+rm -rf %{buildroot}
+# Restore PSR-0 tree
+mkdir -p %{buildroot}%{_datadir}/php/%{ns_vendor}
+cp -pr src %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_name}
+
+
+
+%check
+cd tests
+: Generate a simple autoloader for test suite
+%{_bindir}/phpab --output bootstrap.php .
+echo "require '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_name}/autoload.php';" >> bootstrap.php
+
+: Run the test suite
+%{_bindir}/phpunit --verbose
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc *.md
+%dir %{_datadir}/php/%{ns_vendor}
+ %{_datadir}/php/%{ns_vendor}/%{ns_name}
+
+
+%changelog
+* Tue Sep 1 2015 Remi Collet <remi@fedoraproject.org> - 0.2.0-1
+- initial package, version 0.2.0 \ No newline at end of file