summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-09-13 08:29:04 +0200
committerRemi Collet <fedora@famillecollet.com>2014-09-13 08:29:04 +0200
commit47d11df26d5c46df259868c768718a20817e05a9 (patch)
tree613fee38426715358a23f1d656ac00437a36903e
php-horde-passwd: 5.0.2 - New package
-rw-r--r--.php-horde-passwd.spec.kate-swpbin0 -> 314 bytes
-rw-r--r--Makefile4
-rw-r--r--php-horde-passwd.spec186
3 files changed, 190 insertions, 0 deletions
diff --git a/.php-horde-passwd.spec.kate-swp b/.php-horde-passwd.spec.kate-swp
new file mode 100644
index 0000000..ed20eb1
--- /dev/null
+++ b/.php-horde-passwd.spec.kate-swp
Binary files differ
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-horde-passwd.spec b/php-horde-passwd.spec
new file mode 100644
index 0000000..c3461fc
--- /dev/null
+++ b/php-horde-passwd.spec
@@ -0,0 +1,186 @@
+# spec file for php-horde-turba
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?__pear: %global __pear %{_bindir}/pear}
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%global pear_name passwd
+%global pear_channel pear.horde.org
+# disabled as not ready
+%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+
+Name: php-horde-passwd
+Version: 5.0.2
+Release: 1%{?dist}
+Summary: Horde password changing application
+
+Group: Development/Libraries
+License: GPLv2
+URL: http://www.horde.org/apps/turba
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: gettext
+BuildRequires: php(language) >= 5.3.0
+BuildRequires: php-pear(PEAR) >= 1.7.0
+BuildRequires: php-channel(%{pear_channel})
+BuildRequires: php-pear(%{pear_channel}/Horde_Role) >= 1.0.0
+%if %{with_tests}
+BuildRequires: php-pear(%{pear_channel}/Horde_Test) >= 2.1.0
+%endif
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+
+# Web stuff
+Requires: mod_php
+Requires: httpd
+# From package.xml required
+Requires: php(language) >= 5.3.0
+Requires: php-gettext
+Requires: php-pear(PEAR) >= 1.7.0
+Requires: php-channel(%{pear_channel})
+Requires: php-pear(%{pear_channel}/horde) >= 5.0.0
+Requires: php-pear(%{pear_channel}/horde) < 6.0.0
+Requires: php-pear(%{pear_channel}/Horde_Auth) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Auth) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Core) >= 2.11.0
+Requires: php-pear(%{pear_channel}/Horde_Core) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Exception) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Injector) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Injector) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_Util) < 3.0.0
+Requires: php-pear(%{pear_channel}/Horde_View) >= 2.0.0
+Requires: php-pear(%{pear_channel}/Horde_View) < 3.0.0
+# From package.xml optional
+Requires: php-ldap
+Requires: php-soap
+# From phpcompatinfo report for version 5.0.2
+Requires: php-date
+Requires: php-pcre
+Requires: php-spl
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+
+%description
+An application to change any user passwords stored in various backends like
+SQL, LDAP, Kolab, passwd files etc.
+
+
+%prep
+%setup -q -c
+cat <<EOF >httpd.conf
+<DirectoryMatch %{pear_hordedir}/%{pear_name}/(config|lib|locale|scripts|templates)>
+ Deny from all
+</DirectoryMatch>
+EOF
+
+cd %{pear_name}-%{version}
+
+# Don't install .po and .pot files
+# Remove checksum for .mo, as we regenerate them
+sed -e '/%{pear_name}.po/d' \
+ -e '/htaccess/d' \
+ -e '/%{pear_name}.mo/s/md5sum=.*name=/name=/' \
+ ../package.xml >%{name}.xml
+touch -r ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+
+# Regenerate the locales
+for po in $(find locale -name \*.po)
+do
+ msgfmt $po -o $(dirname $po)/$(basename $po .po).mo
+done
+
+
+%install
+cd %{pear_name}-%{version}
+rm -rf %{buildroot}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+install -Dpm 644 %{name}.xml %{buildroot}%{pear_xmldir}/%{name}.xml
+
+# Install Apache configuration
+install -Dpm 0644 ../httpd.conf %{buildroot}%{_sysconfdir}/httpd/conf.d/%{name}.conf
+
+# Move configuration to /etc
+mkdir -p %{buildroot}%{_sysconfdir}/horde
+mv %{buildroot}%{pear_hordedir}/%{pear_name}/config \
+ %{buildroot}%{_sysconfdir}/horde/%{pear_name}
+ln -s %{_sysconfdir}/horde/%{pear_name} %{buildroot}%{pear_hordedir}/%{pear_name}/config
+
+# Locales
+for loc in locale/?? locale/??_??
+do
+ lang=$(basename $loc)
+ echo "%%lang(${lang%_*}) %{pear_hordedir}/%{pear_name}/$loc"
+done | tee ../%{pear_name}.lang
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%check
+%if %{with_tests}
+src=$(pwd)/%{pear_name}-%{version}
+cd %{pear_name}-%{version}/test/Passwd
+phpunit\
+ --include-path=$src/lib \
+ -d date.timezone=UTC \
+ .
+%else
+: Test disabled
+%endif
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files -f %{pear_name}.lang
+%defattr(-,root,root,-)
+%doc %{pear_docdir}/%{pear_name}
+%config(noreplace) %{_sysconfdir}/httpd/conf.d/%{name}.conf
+%attr(0770,apache,apache) %dir %{_sysconfdir}/horde/%{pear_name}
+%attr(0640,apache,apache) %config %{_sysconfdir}/horde/%{pear_name}/*.dist
+%attr(0660,apache,apache) %config(noreplace) %{_sysconfdir}/horde/%{pear_name}/*.php
+%attr(0660,apache,apache) %config %{_sysconfdir}/horde/%{pear_name}/*.xml
+%{pear_xmldir}/%{name}.xml
+%dir %{pear_hordedir}/%{pear_name}
+%{pear_hordedir}/%{pear_name}/*.php
+%{pear_hordedir}/%{pear_name}/config
+%{pear_hordedir}/%{pear_name}/js
+%{pear_hordedir}/%{pear_name}/lib
+%{pear_hordedir}/%{pear_name}/scripts
+%{pear_hordedir}/%{pear_name}/templates
+%{pear_hordedir}/%{pear_name}/themes
+%dir %{pear_hordedir}/%{pear_name}/locale
+%{pear_testdir}/%{pear_name}
+
+
+%changelog
+* Sat Sep 13 2014 Remi Collet <remi@fedoraproject.org> - 5.0.2-1
+- initial package \ No newline at end of file